[Oneiric] the Speech-dispatcher automatic killing related patch are dropped out with gnome-orca Oneiric version

Bug #859404 reported by Attila Hammer on 2011-09-26
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-orca (Ubuntu)
Undecided
Luke Yelavich

Bug Description

Dear Developers,

In prewious Orca releases if anybody enabled the kill X Server related hotkey (CTRL+ALT+BACKSPACE), Orca automaticaly kill and restart Speech-dispatcher process to prowide speech support without the user manual need running killall speech-dispatcher command. This possibility is awailable, if anybody enabling the CTRL+ALT+BACKSPACE key combination to kill X server in GNOME Control Center Keyboard Layout pane/preferences dialog part.
This patch is only an Ubuntu level patch, and doesn't reported this problem with upstream level. For example, with Orca master versions if the X server is killed and the user login a session, need manual killing Speech-dispatcher process and press a key to Speech-dispatcher begin talking again.
Now, this good working patch is dropped with Oneiric gnome-orca package.

I attached again Luke doed patch.
Possible putting back this patch the debian/patches directory in gnome-orca source package, or reporting Orca related this Speech-dispatcher killing related problem and attaching Luke patch?

For example, this patch are useful if need restarting lightdm login manager with service lightdm restart command.

Attila

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-orca 3.1.92-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-11.18-generic 3.0.4
Uname: Linux 3.0.0-11-generic i686
ApportVersion: 1.23-0ubuntu1
Architecture: i386
CasperVersion: 1.284
Date: Mon Sep 26 06:01:02 2011
LiveMediaBuild: Ubuntu 11.10 "Oneiric Ocelot" - Beta i386 (20110921.2)
PackageArchitecture: all
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=hu_HU.UTF-8
SourcePackage: gnome-orca
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

The attachment "This patch doed Luke to automaticaly restart Speech-dispatcher if the user killed X server with CTRL+ALT+BACKSPACE key combination" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Luke Yelavich (themuso) wrote :

Ok, I can confirm that this is needed. I'll re-add the patch as a work-around for now, but this needs to be fixed properly for P.

Changed in gnome-orca (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-orca - 3.2.0-0ubuntu1

---------------
gnome-orca (3.2.0-0ubuntu1) oneiric; urgency=low

  * New upstream release
    - General
      + Fix for bug 660091 - Unbound alternative keybindings in
        user-settings.conf prevent the preferences window from
        being shown
    - New and updated translations (THANKS EVERYONE!!!):
      + ca@valencia Catalan (Valencian) Carles Ferrando, Pau Iranzo
      + eu Basque Inaki Larranaga Murgoitio
      + hu Hungarian Attila Hammer, Gabor Kelemen
      + pt_BR Brazilian Portuguese Antonio Fernandes C. Neto
      + ru Russian Anatol Kamynin
      + sr Serbian Miroslav Nikolić
  * debian/watch: Updated
  * Re-introduce patch to kill speech-dispatcher on orca start, to work around
    issues with speech not working if a user has to kill their X session and
    log back in (LP: #859404) thanks to Attila Hammer for pointing this out
 -- Luke Yelavich <email address hidden> Tue, 27 Sep 2011 12:26:05 +1000

Changed in gnome-orca (Ubuntu):
status: In Progress → Fix Released

Hy Luke,

Thank you with your patch putting back.
You reporting this issue for upstream? Your openion have chance upstream
level will accepting your patch to Orca restart automaticaly
Speech-dispatcher if the X server kill the user and logging back?

Attila

Luke Yelavich (themuso) wrote :

I am not sure if this is an issue that needs solving upstream, as I don't even know the cause. I'll debug this further when I get a chance, and help with a proper fix, but just killing speech-dispatcher at every orca start is not the proper fix, because speech-dispatcher should have no problem being left running if a user logs in, kills X, logs in again, logs out and back in, etc.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers