[Natty] Loud synthetic voice at KDE login

Bug #755297 reported by Swâmi Petaramesh on 2011-04-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-orca (Ubuntu)
Undecided
Luke Yelavich

Bug Description

Seen on several systems :

After upgrade from Maverick to Natty Beta, at each KDE login, a loud synthetic voice says something hardly understandable (at least for me, being french) sounding like « I'm a human worker » (?)

Looks somewhat related : A konsole (terminal) window with a white background opens, stays empty, but stays open until manually closed (on all machines showing the "voice" behaviour).

Annoying.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: kubuntu-desktop 1.221
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic i686
Architecture: i386
CheckboxSubmission: 1ea6109db29b53f721a523a77b7f3abf
CheckboxSystem: d00f84de8a555815fa1c4660280da308
Date: Sat Apr 9 08:56:33 2011
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
ProcEnviron:
 LANGUAGE=fr_FR:fr:en_US:en
 PATH=(custom, user)
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
SourcePackage: kubuntu-meta
UpgradeStatus: Upgraded to natty on 2011-04-03 (6 days ago)

Related branches

Sometimes the "empty terminal window" stated above is not "empty" and looks (see attachment).

Dunno what it is and why it's there anyway, it wans't there previous to the natty upgrade, and now appears on each and every machine on which I did it...

Jonathan Thomas (echidnaman) wrote :

It looks like you have Orca, a text-to-speech daemon for people with sight disabilities, running on startup. This is either a bug with it or a configuration issue.

affects: kubuntu-meta (Ubuntu) → gnome-orca (Ubuntu)

@Jonathan : True. I have both kubuntu-desktop and ubuntu-desktop installed on said machine, and I discovered that this comes from speech-dispatcher, which is a dependancy of Orca, which in turn is a "recommend" of ubuntu-desktop.

The matter is that this Orca misbehaves in a KDE session. Well, I uninstalled it, having no need for it.

I've however seen the same behaviour on all 3 machines on which I have both Gnome and KDE. I never installed Orca manually on any, didn't event know what it's supposed to be, so I believed it auto-installed each time with ubuntu-desktop...

Ubuntu auto-installs much too many things one may not need (such as brltty for Braille terminals, I'm about sure that less than 0.5% of Ubuntu users ever need it or know what it is), such "accessibility" packages should definitely be optional rather than bloat and swell the default installation, where they are useless most of the times.

In no way is Orca configured to start automatically anywhere, unless you either explicitly configure your system to do so, or install Ubuntu using one of the accessibility profiles available at CD boot.

Well, I suppose that a bug tracking system is for reporting things that do not behave as they should :-}

I installed all my machines in a standard way and never selected any "accessibility profile". All the machines that I have on which both Ubuntu-desktop and kubuntu-desktop, once upgrades from Maverick to Natty, now find themselves have KDE startup open a terminal and talk with a synthetic voice.

I have no clue why this happens, I just report that it happens very reproductibly on all 3 machines I tested.

Luke Yelavich (themuso) wrote :

Ok there is a bug, thanks to upstrea for the patch that I've just been pointed to.

 affects ubuntu/gnome-orca
 status inprogress
 assignee themuso

Changed in gnome-orca (Ubuntu):
assignee: nobody → Luke Yelavich (themuso)
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-orca - 3.0.0-0ubuntu2

---------------
gnome-orca (3.0.0-0ubuntu2) natty; urgency=low

  * debian/patches/09_dont_start_in_kde.patch: Patch from upstream to
    make sure orca will only start automatically when run under GNOME
    (LP: #755297), fixes GNOME Bugzilla #647117
 -- Luke Yelavich <email address hidden> Mon, 11 Apr 2011 20:45:29 +1000

Changed in gnome-orca (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers