Add a 'Quit Orca' button

Bug #59531 reported by Henrik Nilsen Omma on 2006-09-08
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-desktop
Invalid
Undecided
Unassigned
gnome-orca (Ubuntu)
Medium
Unassigned

Bug Description

Orca is primarily designed with blind users in mind who tend to use keyboard shortcuts for computer navigation. The only implemented way of stopping Orca normally (other than 'killall orca') was with the Insert+q keybinding. This is fine for blind users who prefer that, but when we integrate Orca in the main Ubuntu desktop we also need an easily discoverable way for users to close it. This patch creates a 'Quit Orca' button which does that.

The next patch replaces the OK and Cancel buttons with a Close and Apply button. This is more useful because Orca does not use gconf and hence does not have instant apply. Magnification users have requested this change because when they tweak the magnifier settings it is much more useable this way.

(patches by Chris Jones)

Henrik Nilsen Omma (henrik) wrote :
Henrik Nilsen Omma (henrik) wrote :
Changed in gnome-desktop:
status: Unknown → Confirmed
Changed in gnome-orca:
importance: Undecided → Wishlist
status: Unconfirmed → In Progress
Changed in gnome-desktop:
status: Confirmed → Fix Released
Daniel Holbach (dholbach) wrote :

Need to check for Ubuntu release.

Changed in gnome-orca:
assignee: nobody → desktop-bugs
Daniel Holbach (dholbach) wrote :

Hum, I just checked the Upstream bug and the patches (that were accepted in CVS for 2.17.x - YAY) differ from the ones used in here. Any reason why we shouldn't sync with Upstream?

Henrik Nilsen Omma (henrik) wrote :

I have some minor UI nits with their solution, but the main thing is that they have added a quit button. I'm happy to sync with them and propose further changes directly to upstream later.

Daniel Holbach (dholbach) wrote :

 gnome-orca (1.0.0-0ubuntu3) edgy; urgency=low
 .
   * debian/patches/10-quit-button-bug-59531.dpatch:
     - applied patches from Malone: #59531, thanks Chris Jones for working on
       this.

Changed in gnome-orca:
status: In Progress → Fix Released
Henrik Nilsen Omma (henrik) wrote :

Opening back up this old Orca bug from Edgy because we need to apply the same change to Feisty again. Upstream made their own floating Quit button solution which does not fit well with our presentation of these things. Bug 84172 successfully removes that (Fix Released), but we need to put our own patch back in.

Fortunately Chris has prepared a Feisty-compatible patch, that I'll upload here.

Changed in gnome-orca:
importance: Wishlist → Medium
status: Fix Released → Confirmed
Henrik Nilsen Omma (henrik) wrote :

attached patch

Duncan Lithgow (duncan-lithgow) wrote :

I'm having a few usability problems with Orca (sighted user) and would like to confirm/ check this bug in Feisty Herd 4. Where should I be able to see these buttons? I can't open Orca as an independent app - I can only get a dialog via 'Control Center'.

Luke Yelavich (themuso) wrote :

Do we still want this patch included? It fails to patch against the latest gnome-orca source package.

Henrik Nilsen Omma (henrik) wrote :

The upstream bug is no longer relevant to this issue. Chris, could try making a new patch for Feisty? We should ask Orca to make this a runtime option (having a Quit button)

Changed in gnome-orca:
assignee: desktop-bugs → nobody
Henrik Nilsen Omma (henrik) wrote :

The Orca dialog has been redesigned and this bug is no longer relevant. Shipping stock upstream version.

Changed in gnome-orca:
status: Confirmed → Won't Fix
Changed in gnome-desktop:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.