GNOME stable update, gnome-orca 2.30.2

Bug #574915 reported by Attila Hammer on 2010-05-04
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-orca (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Luke Yelavich

Bug Description

Stable update for gnome-orca in lucid, update to 2.30.2. Filtered debdiff with changes since 2.30.0 attached.

Original description follows:

Binary package hint: gnome-orca

Dear developers,

Because Orca developers publicate new 2.30.1 Orca upstream version, please upload a new version of gnome-orca package if this is possible. This new upstream version is publicated in april 25, 2010, but I think this time period have an archive freeze, so, final Lucid release now containing 2.30.0 gnome-orca package version.
In future, because Lucid is an LTS release, possible following automatical the new maintenance upstream version upgrades (2.30.1 to 2.30.2 and 2.30.3 versions)? The maintenance versions containing some time important bugfixes vith visual impaired users. Of course, not need do in future upgrade gnome-orca version to 6 month later publicated new upstream version (for example 2.32.1 version), but actual Lucid used gnome branch maintenance upgrades is need I think.
Now, with hungarian visual impaired users I always tracking the actual maintenance branch Orca version my PPA, but better do this an official way if this is possible. Need upload new versions of following packages:
gnome-orca, at-spi

Thanks,

Attila

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-orca 2.30.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
Date: Tue May 4 06:33:45 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 LANG=hu_HU.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-orca

Attila Hammer (hammera) wrote :
Changed in gnome-orca (Ubuntu):
status: New → Confirmed
WaywardGeek (waywardgeek) wrote :

Lucid is the most accessible Ubuntu release in at least two years, maybe the most accessible ever. Many blind users stayed on Ubuntu 8.04 for two years, skipping the less stable releases in between. I believe this pattern will continue, and the blind will rely on Ubuntu Lucid far more than typical users over the next two years. However, Orca is progressing very rapidly. I believe we will be happy to test Orca new releases on the Vinux derivation of Ubuntu Lucid to help insure the stability of orca package upgrades. I hope that Ubuntu Lucid will be able to move forward for the blind over the coming two years, rather than staying back the way Ubuntu Hardy did.

Thanks,
Bill

Filtered debdiff with changes since 2.30.0.

Changed in gnome-orca (Ubuntu):
status: Confirmed → Fix Released
Changed in gnome-orca (Ubuntu Lucid):
assignee: nobody → Luke Yelavich (themuso)
status: New → In Progress
description: updated
summary: - [Lucid] please upgrade gnome-orca 2.30.0 package version to 2.30.1
- upstream version
+ GNOME stable update, gnome-orca 2.30.2
Luke Yelavich (themuso) wrote :

Updated debdif with bug number.

Luke Yelavich (themuso) on 2010-07-02
Changed in gnome-orca (Ubuntu Lucid):
status: In Progress → Fix Committed
John Dong (jdong) wrote :

The filtered debdiff looks fairly reasonable, and given the compelling rationale given for this SRU, ACK from me.

Accepted gnome-orca into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

I not see any problem with this package.

Attila

Luke Yelavich (themuso) wrote :

I can also verify that the gnome-orca update shows know obvious signs of regression. I've also been able to test a few of the bug conditions mentioned in the changelog, and can verify that they are fixed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-orca - 2.30.2-0ubuntu1

---------------
gnome-orca (2.30.2-0ubuntu1) lucid-proposed; urgency=low

  * New upstream release (LP: #574915)
  * Changes in 2.30.2:
    - General
      + Fix for bgo#621800 - GUI: should not be possible to set the right
        coordinate of zoomer position to less than left (ditto for bottom
        less than top)
      + Fix for bgo#619809 - Orca freezes when building the flat review
        context of the Keybindings table
      + Fix for bgo#618334 - SD python bindings crashes when receiving
        newline followed by full stop
      + Fix for bgo#617345 - getChildNodes() is returning a list of integers
        rather than accessibles if NODE_PARENT_OF relationship is present
      + Fix for bgo#617204 - Name changed on comboboxes that have focus
        should not be announced
      + Fix for bgo#617118 - Speak table cell preference is not being saved
    - Gecko
      + Fix for bgo#618863 - Table structural navigation not working with
        th element in Firefox 3.6
      + Fix for bgo#618827 - The generatorCache is not getting dumped when
        using Gecko's caret or structural navigation due to lack of AT-SPI
        events
      + Fix for bgo#618801 - Traceback in Thunderbird
    - OpenOffice
      + Fix for bgo#620156 - Caret-moved events not presented in OOo Writer
        3.2's Hyperlink dialog
      + Fix for bgo#613299 - Orca should not present changes in the active
        descendant for unfocused widgets in OOo
      + Fix for bgo#619101 - Duplicate caret-moved events in OOo Writer are
        causing Orca to double-speak lines of text
      + Fix for bgo#620045 - Left and Right are missing from the list of
        keys the OOo script uses to determine when to speak toggle button
        state changes
      + Fix for bgo#619574 - Orca fails to speak links in OOo Writer when
        the localized form of 'link' contains an accented character
      + Fix for bgo#618790 - The active descendant in OOo Writer 3.2's
        Templates and Documents dialog are not presented
      + Fix for bgo#617603 - OO Cell numbers not spoken in Ubuntu.
    - New and updated translations
      + hu Hungarian Attila Hammer and Gabor Kelemen
  * Changes in 2.30.1:
    - General
      + Fix for bgo#615304 - Sanity check needed in the Gecko script's
        updateBraille
      + Fix for bgo#614218 - In orca.desktop.in file the --replace parameter
        is not present in the exec line
    - New and updated translations
      + ca Catalan Gil Forcada
      + ja Japanese Jiro MATSUZAWA
      + uk Ukrainian Sergiy Gavrylov
 -- Luke Yelavich <email address hidden> Fri, 02 Jul 2010 13:11:09 +1000

Changed in gnome-orca (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers