Update to 3.7.0.94.

Bug #1067565 reported by Luke Yelavich on 2012-10-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-orca (Ubuntu)
Wishlist
Luke Yelavich
Quantal
Wishlist
Luke Yelavich

Bug Description

[Impact]
This update is covered by the MicroReleaseException for GNOME.

[Test case]
?

GNOME upstream has released a new version of orca. For GNOME 3.6, the version is 3.6.1, but Orca upstrea have maintained a python 3 branch of orca at the same time during 3.6 development, hense the 3.7.0.x version number, since 3.8 is likely going to move to python 3.

Please consider this update for quantal.

Sebastien Bacher (seb128) wrote :

Hey Luke, thanks for the update, since that will likely be a SRU at this point can you make the bug follow the SRU rules (document the impact, the test case and the regression potential)?

Changed in gnome-orca (Ubuntu Quantal):
assignee: nobody → Luke Yelavich (themuso)
importance: Undecided → Wishlist
status: New → In Progress
Steve Langasek (vorlon) wrote :

This appears to fit in the GNOME MRE and shouldn't require further details. However, the changelog is inaccurate:

+ - New and updated translations (THANKS EVERYONE!!!):
+ + bg Bulgarian Alexander Shopov
+ + ca Catalan Gil Forcada
+ + ca Catalan (Valencian) Carles Ferrando
+ + cs Czech Lucas Lommer
+ = de German Simon Bienlein, Mario Blättermann
+ + it Italian Milo Casagrande
+ + lv Latvian Rudolfs Mazurs
+ + sl Slovenian Matej Urbančič
+ + pt Portuguese Rui Batista
+ + ta Tamil Dr.T.Vasudevan
+ + uk Ukranian Daniel Korostil
+

This is incorrect. The only new translations in this version are bg and uk. (The upstream changelog confirms this.)

So I've rejected and reuploaded with a corrected changelog.

description: updated

Hello Luke, or anyone else affected,

Accepted gnome-orca into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/gnome-orca/3.7.0.94-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-orca (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed

Here in Raring I can't start Orca Screen Reader. I get the following error:

$ orca

(orca:13406): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:62:17: Theming engine 'unico' not found
Traceback (most recent call last):
  File "/usr/bin/orca", line 41, in <module>
    from orca import orca
  File "/usr/lib/python3/dist-packages/orca/orca.py", line 66, in <module>
    from . import settings_manager
  File "/usr/lib/python3/dist-packages/orca/settings_manager.py", line 599, in <module>
    _manager = SettingsManager()
  File "/usr/lib/python3/dist-packages/orca/settings_manager.py", line 106, in __init__
    raise Exception('SettingsManager._loadBackend failed.')
Exception: SettingsManager._loadBackend failed.

Raring needs the latest upstream git of Orca, which will land this week.

Sebastien Bacher (seb128) wrote :

That SRU is waiting to be verified for several weeks, is there any chance you could try the update and confirm if it solves the issue for you (so it can be moved to -updates)?That SRU is waiting to be verified for several weeks, is there any chance you could try the update and confirm if it solves the issue for you (so it can be moved to -updates)?

Luke Yelavich (themuso) wrote :

I can verify that gnome-orca 3.7.0.94 from quantal-proposed continues to work correctly. In particular, I can verify that using nautilus doesn't break, given that there is a nautilus related change in this update for nautilus 3.6, even though quantal ships nautilus 3.4

tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-orca - 3.7.0.94-0ubuntu0.1

---------------
gnome-orca (3.7.0.94-0ubuntu0.1) quantal-proposed; urgency=low

  * New upstream release (LP: #1067565)
    - General
      + Fix for bug 675288 - Orca doesn't always announce selection changes
        in Nautilus 3.6's icon view
      + Fix for bug 680228 - In Thunderbird 14.0 e-mail address auto
        completion results are not spoken
      + Fix for bug 684838 - Orca should present the accessible name of
        sliders
      + Fix for bug 675656 - Mark Hungarian 8 dot computer braille for
        translation
    - New and updated translations (THANKS EVERYONE!!!):
      + bg Bulgarian Alexander Shopov
      + uk Ukranian Daniel Korostil
 -- Luke Yelavich <email address hidden> Wed, 17 Oct 2012 11:31:07 +1100

Changed in gnome-orca (Ubuntu Quantal):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2013-07-24
Changed in gnome-orca (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers