gnome-online-accounts -> when signing into google account, infinite loading after entering password

Bug #2039235 reported by nathan li
52
This bug affects 10 people
Affects Status Importance Assigned to Milestone
gnome-online-accounts (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

1) What you expected to happen
- sign in is successful, which will allow google services to populate the appropriate applications (calendar, mail, google drive)

2) What actually happened
- sign in hangs infinitely after entering the password
- the process is able to detect that the password is correct or incorrect. When entering an incorrect password, it will correctly and quickly complain that the password is incorrect. When entering the correct password, the bug will occur.

3) Steps to reproduce
  a) start the program
  b) select online accounts
  c) select google
  d) enter email
  e) enter password
  f) loads forever

ProblemType: Bug
DistroRelease: Ubuntu 23.10
Package: gnome-online-accounts 3.48.0-2
ProcVersionSignature: Ubuntu 6.5.0-9.9-generic 6.5.3
Uname: Linux 6.5.0-9-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.27.0-0ubuntu5
Architecture: amd64
CasperMD5CheckResult: pass
CurrentDesktop: ubuntu:GNOME
Date: Thu Oct 12 22:27:59 2023
InstallationDate: Installed on 2023-10-12 (0 days ago)
InstallationMedia: Ubuntu 23.10 "Mantic Minotaur" - Release amd64 (20231011)
ProcEnviron:
 LANG=en_US.UTF-8
 PATH=(custom, no user)
 SHELL=/bin/bash
 TERM=xterm-256color
 XDG_RUNTIME_DIR=<set>
SourcePackage: gnome-online-accounts
UpgradeStatus: No upgrade log present (probably fresh install)

Hardware info (not sure if relevant):
cpu: intel
gpu: nvidia (driver version: "Using NVIDIA driver metapackage from nvidia-driver-535(proprietary, tested)")

Revision history for this message
nathan li (nathannli) wrote :
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-online-accounts (Ubuntu):
status: New → Confirmed
Revision history for this message
Ryan Chew (cryptoxic) wrote :

I am facing this issue on Ubuntu 22.04 LTS as well so I suspect that this is not related to the operating system per se but more of the package and how it interacts with google. I have attached my dependencies as well as my full cpuinfo.

Revision history for this message
Ryan Chew (cryptoxic) wrote :
Revision history for this message
Jon Doe (jondoe789) wrote :

Same for me but some details that can be usefull to know :
- Using a workspace email = evrything is fine
- Using a personal google email = i have the endless loading problem

(for workspace i've used the "add a GOOGLE account" button)

Not too familiar with what .txt file to psot and how to do so... lmk if i can do anything

Revision history for this message
Janek Bevendorff (phoerious) wrote :

Same issue here. I don't think this is related to the other common problem where the whole window would freeze if you are running X11 and haven't disabled the sandbox. Hence, it took me a while to find this issue. The problem is the same on both X11 and Wayland, regardless of whether the sandbox is enabled or not. It's not the window that freezes, it's just the login page that is stuck.

I had my Google account set up before, but I deleted it, because my calendars stopped syncing (I've had that before as well) and now I cannot add it back.

Revision history for this message
Nathan Vaughn (nathanvme) wrote :

Workaround that worked for me was to let it begin loading infinitely, then right-click inside the window and select "Reload". It then skipped the login, and took me to the 2FA page that was presumably trying to load.

Revision history for this message
Janek Bevendorff (phoerious) wrote :

That was it, thanks! It looks very much like it is unable to load the 2FA page if there is a YubiKey configured. When I click Refresh, I see the 2FA page, but the YubiKey is not recognised (that's why I hate these embedded login pages -- why not just use the normal browser??). I can select "try a different way" and then log in with either TOTP or confirmation from my phone. However, when I select YubiKey in that list, I have the same problem again: page loads forever until I hit Refresh.

Revision history for this message
Nathan Vaughn (nathanvme) wrote :

Same for me, my default Google 2FA option is a security key, that's probably the common denominator here.

Revision history for this message
Ryan Chew (cryptoxic) wrote :

Can confirm that the workaround worked for me as well. I had a yubikey on my google account and that was what caused the issue.

Revision history for this message
Felix Stoltenberg (fst-2738952) wrote (last edit ):

I also have a YubiKey on my Google account. However, I just wanted to try the suggested workaround, BUT IT JUST WORKED WITHOUT THE WORKAROUND!

Revision history for this message
Nathan Reed (nathrek) wrote :

Another confirmation that the infinite load is related to having a YubiKey as the primary 2FA on the account. Reloading the page as suggested and then authenticating via mobile device is a successful workaround.

Revision history for this message
Rafael Rodrigues Marquesi (marquesi-cc) wrote :

I had the same problem. I followed the instructions of Nathan Vaughn (nathanvme) and it worked for me. Thanks.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.