online accounts integration with fb isn't working

Bug #1926843 reported by Lars Martin Hambro on 2021-05-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-online-accounts (Ubuntu)
High
Unassigned
Hirsute
Undecided
Unassigned

Bug Description

* Impact

The online accounts setting are proposing a facebook item which isn't working

* Test case

Go to settings -> online account, browse the accounts option proposed, facebook shouldn't be in the list since it doesn't work.

* Regression potential

The change is to disable the facebook provider using the upstream provided build option. Check that facebook isn't listed anymore but that the other providers still are. Since it's a build option change it could fail to build so check for that as well on launchpad.

Since the facebook service currently doesn't consider gnome-online-accounts as a valid client there should be no user with that provider configured. Even if there were since the service isn't working they would see a functional regression.

---------------------------------------------------------------

Hi i tryed to use gnome-control-center online-accounts to make easy like windows 10 to login to email or add other login so its more easy with ID to use pincode or other ID fingerprint and other.

But its look its much issue compared with windows 10 with thunderbird, firefox, and other program.

Worst is facebook only little windows with issue with login?

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: gnome-online-accounts 3.38.1-1ubuntu1
Uname: Linux 5.12.0-051200-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu65
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: ubuntu:GNOME
Date: Sat May 1 19:38:03 2021
InstallationDate: Installed on 2019-05-07 (725 days ago)
InstallationMedia: Kubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
SourcePackage: gnome-online-accounts
UpgradeStatus: Upgraded to hirsute on 2021-04-06 (24 days ago)

Add also instagram and snapchat or other with apps so is be nice,

Its isssue with Facebook as picture show, but other like ubuntu\hotmail or google email works to login but not did not help much to use thunderbird or firefox\chrome to make its more easy to login without less safety issue.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the facebook issue is known and reported upstream on https://gitlab.gnome.org/GNOME/gnome-online-accounts/-/issues/128

Changed in gnome-online-accounts (Ubuntu):
importance: Undecided → High
status: New → Triaged
Sebastien Bacher (seb128) wrote :

the fact that thunderbird isn't integrated with the GNOME online accounts is a known issue and a thunderbird missing feature

summary: - gnome-control-center online-accounts poor app to add facebook and other
+ online accounts integration with fb isn't working
Changed in gnome-online-accounts (Ubuntu):
status: Triaged → Fix Committed

stil the samme issue?

XDG_CURRENT_DESKTOP=GNOME gnome-control-center
Gtk-Message: 18:39:14.049: Failed to load module "appmenu-gtk-module"
Gtk-Message: 18:39:19.385: Failed to load module "appmenu-gtk-module"

(WebKitWebProcess:2): dbind-WARNING **: 18:39:19.409: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-pkft2CzOvy: file or folder did not exist.

Also want to know

sed -i ‘s/^Exec.*/Exec=env XDG_CURRENT_DESKTOP=GNOME gnome-control-center --overview/’ ~/.local/share/applications/gnome-control-center.desktop --debug

how to use that one?

 gnome-online-accounts (3.38.1-1ubuntu1).
sudo apt-get upgrade
0 upgrade, 0 new installed, 0 to remove and 0 no upgrades.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-online-accounts - 3.38.1-1ubuntu2

---------------
gnome-online-accounts (3.38.1-1ubuntu2) impish; urgency=medium

  * debian/rules:
    - disable the facebook provider since it's current not working
      (lp: #1926843)

 -- Sebastien Bacher <email address hidden> Fri, 07 May 2021 17:16:05 +0200

Changed in gnome-online-accounts (Ubuntu):
status: Fix Committed → Fix Released

sorry i can not find gnome-online-accounts - 3.38.1-1ubuntu2 packages so please tell how to add it with apt-get?

Why is disable the facebook provider since it's current not working? its because facebook did not want to use it on linux or safety issue?

Because android and windows 10 support instgram and facebook apps?

Sebastien Bacher (seb128) wrote :

> its because facebook did not want to use it on linux or safety issue?

no, it's the code in gnome-online-accounts which isn't properly maintained upstream at the moment, they would need to do changes to the code and follow the registration process for the service

Ideally that would be fixed and enabled, but until that happens it's less misleading to not propose the option than to have one that isn't working

description: updated

But can you confirm:
sudo add-apt-repository ppa:folke-schwinning/personal
sudo apt-get update
sudo apt-get install desktop-facebook

 sudo apt install npm nodejs-legacy git

https://snapcraft.io/install/facebook-webapp/ubuntu

Its this safe as worksaground or may is get safety issue?
I want replacement for linux, because windows 10 android works with facebook but did no know how becauce is hard to get to works with wine HQ or other software?

Because i did not know if APT get or other repo is protected other than wrong repo to old config, because some software may be maded only because developer get money for works with other company that get money on password leaks or other. Not sure if some of apps if safe because it can come software bugs to safety also.

Or is snap\apt-get safe with install apps?

Hello Lars, or anyone else affected,

Accepted gnome-online-accounts into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-online-accounts/3.38.1-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-online-accounts (Ubuntu Hirsute):
status: New → Fix Committed
tags: added: verification-needed verification-needed-hirsute

All autopkgtests for the newly accepted gnome-online-accounts (3.38.1-1ubuntu1.1) for hirsute have finished running.
The following regressions have been reported in tests triggered by the package:

libgdata/0.18.1-1 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/hirsute/update_excuses.html#gnome-online-accounts

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Iain Lane (laney) wrote :

I retried libgdata and it works now

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.