gnome-control-center cannot access google account

Bug #1847597 reported by Luigi on 2019-10-10
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-online-accounts
New
Undecided
Unassigned
gnome-online-accounts (Ubuntu)
Low
Unassigned

Bug Description

Good morning,

If I run "gnome-control-center online-accounts" from the terminal and trying to add a Google account, I get this error: "Sign in with Google is temporarily disabled for this app. This app has not been verified yet by Google in order to use Google sign in". On the web, Google suggests to contact you, so here I am. Can you fix please? I would use my drive folders on my ubuntu 16.04. Thanks in advance.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you take a screenshot showing the error?
What desktop environement are you using?
What's the gnome-control-center version installed? (dpkg -l | grep gnome-control-center)

Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Luigi (cavoliamauri) wrote :

Yes of course. I will attach my screenshot (which is in Italian) with the English version.
My gnome-control-center version is:

ii gnome-control-center 1:3.18.2-1ubuntu6.1 amd64 utilities to configure the GNOME desktop

ii gnome-control-center-data 1:3.18.2-1ubuntu6.1 all configuration applets for GNOME - data files

Thanks in advance.

Sebastien Bacher (seb128) wrote :

thank you for the screenshot, it's not clear it's a control center UI though. How do you start it? Could you maybe do xprop on the application and copy the log there?

Luigi (cavoliamauri) wrote :

I start the application typing in the terminal the following command:

"gnome-control-center online-accounts"

Could you tell me how to do xprop on the application?

Gunnar Hjalmarsson (gunnarhj) wrote :

Changed the affected package.

@Luigi: The error message indicates that Google requires some kind of verification. Do you have a verified Google address, and is it that address you enter?

affects: gnome-control-center (Ubuntu) → gnome-online-accounts (Ubuntu)
Luigi (cavoliamauri) wrote :

Yes I have a verified Google address, which is that I enter in the gnome-control-center-app

Sebastien Bacher (seb128) wrote :

to use 'xprop' just type that command on a command line (you need 'x11-utils' installed) and click on the dialog you want the info from and it's going to print the info on the command line

what session/desktop are you using?

Luigi (cavoliamauri) wrote :
Download full text (4.5 KiB)

I'm using a Ubuntu 16.04.6 LTS version.

The xprop output is:

XdndAware(ATOM) = BITMAP
_NET_WM_ICON_GEOMETRY(CARDINAL) = 1925, 737, 54, 54
WM_STATE(WM_STATE):
  window state: Normal
  icon window: 0x0
_NET_WM_DESKTOP(CARDINAL) = 0
_NET_WM_STATE(ATOM) = _NET_WM_STATE_MODAL
WM_HINTS(WM_HINTS):
  Client accepts input or input focus: True
  Initial state is Normal State.
  bitmap id # to use for icon: 0x6c00376
  bitmap id # of mask for icon: 0x6c0037c
  window id # of group leader: 0x6c00001
_GTK_MENUBAR_OBJECT_PATH(UTF8_STRING) = "/com/canonical/unity/gtk/window/1"
_UNITY_OBJECT_PATH(UTF8_STRING) = "/com/canonical/unity/gtk/window/1"
_GTK_UNIQUE_BUS_NAME(UTF8_STRING) = ":1.265"
_NET_WM_ICON(CARDINAL) = Icon (22 x 22):

       β–‘β–‘ β–‘β–‘β–‘β–‘
     β–‘β–‘ β–‘ β–‘β–‘β–‘β–‘β–’β–‘
   β–‘β–‘ β–‘β–‘ β–‘β–‘ β–‘β–‘ β–‘β–‘
   β–‘ β–‘β–‘β–‘β–‘β–‘ β–‘β–‘ β–‘β–‘
  β–’ β–‘β–’β–’β–’β–‘β–‘β–‘ β–‘
 β–‘β–‘ β–‘β–’ β–‘β–’β–‘β–‘β–‘β–‘ β–‘β–‘
 β–‘β–‘ β–‘ β–‘ β–’β–’β–’β–‘ β–‘β–‘ β–‘β–’
 β–’β–‘β–‘ β–‘ β–’β–‘β–‘β–‘β–‘β–‘β–‘ β–‘β–‘β–’
 β–’β–‘β–‘ β–‘β–‘β–‘ β–’β–‘β–‘β–‘β–‘β–‘β–‘ β–‘β–’β–’
 β–’β–’β–‘ β–‘β–‘β–‘β–‘β–‘β–’β–’β–’β–’β–‘β–‘β–‘ β–‘β–’β–’
 β–‘β–’β–‘ β–’β–’β–’β–’ β–‘β–’β–‘β–‘β–‘ β–‘β–’β–’β–‘
  β–’β–‘β–‘ β–‘β–’β–’β–’β–’β–’β–’β–‘ β–‘β–‘ β–‘β–’β–’
  β–‘β–’β–‘β–‘β–‘β–’β–’β–’β–’β–‘β–’β–‘β–‘β–‘β–‘β–‘β–‘β–‘β–’β–‘
   β–’β–’ β–‘β–’β–’β–‘β–’β–‘β–’β–‘β–‘β–‘β–‘β–‘β–‘β–’β–’
   β–‘β–’β–’β–‘β–‘ β–’β–’β–‘β–’β–’β–‘β–‘β–‘β–‘β–’β–’β–‘
   β–‘β–’β–’β–“β–“β–’β–“β–’β–‘β–‘β–’β–’β–’β–“β–“β–’β–’β–‘
    β–‘β–‘β–‘β–’β–‘β–‘ β–‘β–‘β–‘β–’β–‘β–‘β–‘

 Icon (16 x 16):
       β–‘β–‘
    β–‘β–‘β–‘ β–‘
   β–‘ β–‘β–‘
  β–‘ β–‘β–‘
  β–‘ β–‘β–’β–’β–’β–‘
 β–‘β–‘ β–‘β–‘β–‘ β–’
 β–’ β–‘ β–’β–’β–’β–‘
 β–’β–‘β–‘ β–‘
 β–’β–‘β–‘ β–‘β–‘β–‘ β–’
 β–’β–’β–‘ β–‘β–‘β–‘β–‘β–‘β–’β–’β–’β–‘
 β–’β–’β–‘ β–‘β–’β–’β–’β–’ β–’
  β–’β–‘β–‘ β–’β–’β–’β–’β–’β–’β–’β–‘
  β–’β–’β–‘β–‘β–‘β–’β–’β–’β–’
   β–’β–‘ β–‘β–‘β–’β–‘β–’
    β–‘β–’β–‘β–‘ β–’β–‘
      β–‘β–’β–’β–’

 Icon (24 x 24):

        β–‘β–‘ β–‘β–‘β–‘β–‘
      β–‘β–‘ β–‘ β–‘β–‘β–‘β–‘β–’β–‘
    β–‘β–‘ β–‘β–‘ β–‘β–‘ β–‘β–‘ β–‘β–‘
    β–‘ β–‘β–‘β–‘β–‘ β–‘β–‘ β–‘
   β–’ β–‘β–’β–’β–’β–‘β–‘β–‘ β–’
  β–‘β–‘ β–‘β–’ β–‘β–’β–‘β–‘β–‘β–‘ β–‘β–‘
  β–‘β–‘ β–‘ β–‘ β–’β–’β–’β–‘ β–‘β–‘ β–‘β–’
  β–’β–‘β–‘ β–‘ β–’β–‘β–‘β–‘β–‘β–‘β–‘ β–‘β–’
  β–’β–‘β–‘ β–‘β–‘ β–’β–‘β–‘β–‘β–‘β–‘β–‘ β–‘β–’β–’
  β–’β–’β–‘ β–‘β–‘β–‘β–‘β–‘β–’β–’β–’β–’β–‘β–‘β–‘ β–‘β–’β–’
  β–‘β–’β–‘ β–’β–’β–’β–’ β–‘β–’β–‘β–‘β–‘ β–‘β–’β–’β–‘
   β–’β–‘β–‘ β–‘β–’β–’β–’β–’β–’β–’β–‘ β–‘β–‘ β–‘β–’β–’
   β–‘β–’β–‘β–‘β–‘β–’β–’β–’β–’β–’β–’β–‘β–‘β–‘β–‘β–‘β–‘β–‘β–’β–‘
    β–’β–’ β–‘β–’β–’β–‘β–’β–‘β–’β–‘β–‘β–‘β–‘β–‘β–‘β–’β–’
    β–‘β–’β–’β–‘β–‘ β–‘β–’β–‘β–’β–’β–‘β–‘β–’β–‘β–’β–’β–‘
    β–‘β–’β–’β–“β–“β–’β–“β–’β–‘β–‘β–’β–’β–’β–’β–“β–’β–’β–‘
     β–‘β–‘β–‘β–’β–‘β–‘β–‘ β–‘β–‘β–‘β–’β–‘β–‘β–‘

 Icon (32 x 32):

          β–‘β–‘ β–‘β–‘β–‘β–‘
       β–‘β–‘β–‘ β–‘ β–‘β–‘β–‘β–‘β–‘β–‘β–‘β–‘
      β–‘β–‘ β–‘β–‘ β–‘ β–‘β–‘β–‘β–‘β–‘
     β–‘ β–‘β–‘ β–‘β–‘ β–‘ β–‘
    β–‘ β–‘β–‘ β–‘ β–’
   β–‘ β–‘β–‘β–’β–’β–’β–’β–’ β–‘β–‘β–‘ β–‘
   β–‘ β–‘ β–‘β–‘ β–‘β–‘β–‘β–“β–‘ β–’
  β–‘β–‘ β–‘ β–‘ β–‘β–‘β–‘β–‘β–’β–‘β–‘β–’β–‘ β–‘β–‘ β–‘β–‘
  β–‘β–‘β–‘β–‘ β–‘ β–’β–’β–’β–’β–‘ β–‘β–‘β–‘
  β–’β–‘β–‘β–‘ β–‘ β–’ β–’β–‘ β–‘ β–’β–’
  β–’β–‘β–‘β–‘ β–‘β–‘ β–’ β–’β–‘β–‘β–‘β–‘β–‘ β–‘ β–‘β–‘β–’β–’
  β–’β–’β–‘β–‘ β–‘β–‘β–‘β–‘β–‘β–‘β–‘β–’β–’β–’β–’β–‘β–‘β–‘β–‘β–‘β–‘β–‘ β–’β–’β–’
  β–‘β–’β–‘β–‘ β–‘β–‘β–‘β–‘β–’β–’β–’ β–’β–‘β–‘β–’β–‘β–‘β–‘ β–‘β–’β–’β–‘
   β–’β–‘β–‘ β–‘β–’β–’β–’β–’β–’β–‘β–‘β–‘β–’β–‘β–‘β–“β–‘β–‘β–‘β–‘ β–‘β–‘β–’β–’
   β–’β–’β–‘β–‘ β–’β–’β–’β–’β–’β–’β–’β–’β–’β–’β–‘ β–‘β–‘β–‘β–‘β–‘β–‘β–’β–’
    β–’β–‘β–‘β–‘β–‘β–‘β–’β–’β–’β–‘β–’ β–’β–‘β–‘β–‘β–‘β–‘β–‘β–‘β–‘β–‘β–’β–’
    β–‘β–’β–‘ β–’β–’β–’β–’β–’β–’ β–’β–‘β–‘β–‘β–‘β–‘β–‘β–‘ β–‘β–’β–‘
     β–’β–’ β–‘β–‘β–‘β–‘β–’β–’β–‘β–‘ β–‘β–’β–‘β–‘β–‘β–‘β–‘β–‘β–‘β–’β–’
     β–‘β–’β–’β–’β–‘β–‘ β–‘β–’β–’β–’β–‘β–‘β–‘β–‘β–’β–’β–‘β–‘β–’β–‘β–’β–“β–’β–‘β–‘
      β–‘β–’β–’β–“β–“β–“β–“β–“β–’β–‘β–‘ β–‘β–’β–’β–’β–’β–“β–“β–“β–’β–’β–‘β–‘
       β–‘β–‘β–’β–’β–’β–’β–’β–‘β–‘ β–‘β–‘β–’β–’β–’β–’β–’β–‘β–‘
           β–‘ β–‘β–‘

                          ...

Read more...

I'm seeing the same error.

Steps to reproduce:

Open System Settings
Go to Online Accounts
Add a google account
Enter username / password

I then get the same dialog as the reporter of this bug.

I'm on Ubuntu 19.10.

This smacks of our online accounts api key being revoked / rate-limited or otherwise restricted by Google.

I have tested with a second google account (my canonical one, as opposed to my personal one) and get the exact same error.

Changed in gnome-online-accounts:
status: Unknown → New
Changed in gnome-online-accounts (Ubuntu):
status: Incomplete → Confirmed
Sebastien Bacher (seb128) wrote :

The GNOME key expired this week, that's bug #1851564. The issue there is older so it can't be the same issue

Changed in gnome-online-accounts:
importance: Unknown → Undecided
AC (atcapollo) wrote :

Same issue - any solution?

AC (atcapollo) wrote :

Gnome team have fixed this upstream, see fix https://gitlab.gnome.org/GNOME/gnome-online-accounts/-/issues/42

v3.18.2 will not be fixed.

I have manually compiled and installed v3.18.3 with my own API key but it still does not work. Gnome team have advised that 3.18 is now unsupported and latest stable is v3.36.

I cannot compile and install v3.36 due to other dependencies on updated version glib not available in Ubuntu LTS.

Can the Ubuntu package maintainer please incorporate the upstream fix from Gnome and update the package in the repository? as it stands this is broke on 16.04LTS.

Sebastien Bacher (seb128) wrote :

GNOME isn't the default desktop on Ubuntu 16.04 and there is only one bug with 3 affected users, which means it's low priority for a fix in that serie

tsechunhin (colmantse) wrote :

I could not upgrade gnome over v3.18 at ubuntu 1.16, it says its already the newest.
If this is the case, does this mean g-drive is screwed for all ubuntu 1.16 users?

Sebastien Bacher (seb128) wrote :

The default desktop on Ubuntu 16.04 (assuming that's what you meant by 1.16) is Unity and the online accounts used there are different from the GNOME one.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.