U1 login dialog missing link to the privacy policy

Bug #1773213 reported by Will Cooke on 2018-05-24
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-online-accounts (Ubuntu)
High
Ken VanDine
Bionic
High
Ken VanDine

Bug Description

The U1 login for g-o-a is missing a link to the privacy policy.

[Impact]

 * No way to view the privacy policy for Ubuntu One

[Test Case]

 * Open gnome-control-center
 * Select "Online Accounts" on the left
 * Select "Ubuntu Single Sign-On" under "Add an account"
 * Not you should see a link to open the Privacy Policy on the bottom left of the dialog.
 * Verify when clicking the window a browser window opens with our data privacy page

[Regression Potential]

 * None

Will Cooke (willcooke) on 2018-05-24
Changed in gnome-online-accounts (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Will Cooke (willcooke) wrote :
Will Cooke (willcooke) on 2018-05-24
Changed in gnome-online-accounts (Ubuntu):
assignee: nobody → Andrea Azzarone (azzar1)
Andrea Azzarone (azzar1) on 2018-05-24
Changed in gnome-online-accounts (Ubuntu):
status: Confirmed → In Progress
Andrea Azzarone (azzar1) on 2018-05-25
tags: added: rls-bb-incoming
Andrea Azzarone (azzar1) wrote :

Please find attached the proposed debdiff.

The attachment "goa.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Iain Lane (laney) wrote :

Hey, I think this should get the privacy policy URL from /etc/os-release, do you agree?

Changed in gnome-online-accounts (Ubuntu):
assignee: Andrea Azzarone (azzar1) → Ken VanDine (ken-vandine)
Changed in gnome-online-accounts (Ubuntu Bionic):
assignee: nobody → Ken VanDine (ken-vandine)
tags: removed: rls-bb-incoming
Andrea Azzarone (azzar1) wrote :

Done.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-online-accounts - 3.28.0-0ubuntu3

---------------
gnome-online-accounts (3.28.0-0ubuntu3) cosmic; urgency=medium

  * debian/patches/0001-ubuntu-sso-provider.patch: Add a link to the
    link to the privacy policy in U1 login dialog (LP: #1773213).
  * debian/patches/0002-livepatch-auth: Refresh patch.

 -- Andrea Azzarone <email address hidden> Fri, 25 May 2018 09:04:11 -0500

Changed in gnome-online-accounts (Ubuntu):
status: In Progress → Fix Released
description: updated
Andrea Azzarone (azzar1) on 2018-06-13
Changed in gnome-online-accounts (Ubuntu Bionic):
importance: Undecided → High

Hello Will, or anyone else affected,

Accepted gnome-online-accounts into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-online-accounts/3.28.0-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-online-accounts (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Nafallo Bjälevik (nafallo) wrote :

I can confirm this is working as intended.

tags: added: verification-done-bionic
removed: verification-needed-bionic
tags: added: verification-done
removed: verification-needed
Łukasz Zemczak (sil2100) wrote :

Which version of the package has been used for verification?

Nafallo Bjälevik (nafallo) wrote :

nafallo@wendigo:~$ apt policy gnome-online-accounts
gnome-online-accounts:
  Installed: 3.28.0-0ubuntu2.1
  Candidate: 3.28.0-0ubuntu2.1
  Version table:
 *** 3.28.0-0ubuntu2.1 400
        400 http://se.archive.ubuntu.com/ubuntu bionic-proposed/main amd64 Packages
        100 /var/lib/dpkg/status
     3.28.0-0ubuntu2 500
        500 http://se.archive.ubuntu.com/ubuntu bionic/main amd64 Packages

Same with the rest of the packages built from the source.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-online-accounts - 3.28.0-0ubuntu2.1

---------------
gnome-online-accounts (3.28.0-0ubuntu2.1) bionic-proposed; urgency=medium

  * debian/patches/0001-ubuntu-sso-provider.patch: Add a link to the
    link to the privacy policy in U1 login dialog (LP: #1773213).
  * debian/patches/0002-livepatch-auth: Refresh patch.

 -- Andrea Azzarone <email address hidden> Fri, 25 May 2018 09:04:11 -0500

Changed in gnome-online-accounts (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-online-accounts has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments