Replace Google API key used by GNOME services

Bug #1649995 reported by Jeremy Bicha on 2016-12-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-online-accounts
Fix Released
Medium
gnome-online-accounts (Ubuntu)
High
Unassigned
Yakkety
High
Unassigned

Bug Description

Impact
======
Some bugs in evolution-data-server (e-d-s) were causing daily limit errors for those using Google services with evolution-data-server and apps that use it (Evolution is a prominent example). Unfortunately, it looks like users using older versions of e-d-s are causing those errors to affect everyone using e-d-s since they are using the same API key. It's very difficult for GNOME to push everyone to use an updated version of their software.

Therefore, this update changes the API key used by those using the GNOME Online Accounts feature for Google services.

Test Case
=========
Restart your computer after applying the updates.

Then use Evolution with a Google account configured by gnome-control-center's Online Accounts. The easiest way to configure that correctly is to use Ubuntu GNOME.

Make sure that Evolution works without getting authentication errors with your Google services.

Regression Potential
====================
I think the only possibility for regression is if GNOME did not configure the key correctly with Google's developer platform.

Other Info
==========
This was fixed in zesty in gnome-online-accounts 3.22.3-1.

This update depends on the evolution-data-server 3.22.3 SRU (LP: #1639926) (now in yakkety-updates and fully phased) since we need to make sure the user has a fixed version of e-d-s so we don't taint the new keys too!

We can't fix this for Ubuntu 16.04 LTS until we figure out how to backport the needed e-d-s changed there.

I believe Evolution has three ways to use Google services: 1) GNOME Online Accounts 2) evolution-data-server (e-d-s) has its own Google authentication method 3) Ubuntu Online Accounts.

The errors are much less common for the e-d-s API key so upstream does not intend to change that key. The e-d-s key is new, only existing in Ubuntu 16.10 and above. (It's not even used in the Ubuntu 16.04 GNOME3 Staging PPA since --disable-google-auth is used there to not add a new universe dependency.)

Similarly, Ubuntu Online Accounts does not currently appear to be impacted (LP: #1650007).

Changed in gnome-online-accounts:
importance: Unknown → Medium
status: Unknown → Fix Released
Jeremy Bicha (jbicha) on 2016-12-14
description: updated
Jeremy Bicha (jbicha) on 2016-12-15
description: updated
Jeremy Bicha (jbicha) on 2016-12-16
Changed in gnome-online-accounts (Ubuntu):
status: New → Fix Released
Changed in gnome-online-accounts (Ubuntu Yakkety):
importance: Undecided → High
status: New → In Progress
description: updated
Jeremy Bicha (jbicha) on 2017-01-12
description: updated

Hello Jeremy, or anyone else affected,

Accepted gnome-online-accounts into yakkety-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-online-accounts/3.20.5-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-online-accounts (Ubuntu Yakkety):
status: In Progress → Fix Committed
tags: added: verification-needed
Jeremy Bicha (jbicha) on 2017-01-12
description: updated
Jeremy Bicha (jbicha) wrote :

I tested this by adding a Google account to Ubuntu GNOME 16.10 and making sure it worked in Evolution. I then updated the gnome-online-accounts packages and made sure Evolution still worked. I rebooted and made sure Evolution still worked. I checked Evolution's mail, calendar and contacts integration with Google.

I've been using the new evolution-data-server and gnome-online-accounts in Ubuntu GNOME 17.04 for several weeks and haven't seen the Google authentication errors recently at all.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-online-accounts - 3.20.5-0ubuntu0.1

---------------
gnome-online-accounts (3.20.5-0ubuntu0.1) yakkety; urgency=medium

  * New upstream bugfix release (LP: #1649995)
    - Use a new Google API key because there are authentication errors
      for anyone using the same key as old, buggy versions of
      evolution-data-server

 -- Jeremy Bicha <email address hidden> Fri, 16 Dec 2016 06:38:44 -0500

Changed in gnome-online-accounts (Ubuntu Yakkety):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-online-accounts has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.