An Online account needs attention when opening Thunderbird

Bug #1152490 reported by Emmanuel DA MOTA on 2013-03-08
348
This bug affects 72 people
Affects Status Importance Assigned to Milestone
Evolution
New
Undecided
Unassigned
gnome-online-accounts (Ubuntu)
Undecided
Unassigned
gnome-online-accounts (openSUSE)
New
Undecided
Unassigned

Bug Description

Having a gmail account configured in Thunderbird and a google account in goa

After Login, the first time i open thunderbird, i get 2 popups

1) An online account needs attention

2) Error popup with the following message :

There was a problem opening the address book "Contacts" - the message returned was: Cannot open book: GDBus.Error:org.gnome.OnlineAccounts.Error.NotAuthorized: Did not find password with username `<email address hidden>' in credentials

i deleted an recreated the google settings in goa but this changes nothing

If i close thunderbird and reopen it, there's no error message

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-online-accounts 3.6.2-1
ProcVersionSignature: Ubuntu 3.8.0-11.20-generic 3.8.2
Uname: Linux 3.8.0-11-generic x86_64
ApportVersion: 2.9.1-0ubuntu1
Architecture: amd64
Date: Fri Mar 8 09:18:31 2013
InstallationDate: Installed on 2011-10-14 (510 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
MarkForUpload: True
SourcePackage: gnome-online-accounts
UpgradeStatus: Upgraded to raring on 2013-02-21 (14 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-online-accounts (Ubuntu):
status: New → Confirmed
Pere Escobar Solsona (pere-0) wrote :

Possibly a permissions problem: same "/home" (in my case) on two different installations (openSuse 12.2 & Ubuntu 12.10). My problem is on the openSuse distribution (first installed), not on Ubuntu 12.10. Problem remains with last release (2013) of PCLinuxOS and from a clean install of openSuse 12.3.

There was no problem when "/home" was shared on an old installation with Fedora 17 and openSuse 12.1.

I have this Problem without any sharing /home scenarios.

Same here, no shared /home

For me this bug appeared when upgraded from ubuntu 12.10 to 13.04 beta2

ConnyLo (webmaster-333) wrote :

Bug appeared after updating from 12.10 to 13.04.

Also having this issue on upgrade to 13.04 from 12.10: two pop-ups after a restart, same error messages as OP described.
If I log out and log back in, I only get the pop-up for the "An online account needs your attention", but no pop-up in Thunderbird.

Andreas Jonsson (sonofjon) wrote :

I started experiencing this bug after upgrading from 12.04 to 12.10 and 13.04 in rapid succession. I have two-factor authentication enabled for the Gmail account involved.

hshan (hshan) wrote :

Happens to me on two machines running 13.04. Same as above.. login to online accounts need attention requester. Empathy does not show up (window) when i click on it from the top bar.

I purge uninstalled it and reinstalled with same affect.
Killing the task in terminal and then running empathy from there returns error with this in it;
"Cannot open book: GDBus.Error:org.gnome.OnlineAccounts.Error.NotAuthorized"

Jan Henke (jhe) wrote :

Same problem here. I noticed that the number of unread messages does not appear on the affected machine.

I have another Ubuntu 13.04 (upgrade from 12.10) running at my work PC at university not experiencing the problem and showing the number of unread messages. To exclude possible problems with the Thunderbird account I copied over the whole account from university. No change, the very same Thunderbird account runs flawless on the University machine, while the symptoms appear on the laptop at home. So it must be some external factor.

gianluca (amato) wrote :

In my case, the problem is triggered by the "EDS Contact Integration" addon. By disabling the add-on, the erorr disappear. However, I also loose the integration with Google contacts.

Yes, it seems to be an "EDS Contact integration" issue. Every time I open Thunderbird the first time in a session I get these two message boxes: "An online account needs attention" and "There was a problem opening the address book...". In this case imported online accounts from goa are also not populated. A workaround is to simply restart Thunderbird which will fix it in most cases. Ugraded system from 12.10 to 13.04.

Zordid (zordid-gmx) wrote :

I am also affected. Deleted my while Thunderbird configuration, re-setup all my accounts. It worked fine until the first restart of my system (which I have to do because of another bug that prevents standby...).
Now, same bug again.
Always get this dialog box when opening Thunderbird.

Please get it fixed!

peter smout (psmouty) wrote :

It affects me as well, only when I open thunderbird the first time in that session, and only with gmail.
I have also updated from 12-10 to 13-04.

I have tried deleteing the account in t-bird and online accounts and still the same, although it does login to my account and get any new mail. Sending is not affected either just an annoying message!

Christian Dywan (kalikiana) wrote :

My work-around: uninstall gnome-online-accounts. I no longer see the issue as of this morning.

Jens Heise (heise-s) wrote :

The "disable EDS Contact Integration" solution worked for me as well. Thank You.

lostprophet (matze-spam1) wrote :

it vvorks for thunderbird, but as soon as i try to share a file by rightclicking and sending it to someone, i get the same error message. every time!

J-Paul BERARD (arverne) wrote :

The problem came from 'EDS contact Integration' : I disabled it and this message disappeared.
EDS... looks to be not useful : Zindus is enough

Gauner (gauner) wrote :

Same here: Deactivated 'EDS contact Integration' in thunderbird addons - problem gone.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers