Ubuntu

Cannot add Facebook to online accounts

Reported by Alexander on 2013-02-23
162
This bug affects 35 people
Affects Status Importance Assigned to Milestone
gnome-online-accounts (Ubuntu)
Undecided
Unassigned

Bug Description

Like the title says, cannot add Facebook to online accounts.

Instead of presenting the login dialog inside the online accounts tool for authorizing, online accounts pop outs browser INSTEAD of embedding it inside the online accounts, which, after login just prints out "Success" in the browser and adding the account fails.

Ehm, here's screenshot to illustrate the problem:

http://www.foopics.com/showfull/ad33a8bbb1385b4d32841e9375d3d8c8

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: gnome-online-accounts 3.6.2-1
ProcVersionSignature: Ubuntu 3.8.0-7.15-generic 3.8.0
Uname: Linux 3.8.0-7-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.8-0ubuntu4
Architecture: amd64
Date: Sat Feb 23 09:10:46 2013
InstallationDate: Installed on 2013-02-20 (2 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: gnome-online-accounts
UpgradeStatus: Upgraded to raring on 2013-02-20 (2 days ago)

Alexander (alexander-) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-online-accounts (Ubuntu):
status: New → Confirmed
dave booth (davidleebooth) wrote :

getting the same bug here too, google serach provides nothing but a whole bunch of other people blaming this problem on gwibber, it isnt gwibber or empathy, it is the online accounts, a fix would be nice so i can start integrating facebook with ubuntu.
now, when we go to authorize twitter, the auth is in the settings window, where with facebook, it opens up a new browser, this seems to be the source of the problem, I am figuring online accounts isnt "seeing" the auth since it is being done in browser. please fix, bugs like this shouldnt come out of the box.
fresh install
12.10
amd64

Alexander (alexander-) wrote :

Yep, my installation is 13.04 though, but this has been broken for ages, including in 12.10. Online accounts is kinda useless when it doesn't work, would be better to remove it altogether than display completely broken features for users. Hopefully it gets fixed soon.

Ron Alon (ro2342) wrote :

It is happening in Quantal too.

description: updated
Vincent (vinnl) wrote :

Not sure if it's relevant, but it used to work for me. Then some day I got a notice that I had to re-authorize Facebook, and now this behaviour shows.

It has been fixed for Ubuntu 12.10
Don't really know if it has been ported to Raring and what would the behavior on 13.04 be, but its working now in Ubuntu 12.10

https://bugs.launchpad.net/ubuntu/+source/gnome-control-center-signon/+bug/1132030

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers