ip information frame not displayed correctly

Bug #806606 reported by Victor Vargas on 2011-07-06
508
This bug affects 84 people
Affects Status Importance Assigned to Milestone
GNOME Nettool
Fix Released
Critical
gnome-nettool (Ubuntu)
Medium
Matt Fischer
Oneiric
Low
Unassigned

Bug Description

In gnome-nettools, If you want to see the information about your network interface (after "IP Information" label) you can notice that is not displayed correctly, see the attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: gnome-nettool 3.0.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
Uname: Linux 3.0-3-generic i686
Architecture: i386
Date: Wed Jul 6 14:03:15 2011
ExecutablePath: /usr/bin/gnome-nettool
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=es_CL:es
 LANG=es_CL.UTF-8
SourcePackage: gnome-nettool
UpgradeStatus: No upgrade log present (probably fresh install)

Victor Vargas (kamus) wrote :
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=654117

Changed in gnome-nettool (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in gnome-nettool:
importance: Unknown → Critical
status: Unknown → New
Matt Fischer (mfisch) on 2011-11-27
Changed in gnome-nettool (Ubuntu):
assignee: nobody → Matt Fischer (mfisch)
status: Triaged → In Progress
Changed in gnome-nettool (Ubuntu):
importance: Low → Medium
Sam_ (and-sam) on 2011-11-28
tags: added: amd64 unity
Warren Hill (warren-hill) wrote :

Other problems. If you go to the ping tab and enter a valid address say "www.bbc.co.uk" or anything else the box displaying the IP address is too small to read

Yes, everyone experiencing same problem.

On 3 December 2011 19:53, Warren Hill <email address hidden> wrote:

> Other problems. If you go to the ping tab and enter a valid address say
> "www.bbc.co.uk" or anything else the box displaying the IP address is
> too small to read
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (885111).
> https://bugs.launchpad.net/bugs/806606
>
> Title:
> ip information frame not displayed correctly
>
> Status in GNOME Nettool:
> New
> Status in “gnome-nettool” package in Ubuntu:
> In Progress
>
> Bug description:
> In gnome-nettools, If you want to see the information about your
> network interface (after "IP Information" label) you can notice that
> is not displayed correctly, see the attached screenshot.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-nettool 3.0.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic i686
> Architecture: i386
> Date: Wed Jul 6 14:03:15 2011
> ExecutablePath: /usr/bin/gnome-nettool
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
> ProcEnviron:
> SHELL=/bin/bash
> LANGUAGE=es_CL:es
> LANG=es_CL.UTF-8
> SourcePackage: gnome-nettool
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-nettool/+bug/806606/+subscriptions
>

--

*Rishad. A*
Thiruvanthapuram <http://goo.gl/maps/h0QO>
Kerala, India

 <email address hidden>
0091 94 005 91326
 0091 94 003 28205 (Not available now)

Matt Fischer (mfisch) wrote :

That issue is covered here:

891852 Network Tools: Obstruction of Ping tab contents.

https://bugs.launchpad.net/ubuntu/+source/gnome-nettool/+bug/891852

tags: added: gnome-session-fallback
Paul White (paulw2u) on 2011-12-08
tags: added: precise
Matt Fischer (mfisch) wrote :

I have a proposed fix for this in my PPA: ppa:mfisch/gnome-nettool

Directions on how to add it and what it fixes are on the PPA page:
https://launchpad.net/~mfisch/+archive/gnome-nettool

florin (florin-arjocu) wrote :

I just installed the proposed nettool from Matt's PPA and it seems to have fixed the bug. Congratulations and thank you for the update!

Knute Holian (knute) wrote :

I also installed Matt's proposed nettool fix. It looks like it's fixed!
Nice job, Matt.

On Tue, Dec 20, 2011 at 1:16 PM, Matt Fischer <email address hidden>wrote:

> I have a proposed fix for this in my PPA: ppa:mfisch/gnome-nettool
>
> Directions on how to add it and what it fixes are on the PPA page:
> https://launchpad.net/~mfisch/+archive/gnome-nettool
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (877020).
> https://bugs.launchpad.net/bugs/806606
>
> Title:
> ip information frame not displayed correctly
>
> Status in GNOME Nettool:
> New
> Status in “gnome-nettool” package in Ubuntu:
> In Progress
>
> Bug description:
> In gnome-nettools, If you want to see the information about your
> network interface (after "IP Information" label) you can notice that
> is not displayed correctly, see the attached screenshot.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-nettool 3.0.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic i686
> Architecture: i386
> Date: Wed Jul 6 14:03:15 2011
> ExecutablePath: /usr/bin/gnome-nettool
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
> ProcEnviron:
> SHELL=/bin/bash
> LANGUAGE=es_CL:es
> LANG=es_CL.UTF-8
> SourcePackage: gnome-nettool
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-nettool/+bug/806606/+subscriptions
>

--
Knute Holian
Holian Computer Services
<email address hidden>
307-214-7575

Good job, Matt! But let me make a question: how can we become this official? I mean how can we make Matt's solution an official update from Canonical? I'm new here and I'd like to understand the process.

Matt Fischer (mfisch) wrote :

I have sent a patch for this and a few others issues to the maintainer and he will look at it after the holiday break. The official fix will come from a new version upstream and I'll pull it back into the build for precise (12.04).

Louis Passano III (lp3825) wrote :

I have applied the ops and it works.
On Dec 22, 2011 10:20 AM, "Matt Fischer" <email address hidden> wrote:

> I have sent a patch for this and a few others issues to the maintainer
> and he will look at it after the holiday break. The official fix will
> come from a new version upstream and I'll pull it back into the build
> for precise (12.04).
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (904814).
> https://bugs.launchpad.net/bugs/806606
>
> Title:
> ip information frame not displayed correctly
>
> Status in GNOME Nettool:
> New
> Status in “gnome-nettool” package in Ubuntu:
> In Progress
>
> Bug description:
> In gnome-nettools, If you want to see the information about your
> network interface (after "IP Information" label) you can notice that
> is not displayed correctly, see the attached screenshot.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-nettool 3.0.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic i686
> Architecture: i386
> Date: Wed Jul 6 14:03:15 2011
> ExecutablePath: /usr/bin/gnome-nettool
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
> ProcEnviron:
> SHELL=/bin/bash
> LANGUAGE=es_CL:es
> LANG=es_CL.UTF-8
> SourcePackage: gnome-nettool
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-nettool/+bug/806606/+subscriptions
>

Warren Hill (warren-hill) wrote :

Well done Matt.

All issues with the UI now appear to be fixed.

Changed in gnome-nettool:
status: New → Fix Released
Clark Leach (clark-leach) wrote :

I still have the problem in my Xubuntu/XFCE desktop. Not sure if it is present in the crappy POS unity desktop since I can't even find anything, much less make anything useful happen. I followed the directions for adding the PPA as described, but that left me wondering how to install the actual fix since I can't find it anywhere in the Ubuntu Software Center. This kind of crap makes Windoze look much better than it should.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-nettool - 3.1.1-0ubuntu1

---------------
gnome-nettool (3.1.1-0ubuntu1) precise; urgency=low

  * Merge with Debian unstable. Remaining Ubuntu changes:
    - Launchpad integration:
      o Add 02_lpi.patch.
      o debian/control.in: Build-depend on liblaunchpad-integration-3.0-dev
        and dh-autoreconf.
      o debian/rules: Use dh-autoreconf.
    - Use iputils-tracepath instead of tcptraceroute, so that this works as
      user:
      o Add 03_use_tracepath.patch.
      o debian/control.in: Change dependency accordingly.
    - debian/watch: Look for unstable versions.
  * Drop 04_menu_change.patch, obsolete with Unity.
  * 02_lpi.patch: Update to actually work with current version, thanks
    Sebastien Bacher.
  * debian/watch: Fix syntax.
  * New upstream release.
    - Fix traceroute mouseover help. (LP: #841007)
    - Fix IP information table. (LP: #806606)
    - Fix resizing of ping table. (LP: #389153)
  * Drop 03_use_tracepath.patch, upstream supports this directly now.
 -- Martin Pitt <email address hidden> Wed, 22 Feb 2012 12:47:15 +0100

Changed in gnome-nettool (Ubuntu):
status: In Progress → Fix Released

I can't help but notice the status says "fix released" yet the problem is still there. My machines are up to date and I am still having this problem, as well as other folks.

Screenshot attached.

hebbet (hebbet) wrote :

it is fixed in ubunut 12.04 aka precise

I realized you guys have fixed the problem in the next release version, but why not patch the latest supported version used by 11.10 so folks do not have to bend over backwards to get this program working?

z3z (z3z) wrote :

@Ronnie, Agreed. I feel it's a little excessive to suggest upgrading your whole OS in order to fix a little bug like this. If a patch has been issued, it should surely be pushed out to every currently supported release that is affected by the bug.

rishad2m8 (rishad2m8) wrote :

this is the one problem with ubuntu.

On 24 March 2012 22:18, Ronnie McMaster <email address hidden> wrote:

> I realized you guys have fixed the problem in the next release version,
> but why not patch the latest supported version used by 11.10 so folks do
> not have to bend over backwards to get this program working?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (885111).
> https://bugs.launchpad.net/bugs/806606
>
> Title:
> ip information frame not displayed correctly
>
> Status in GNOME Nettool:
> Fix Released
> Status in “gnome-nettool” package in Ubuntu:
> Fix Released
>
> Bug description:
> In gnome-nettools, If you want to see the information about your
> network interface (after "IP Information" label) you can notice that
> is not displayed correctly, see the attached screenshot.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-nettool 3.0.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic i686
> Architecture: i386
> Date: Wed Jul 6 14:03:15 2011
> ExecutablePath: /usr/bin/gnome-nettool
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
> ProcEnviron:
> SHELL=/bin/bash
> LANGUAGE=es_CL:es
> LANG=es_CL.UTF-8
> SourcePackage: gnome-nettool
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-nettool/+bug/806606/+subscriptions
>

--

*Rishad. A*
Thiruvanthapuram <http://goo.gl/maps/h0QO>
Kerala, India

 <email address hidden>
0091 94 005 91326
 0091 94 003 28205 (Not available now)

Knute Holian (knute) wrote :

My Gnome Nettool is fixed in ubuntu 11.10 with current updates applied on 2
laptops and one desktop. I checked the tool in both Gnome3 and Unity. The
problem is fixed and working well for me.

Knute Holian

On Sat, Mar 24, 2012 at 10:40 AM, Ronnie McMaster <<email address hidden>
> wrote:

> I can't help but notice the status says "fix released" yet the problem
> is still there. My machines are up to date and I am still having this
> problem, as well as other folks.
>
> Screenshot attached.
>
> ** Attachment added: "Screenshot at 2012-03-24 09:28:52.png"
>
> https://bugs.launchpad.net/ubuntu/+source/gnome-nettool/+bug/806606/+attachment/2929729/+files/Screenshot%20at%202012-03-24%2009%3A28%3A52.png
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (877020).
> https://bugs.launchpad.net/bugs/806606
>
> Title:
> ip information frame not displayed correctly
>
> Status in GNOME Nettool:
> Fix Released
> Status in “gnome-nettool” package in Ubuntu:
> Fix Released
>
> Bug description:
> In gnome-nettools, If you want to see the information about your
> network interface (after "IP Information" label) you can notice that
> is not displayed correctly, see the attached screenshot.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-nettool 3.0.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic i686
> Architecture: i386
> Date: Wed Jul 6 14:03:15 2011
> ExecutablePath: /usr/bin/gnome-nettool
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
> ProcEnviron:
> SHELL=/bin/bash
> LANGUAGE=es_CL:es
> LANG=es_CL.UTF-8
> SourcePackage: gnome-nettool
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-nettool/+bug/806606/+subscriptions
>

--
Knute Holian
Holian Computer Services
<email address hidden>
307-214-7575

z3z (z3z) wrote :

I'm still on version 3.0 of Nettools. I believe the issue is fixed in version 3.1. The newer version isn't available to me in the Repositories and I'm unwilling to add a PPA for this.

Knute, what version of Nettool are you running?

rishad2m8 (rishad2m8) wrote :
Download full text (3.5 KiB)

are you using amd64 or x86?

On 24 March 2012 23:05, Knute Holian <email address hidden> wrote:

> My Gnome Nettool is fixed in ubuntu 11.10 with current updates applied on 2
> laptops and one desktop. I checked the tool in both Gnome3 and Unity. The
> problem is fixed and working well for me.
>
> Knute Holian
>
> On Sat, Mar 24, 2012 at 10:40 AM, Ronnie McMaster <
> <email address hidden>
> > wrote:
>
> > I can't help but notice the status says "fix released" yet the problem
> > is still there. My machines are up to date and I am still having this
> > problem, as well as other folks.
> >
> > Screenshot attached.
> >
> > ** Attachment added: "Screenshot at 2012-03-24 09:28:52.png"
> >
> >
> https://bugs.launchpad.net/ubuntu/+source/gnome-nettool/+bug/806606/+attachment/2929729/+files/Screenshot%20at%202012-03-24%2009%3A28%3A52.png
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (877020).
> > https://bugs.launchpad.net/bugs/806606
> >
> > Title:
> > ip information frame not displayed correctly
> >
> > Status in GNOME Nettool:
> > Fix Released
> > Status in “gnome-nettool” package in Ubuntu:
> > Fix Released
> >
> > Bug description:
> > In gnome-nettools, If you want to see the information about your
> > network interface (after "IP Information" label) you can notice that
> > is not displayed correctly, see the attached screenshot.
> >
> > ProblemType: Bug
> > DistroRelease: Ubuntu 11.10
> > Package: gnome-nettool 3.0.0-0ubuntu2
> > ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> > Uname: Linux 3.0-3-generic i686
> > Architecture: i386
> > Date: Wed Jul 6 14:03:15 2011
> > ExecutablePath: /usr/bin/gnome-nettool
> > InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386
> (20110705.1)
> > ProcEnviron:
> > SHELL=/bin/bash
> > LANGUAGE=es_CL:es
> > LANG=es_CL.UTF-8
> > SourcePackage: gnome-nettool
> > UpgradeStatus: No upgrade log present (probably fresh install)
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/gnome-nettool/+bug/806606/+subscriptions
> >
>
>
> --
> Knute Holian
> Holian Computer Services
> <email address hidden>
> 307-214-7575
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (885111).
> https://bugs.launchpad.net/bugs/806606
>
> Title:
> ip information frame not displayed correctly
>
> Status in GNOME Nettool:
> Fix Released
> Status in “gnome-nettool” package in Ubuntu:
> Fix Released
>
> Bug description:
> In gnome-nettools, If you want to see the information about your
> network interface (after "IP Information" label) you can notice that
> is not displayed correctly, see the attached screenshot.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-nettool 3.0.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic i686
> Architecture: i386
> Date: Wed Jul 6 14:03:15 2011
> ExecutablePath: /usr/bin/gnome-nettool
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
> ProcEnviron:
> SHELL=/bin/bash
> LANGUAGE=es_CL:es
> LANG=es_CL.UTF-8
> S...

Read more...

z3z (z3z) wrote :

I'm using AMD64. Is this an AMD64 issue, anyone know?

rishad2m8 (rishad2m8) wrote :

Sorry Rrrrube, My question is confusing.
My question is to Knute Holian.
Which architecture you are using Knute Holian.

On 24 March 2012 23:15, Rrrrube <email address hidden> wrote:

> I'm still on version 3.0 of Nettools. I believe the issue is fixed in
> version 3.1. The newer version isn't available to me in the Repositories
> and I'm unwilling to add a PPA for this.
>
> Knute, what version of Nettool are you running?
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (885110).
> https://bugs.launchpad.net/bugs/806606
>
> Title:
> ip information frame not displayed correctly
>
> Status in GNOME Nettool:
> Fix Released
> Status in “gnome-nettool” package in Ubuntu:
> Fix Released
>
> Bug description:
> In gnome-nettools, If you want to see the information about your
> network interface (after "IP Information" label) you can notice that
> is not displayed correctly, see the attached screenshot.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-nettool 3.0.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic i686
> Architecture: i386
> Date: Wed Jul 6 14:03:15 2011
> ExecutablePath: /usr/bin/gnome-nettool
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
> ProcEnviron:
> SHELL=/bin/bash
> LANGUAGE=es_CL:es
> LANG=es_CL.UTF-8
> SourcePackage: gnome-nettool
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-nettool/+bug/806606/+subscriptions
>

--

*Rishad. A*
Thiruvanthapuram <http://goo.gl/maps/h0QO>
Kerala, India

 <email address hidden>
0091 94 005 91326
 0091 94 003 28205 (Not available now)

florin (florin-arjocu) wrote :

Actually @Rrrrube is right, amd64 still has the problem. My system was quite recently reinstalled and gnome-nettool 3.0.0 IP information list is not readable.

See this for screenshot: http://goo.gl/slNy5

Knute Holian (knute) wrote :
Download full text (3.9 KiB)

I am running 64bit Ubuntu 11.10. However, I have to amend my first
statement that all three of my computers were displaying correctly.

   1. My first laptop displays nettool correctly.
   2. My desktop displays nettool correctly only after I change the focus
   from the loopback adapter to the ethernet adapter. doWhen I switch back to
   the loopback it still displays correctly.
   3. My second laptop (fresh install of ubuntu 11.10 - 64bit three days
   ago) does not display nettool correctly even if I change the adapter focus.

All three computers show the version of nettool as 3.0.0.

I'm not sure why the inconsistency exists. I don't remember running the ppa
update on any of the computers, but if I did, wouldn't the version be
different?

Knute Holian

On Sat, Mar 24, 2012 at 12:07 PM, rishad2m8 <email address hidden>wrote:

> Sorry Rrrrube, My question is confusing.
> My question is to Knute Holian.
> Which architecture you are using Knute Holian.
>
>
> On 24 March 2012 23:15, Rrrrube <email address hidden> wrote:
>
> > I'm still on version 3.0 of Nettools. I believe the issue is fixed in
> > version 3.1. The newer version isn't available to me in the Repositories
> > and I'm unwilling to add a PPA for this.
> >
> > Knute, what version of Nettool are you running?
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (885110).
> > https://bugs.launchpad.net/bugs/806606
> >
> > Title:
> > ip information frame not displayed correctly
> >
> > Status in GNOME Nettool:
> > Fix Released
> > Status in “gnome-nettool” package in Ubuntu:
> > Fix Released
> >
> > Bug description:
> > In gnome-nettools, If you want to see the information about your
> > network interface (after "IP Information" label) you can notice that
> > is not displayed correctly, see the attached screenshot.
> >
> > ProblemType: Bug
> > DistroRelease: Ubuntu 11.10
> > Package: gnome-nettool 3.0.0-0ubuntu2
> > ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> > Uname: Linux 3.0-3-generic i686
> > Architecture: i386
> > Date: Wed Jul 6 14:03:15 2011
> > ExecutablePath: /usr/bin/gnome-nettool
> > InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386
> (20110705.1)
> > ProcEnviron:
> > SHELL=/bin/bash
> > LANGUAGE=es_CL:es
> > LANG=es_CL.UTF-8
> > SourcePackage: gnome-nettool
> > UpgradeStatus: No upgrade log present (probably fresh install)
> >
> > To manage notifications about this bug go to:
> > https://bugs.launchpad.net/gnome-nettool/+bug/806606/+subscriptions
> >
>
>
> --
>
>
> *Rishad. A*
> Thiruvanthapuram <http://goo.gl/maps/h0QO>
> Kerala, India
>
> <email address hidden>
> 0091 94 005 91326
> 0091 94 003 28205 (Not available now)
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (877020).
> https://bugs.launchpad.net/bugs/806606
>
> Title:
> ip information frame not displayed correctly
>
> Status in GNOME Nettool:
> Fix Released
> Status in “gnome-nettool” package in Ubuntu:
> Fix Released
>
> Bug description:
> In gnome-nettools, If you want to see the information about your
> network interface (after "IP Informati...

Read more...

rishad2m8 (rishad2m8) wrote :
Download full text (5.6 KiB)

Is that the only problem with AMD64?
I'm using AMD64 too.

On 24 March 2012 23:58, Knute Holian <email address hidden> wrote:

> I am running 64bit Ubuntu 11.10. However, I have to amend my first
> statement that all three of my computers were displaying correctly.
>
>
> 1. My first laptop displays nettool correctly.
> 2. My desktop displays nettool correctly only after I change the focus
> from the loopback adapter to the ethernet adapter. doWhen I switch back
> to
> the loopback it still displays correctly.
> 3. My second laptop (fresh install of ubuntu 11.10 - 64bit three days
> ago) does not display nettool correctly even if I change the adapter
> focus.
>
> All three computers show the version of nettool as 3.0.0.
>
> I'm not sure why the inconsistency exists. I don't remember running the ppa
> update on any of the computers, but if I did, wouldn't the version be
> different?
>
> Knute Holian
>
> On Sat, Mar 24, 2012 at 12:07 PM, rishad2m8
> <email address hidden>wrote:
>
> > Sorry Rrrrube, My question is confusing.
> > My question is to Knute Holian.
> > Which architecture you are using Knute Holian.
> >
> >
> > On 24 March 2012 23:15, Rrrrube <email address hidden> wrote:
> >
> > > I'm still on version 3.0 of Nettools. I believe the issue is fixed in
> > > version 3.1. The newer version isn't available to me in the
> Repositories
> > > and I'm unwilling to add a PPA for this.
> > >
> > > Knute, what version of Nettool are you running?
> > >
> > > --
> > > You received this bug notification because you are subscribed to a
> > > duplicate bug report (885110).
> > > https://bugs.launchpad.net/bugs/806606
> > >
> > > Title:
> > > ip information frame not displayed correctly
> > >
> > > Status in GNOME Nettool:
> > > Fix Released
> > > Status in “gnome-nettool” package in Ubuntu:
> > > Fix Released
> > >
> > > Bug description:
> > > In gnome-nettools, If you want to see the information about your
> > > network interface (after "IP Information" label) you can notice that
> > > is not displayed correctly, see the attached screenshot.
> > >
> > > ProblemType: Bug
> > > DistroRelease: Ubuntu 11.10
> > > Package: gnome-nettool 3.0.0-0ubuntu2
> > > ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> > > Uname: Linux 3.0-3-generic i686
> > > Architecture: i386
> > > Date: Wed Jul 6 14:03:15 2011
> > > ExecutablePath: /usr/bin/gnome-nettool
> > > InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386
> > (20110705.1)
> > > ProcEnviron:
> > > SHELL=/bin/bash
> > > LANGUAGE=es_CL:es
> > > LANG=es_CL.UTF-8
> > > SourcePackage: gnome-nettool
> > > UpgradeStatus: No upgrade log present (probably fresh install)
> > >
> > > To manage notifications about this bug go to:
> > > https://bugs.launchpad.net/gnome-nettool/+bug/806606/+subscriptions
> > >
> >
> >
> > --
> >
> >
> > *Rishad. A*
> > Thiruvanthapuram <http://goo.gl/maps/h0QO>
> > Kerala, India
> >
> > <email address hidden>
> > 0091 94 005 91326
> > 0091 94 003 28205 (Not available now)
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (877020).
> > https://bugs.launchpad.net/bugs...

Read more...

Germán Poo-Caamaño (gpoo) wrote :

Stable distributions only make updates between minor releases, not between major releases.
This avoid the introduction of regressions in other places.

Nevertheless, gnome-nettool 3.0.1 was released in January and there is no update in Ubuntu.
You can file a bug for getting that package into 11.10.

However, gnome-nettool 3.0.1 does not include the fix for this particular bug because the
solution implies a change in the UI. Therefore it was included in gnome-nettool 3.1, which is
is a development version of the next gnome 3.2 (not released yet).

A.K.Karthikeyan (mindaslab) wrote :

I have upgraded to 12.04 beta and found that thisissue has been fixed. Yup
for those who are in 11.10, its still a problem.

2012/3/25 Germán Poo-Caamaño <email address hidden>

> Stable distributions only make updates between minor releases, not between
> major releases.
> This avoid the introduction of regressions in other places.
>
> Nevertheless, gnome-nettool 3.0.1 was released in January and there is no
> update in Ubuntu.
> You can file a bug for getting that package into 11.10.
>
> However, gnome-nettool 3.0.1 does not include the fix for this particular
> bug because the
> solution implies a change in the UI. Therefore it was included in
> gnome-nettool 3.1, which is
> is a development version of the next gnome 3.2 (not released yet).
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (936649).
> https://bugs.launchpad.net/bugs/806606
>
> Title:
> ip information frame not displayed correctly
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-nettool/+bug/806606/+subscriptions
>

--
Nothing is constant

Regards

A.K.Karthikeyan

Matt Fischer (mfisch) wrote :

If you want a fix for 11.10, use the PPA version that is listed way up above in the thread:

https://launchpad.net/~mfisch/+archive/gnome-nettool

Thank you Matt,
it works perfectly for me !

Jm

Le 25/03/2012 04:43, Matt Fischer a écrit :
> If you want a fix for 11.10, use the PPA version that is listed way up
> above in the thread:
>
> https://launchpad.net/~mfisch/+archive/gnome-nettool
>

PeterDz (pdzwig) wrote :

Just downloaded Nettools 3.0 via Synaptic and.... still the same problem (amd64 with Gnome3).

So what is the solution???

Peter

rishad2m8 (rishad2m8) wrote :

try ppa or wait for next release of Ubuntu (Not a good solution.).

On 7 April 2012 18:31, PeterDz <email address hidden> wrote:

> Just downloaded Nettools 3.0 via Synaptic and.... still the same problem
> (amd64 with Gnome3).
>
> So what is the solution???
>
> Peter
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (885111).
> https://bugs.launchpad.net/bugs/806606
>
> Title:
> ip information frame not displayed correctly
>
> Status in GNOME Nettool:
> Fix Released
> Status in “gnome-nettool” package in Ubuntu:
> Fix Released
>
> Bug description:
> In gnome-nettools, If you want to see the information about your
> network interface (after "IP Information" label) you can notice that
> is not displayed correctly, see the attached screenshot.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 11.10
> Package: gnome-nettool 3.0.0-0ubuntu2
> ProcVersionSignature: Ubuntu 3.0-3.4-generic 3.0.0-rc5
> Uname: Linux 3.0-3-generic i686
> Architecture: i386
> Date: Wed Jul 6 14:03:15 2011
> ExecutablePath: /usr/bin/gnome-nettool
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha i386 (20110705.1)
> ProcEnviron:
> SHELL=/bin/bash
> LANGUAGE=es_CL:es
> LANG=es_CL.UTF-8
> SourcePackage: gnome-nettool
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-nettool/+bug/806606/+subscriptions
>

--

*Rishad. A*
Thiruvanthapuram <http://goo.gl/maps/h0QO>
Kerala, India

 <email address hidden>
0091 94 005 91326
 0091 94 003 28205 (Not available now)

I'm getting this bug too on an 11.10 Intel 64 bit system. Is there any word of a fix for 11.10 rather than having to upgrade to 12.04?

florin (florin-arjocu) wrote :

I think the only solution for Natty is to use ~mfisch/+archive/gnome-nettool PPA:

sudo add-apt-repository ppa:mfisch/gnome-nettool

Then update database:
sudo apt-get update

Finally, upgrade your packages:
sudo apt-get upgrade

F.

Le 25/03/2012 04:43, Matt Fischer a écrit :
> If you want a fix for 11.10, use the PPA version that is listed way up
> above in the thread:
>
> https://launchpad.net/~mfisch/+archive/gnome-nettool
>

Ritesh Khadgaray (khadgaray) wrote :
Changed in gnome-nettool (Ubuntu Oneiric):
importance: Undecided → Low
status: New → In Progress
status: In Progress → Triaged
Ritesh Khadgaray (khadgaray) wrote :

[Impact]
Customer cannot use gnome-netool to monitor network traffic.

[Development Fix]
This has been fixed in upstream, and precise and above.

[Stable Fix]
mfisch already has posted a package to his ppa with the fix backported from upstream, which seems to have been tested by quite a few users.

https://bazaar.launchpad.net/~mfisch/ubuntu/precise/gnome-nettool/multiple-ui-fixes/view/head:/debian/patches/10_fix_ui_layout.patch

Additionally, I have attached a debdiff to this issue.

[Test Case]
* The Mouseover text for tracert textbox should read "Enter the network address to trace route ..." .

* The tooltip for Lookup should say "domain", and not "network address"

* The network tool / ping tab have been resized to display more information

* In :Devices" page, "IP Information" table should be visible.

[Regression Potential]
There is very little potential for regression.

Sebastien Bacher (seb128) wrote :

Thank you for work, we can't change strings in stable series though and it doesn't seem worth the work for the SRU team to keep doing such changes on oneiric where a new lts is out, unsubscribing sponsors and setting to wontfix for oneiric, feel free to reopen and subscribe sponsors again if you really think that should be SRUed and you get an update without string changes

Changed in gnome-nettool (Ubuntu Oneiric):
status: Triaged → Won't Fix
To post a comment you must log in.