Ubuntu

No result for ping in Gnome-Nettool

Reported by François Tissandier on 2010-10-18
256
This bug affects 54 people
Affects Status Importance Assigned to Milestone
GNOME Nettool
Fix Released
Medium
OEM Priority Project
Medium
Unassigned
gnome-nettool (Ubuntu)
Low
Mathieu Trudel-Lapierre
Maverick
Low
Mathieu Trudel-Lapierre
Natty
Low
Mathieu Trudel-Lapierre

Bug Description

Binary package hint: gnome-nettool

SRU JUSTIFICATION:
This is a minor patch that affects only the gnome-nettool application, and only its Ping tab. Regression potential is minimal to null, given that the new matching strings should catch both the old and new cases; so a new package taken on an older release (or a new release that reverts ping's behaviour in outputted data) should still work.

TEST CASES:
- Open gnome-nettool, switch to the Ping tab.
- Try to ping the local machine: enter "127.0.0.1" in the address combo box.
- Click the Ping button.

On a successful test, ping requests should pass and return values and draw bar graphs for results.
On a failed test, ping requests should not move, statistics remain not updated.

----

Slighty different problem from the previous bug reports:
Gnome-nettools does not crash, but no results are displayed.
If ran from a terminal, here it is the output (I removed a bunch of duplicated Gtk-CRITICAL errors) :

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed
command: /bin/ping ping -b -c 5 -n www.yahoo.Fr

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text: assertion `text != NULL' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text: assertion `text != NULL' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text: assertion `text != NULL' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text: assertion `text != NULL' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text: assertion `text != NULL' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel: assertion `GTK_IS_WIDGET (widget)' failed

François Tissandier (baloo) wrote :

Some complementary info:

on Maverick, up to date

Changed in gnome-nettool (Ubuntu):
importance: Undecided → Low
deepak_pm (dpkpm007) wrote :

When ping in terminal works for me . But not works with Gnome-Nettool

Tony Wood (toekneewood) wrote :

Looks like other people are getting this problem as "audit" logged it in the Ubuntu Forum --->>> http://ubuntuforums.org/showthread.php?p=10097175#post10097175

This affects me as well. Ping works in the terminal but not the GUI.

I am experiencing this bug as well.

Guy (guy-b) wrote :

Here the same on Lucid 10.4.1 up to date. Ping works in gui but by closing Gnome-Nettool I receive the errors.

Pedro Villavicencio (pedro) wrote :

This is known upstream and the bug for that is: https://bugzilla.gnome.org/show_bug.cgi?id=634749
comment there:

"The output from iputils-ping looks like this:
  64 bytes from window.gnome.org (209.132.180.167): icmp_req=1 ttl=53 time=170
ms

Since gnome-nettool looks for icmp_seq, not icmp_req, it discards all output
and considers ping fails."

Changed in gnome-nettool (Ubuntu):
status: New → Triaged
johnmay (jshall42) wrote :

This issue affects me as well.

I am not sure how the information I have could change the priority, or even if the two are related, though I suspect.

I configured my guest XP on virtualbox to share the internet connection it has with a wnda3100 v2 usb adapter.
Since no 64 bit drivers were written, ndiswrapper does not help to connect straight to 10.10

I was able to then ping outside hosts from my ubuntu client. However I was not able to get firefox to recognize any external addresses. (ping virtual default gateway, physical default gateway and google)

I ma using 64 bit 10.10, and sharing the USB connection is the closest I have gotten to having my wireless sub supplying a connection to my meerkat host.

OSI would say layer three of four?

Seems that fixing this bug might allow for a large portion of wireless connection devices to be ubuntuble.
Definitely interested in any progress and information regarding the issue.

Changed in gnome-nettool:
importance: Unknown → Medium
status: Unknown → New
Gary M (garym) on 2010-12-30
tags: added: natty regression-release
tags: added: maverick
removed: natty
sonicsteve (slougheed-bcs) wrote :

Same problem here,

I have thread in the forums about this also.

http://ubuntuforums.org/showthread.php?p=10362988#post10362988

I would love to find a work around for this other than the terminal. I like the saved ping history since I ping the same thing quite often in my network support. Terminal works and is fine but I like the nettools I hope they get this sorted soon.

rod singleton (rod40cool) wrote :

This bug affects me too. Ubuntu 10.10 64 bit.
Network Tools 2.31.6
Ping doesn't work where the same ping in a terminal does.
rod@rods-t400:~$ uname -a
Linux rods-t400 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:44 UTC 2011 x86_64 GNU/Linux

Ron Lusk (luskwater) wrote :

I've submitted a patch at https://bugzilla.gnome.org/show_bug.cgi?id=634749 which involves adding a non-capturing scanf directive to the PING_FORMAT declarations. (I've been able to test that the linux branch of the code should work—in a separate program—but unable to build gnome-nettool because of a package I can't find.)

tags: added: patch
Ron Lusk (luskwater) wrote :

Apologies for the duplicate entry: I wanted to give GroundControl a try, and figured I'd use it on something I was familiar with.

Mark Garrow (scunizi) wrote :

I also suffer from this bug. 64 bit 10.10 ... also following but #662947 which is marked as a duplicate of this but those commenting on that thread seem to think it's different for some reason..

Eugene Horohorin (genixoid) wrote :

Ubuntu 11.04 (Beta), ping is not working from UI and working well in terminal.

skewty (skewty) wrote :

@Gary M:
     Why did you remove the Natty tag?
     This bug is still present in Natty 11.04 beta 2.

Shang Wu (shangwu) on 2011-04-27
Changed in oem-priority:
importance: Undecided → Medium
Changed in oem-priority:
assignee: nobody → Canonical Platform QA Team (canonical-platform-qa)
Pedro Villavicencio (pedro) wrote :

Folks from the desktop team could somebody have a look to this? I've tried the patch from the upstream bug and it works fine.

Changed in gnome-nettool (Ubuntu):
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Changed in oem-priority:
assignee: Canonical Platform QA Team (canonical-platform-qa) → nobody
assignee: nobody → Pedro Villavicencio (pvillavi)
assignee: Pedro Villavicencio (pvillavi) → nobody
Changed in gnome-nettool (Ubuntu):
assignee: Canonical Desktop Team (canonical-desktop-team) → Mathieu Trudel-Lapierre (mathieu-tl)
status: Triaged → In Progress

Just checked and tested it and it looks fine to me; I'll prepare updated packages for Maverick and Natty.

Changed in gnome-nettool (Ubuntu Maverick):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in gnome-nettool (Ubuntu Natty):
assignee: nobody → Mathieu Trudel-Lapierre (mathieu-tl)
Changed in gnome-nettool (Ubuntu Maverick):
importance: Undecided → Low
Changed in gnome-nettool (Ubuntu Natty):
importance: Undecided → Low
Changed in gnome-nettool (Ubuntu Maverick):
status: New → In Progress
Changed in gnome-nettool (Ubuntu Natty):
status: New → In Progress
Martin Pitt (pitti) wrote :

This is already in 3.0.0 which is in oneiric.

Changed in gnome-nettool (Ubuntu):
status: In Progress → Fix Released

Martin, yeah, that's because I was too slow at poking someone for review, and in the meantime 3.0.0 was merged in. I'm working on the SRU updates now.

description: updated
Chris Coulson (chrisccoulson) wrote :

I've uploaded the changes to maverick-proposed/natty-proposed now

Accepted gnome-nettool into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-nettool (Ubuntu Maverick):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

Accepted gnome-nettool into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in gnome-nettool (Ubuntu Natty):
status: In Progress → Fix Committed
Wally Arms (armsw-crescent) wrote :

works now, thanks for the fix

Works now. Thanks.

2011/5/21 Wally Arms <email address hidden>

> works now, thanks for the fix
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/663014
>
> Title:
> No result for ping in Gnome-Nettool
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/gnome-nettool/+bug/663014/+subscribe
>

Wally, jjinco33, and possibly others who tried, could you confirm which release you tested the fix on, since it was uploaded to Natty and Maverick. Ideally, we'd need one confirmation that this work for each of Maverick and Natty.

jjinco33 (jedadiah-williams) wrote :

Natty for me.

Sent from my HTC Evo
On May 21, 2011 3:20 PM, "Mathieu Trudel-Lapierre" <email address hidden>
wrote:
> Wally, jjinco33, and possibly others who tried, could you confirm which
> release you tested the fix on, since it was uploaded to Natty and
> Maverick. Ideally, we'd need one confirmation that this work for each of
> Maverick and Natty.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/663014
>
> Title:
> No result for ping in Gnome-Nettool
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/gnome-nettool/+bug/663014/+subscribe

sonicsteve (slougheed-bcs) wrote :

Works on Maverick for me. Thanks, it's great to have the tool back.

On 11-05-21 05:11 PM, Mathieu Trudel-Lapierre wrote:
> Wally, jjinco33, and possibly others who tried, could you confirm which
> release you tested the fix on, since it was uploaded to Natty and
> Maverick. Ideally, we'd need one confirmation that this work for each of
> Maverick and Natty.
>

Thanks all for testing. Marking Natty and Maverick as verification-done

tags: added: verification-done
removed: verification-needed

I have the same problem with Network Tools on newly installed Ubuntu 11.04

Wally Arms (armsw-crescent) wrote :
Download full text (3.8 KiB)

Worked on Natty for me, sorry I forgot to mention that.

Bob if you change your update manager to include the
Pre-released updates (Natty-proposed) you should get the update.

2011/5/27 Bob Fletcher <email address hidden>

> I have the same problem with Network Tools on newly installed Ubuntu
> 11.04
>
> --
> You received this bug notification because you are a direct subscriber
> of a duplicate bug (662947).
> https://bugs.launchpad.net/bugs/663014
>
> Title:
> No result for ping in Gnome-Nettool
>
> Status in GNOME Nettool:
> New
> Status in OEM Priority Project:
> New
> Status in “gnome-nettool” package in Ubuntu:
> Fix Released
> Status in “gnome-nettool” source package in Maverick:
> Fix Committed
> Status in “gnome-nettool” source package in Natty:
> Fix Committed
>
> Bug description:
> Binary package hint: gnome-nettool
>
> SRU JUSTIFICATION:
> This is a minor patch that affects only the gnome-nettool application, and
> only its Ping tab. Regression potential is minimal to null, given that the
> new matching strings should catch both the old and new cases; so a new
> package taken on an older release (or a new release that reverts ping's
> behaviour in outputted data) should still work.
>
> TEST CASES:
> - Open gnome-nettool, switch to the Ping tab.
> - Try to ping the local machine: enter "127.0.0.1" in the address combo
> box.
> - Click the Ping button.
>
> On a successful test, ping requests should pass and return values and draw
> bar graphs for results.
> On a failed test, ping requests should not move, statistics remain not
> updated.
>
> ----
>
> Slighty different problem from the previous bug reports:
> Gnome-nettools does not crash, but no results are displayed.
> If ran from a terminal, here it is the output (I removed a bunch of
> duplicated Gtk-CRITICAL errors) :
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
> command: /bin/ping ping -b -c 5 -n www.yahoo.Fr
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text:
> assertion `text != NULL' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text:
> assertion `text != NULL' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text:
> assertion `text != NULL' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text:
> assertion `text != NULL' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text:
> assertion `text != NULL' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `G...

Read more...

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-nettool - 2.31.6-0ubuntu1.1

---------------
gnome-nettool (2.31.6-0ubuntu1.1) maverick-proposed; urgency=low

  * debian/patches/0001-ping-Handle-output-with-icmp_req.patch: fix ping format
    parsing so we get back the results in the UI. (LP: #663014)
 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 18 May 2011 16:09:45 -0400

Changed in gnome-nettool (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-nettool - 2.32.0-0ubuntu1.1

---------------
gnome-nettool (2.32.0-0ubuntu1.1) natty-proposed; urgency=low

  * debian/patches/0001-ping-Handle-output-with-icmp_req.patch: fix ping format
    parsing so we get back the results in the UI. (LP: #663014)
 -- Mathieu Trudel-Lapierre <email address hidden> Wed, 18 May 2011 15:24:29 -0400

Changed in gnome-nettool (Ubuntu Natty):
status: Fix Committed → Fix Released

Ping is working properly again. Thanks to all of you for your effort.

Ron Lusk (luskwater) wrote :
Download full text (3.7 KiB)

Great to hear it works again. Yes, thank you all for your help and your
patience.

Ron
On May 30, 2011 9:56 AM, "Alberto Salvia Novella" <email address hidden>
wrote:
> Ping is working properly again. Thanks to all of you for your effort.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/663014
>
> Title:
> No result for ping in Gnome-Nettool
>
> Status in GNOME Nettool:
> New
> Status in OEM Priority Project:
> New
> Status in “gnome-nettool” package in Ubuntu:
> Fix Released
> Status in “gnome-nettool” source package in Maverick:
> Fix Released
> Status in “gnome-nettool” source package in Natty:
> Fix Released
>
> Bug description:
> Binary package hint: gnome-nettool
>
> SRU JUSTIFICATION:
> This is a minor patch that affects only the gnome-nettool application, and
only its Ping tab. Regression potential is minimal to null, given that the
new matching strings should catch both the old and new cases; so a new
package taken on an older release (or a new release that reverts ping's
behaviour in outputted data) should still work.
>
> TEST CASES:
> - Open gnome-nettool, switch to the Ping tab.
> - Try to ping the local machine: enter "127.0.0.1" in the address combo
box.
> - Click the Ping button.
>
> On a successful test, ping requests should pass and return values and draw
bar graphs for results.
> On a failed test, ping requests should not move, statistics remain not
updated.
>
> ----
>
> Slighty different problem from the previous bug reports:
> Gnome-nettools does not crash, but no results are displayed.
> If ran from a terminal, here it is the output (I removed a bunch of
duplicated Gtk-CRITICAL errors) :
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
assertion `GTK_IS_WIDGET (widget)' failed
> command: /bin/ping ping -b -c 5 -n www.yahoo.Fr
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text:
> assertion `text != NULL' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text:
> assertion `text != NULL' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text:
> assertion `text != NULL' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text:
> assertion `text != NULL' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_entry_set_text:
> assertion `text != NULL' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
> (gnome-nettool:9846): Gtk-CRITICAL **: IA__gtk_widget_get_toplevel:
> assertion `GTK_IS_WIDGET (widget)' failed
>
...

Read more...

Steve Magoun (smagoun) on 2011-06-02
Changed in oem-priority:
status: New → Fix Released
Changed in gnome-nettool:
status: New → Fix Released
tags: added: testcase
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.