(Gutsy) Looking up certain ips in whois tab freezes network-tools

Bug #164552 reported by nowshining on 2007-11-22
14
Affects Status Importance Assigned to Milestone
GNOME Nettool
Fix Released
Critical
gnome-nettool (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

when searching for the info. on ip 146.134.8.125 in the whois tab in network tools it freezes - network tools 2.20.0 and having to force quit it to exit out of it..

Also it says when getting SOME info before it freezes Latino American ip registry however on http://network-tools.com/default.asp?prog=whois&host=146.134.8.125 it shows diff. and that site gets all the info. and I suppose all websites will also that query the whois registry for info. So far all other ips work fine and DO NOT freeze up network tools..

adding that I use a P4 2.66ghz - 32-bit computer.

nowshining (nowshining) on 2007-11-22
description: updated
description: updated

I also confirm that issue on Gutsy 64 bit running on my Intel PC.

nowshining (nowshining) wrote :

adding that these ips do the same also one just acts like it is still downloading whois info even tho it isn't and it was done..

190.154.124.200
200.86.35.235
24.195.183.241 - finishes getting whois info. however bar at bottom acts like it has NOT.
200.101.177.110

nowshining (nowshining) wrote :

i uused xprop | grep WM_CLASS to determine that network tools is the stated above package, if it's not the cause please input it into the right category someone wills ya.. :)

Pedro Villavicencio (pedro) wrote :

whois from the command line works fine with those IPS address, will forward upstream to see what they think about it, thanks you.

Changed in gnome-nettool:
status: Confirmed → Triaged
Pedro Villavicencio (pedro) wrote :
Changed in gnome-nettool:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
Changed in gnome-nettool:
status: Unknown → New

I have solved this bug.
The problem was with particular char for example with address 146.134.8.125 one string is: "Marco Antônio Raupp"
I have solved with changing the encoding (local charset -> ISO-8859-1) only for this problematic string.

Germán Poo-Caamaño (gpoo) wrote :

Fix committed in upstream.

Changed in gnome-nettool (Ubuntu):
status: Triaged → Fix Committed
Changed in gnome-nettool:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-nettool - 2.28.0-0ubuntu1

---------------
gnome-nettool (2.28.0-0ubuntu1) karmic; urgency=low

  * New upstream release: (LP: #434939)
    - Fix glibtop initialization order in order to make it work on BSD
    - Compilation fixes for DragonFly BSD
    - Made some tooltips translatable
    - Avoid freeze in whois tab when encoding isn't the expected one
      (LP: #164552)
    - Fix compilation for DragonFly BSD
    - Use GtkBuilder instead of libglade
    - Translation updates
  * debian/patches/03_autoconf.patch: refreshed.

 -- Robert Ancell <email address hidden> Wed, 23 Sep 2009 09:48:44 +1000

Changed in gnome-nettool (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-nettool:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.