Ubuntu

Feisty usb stick Cannot eject volume

Reported by Esko Kauppinen on 2007-03-31
This bug report is a duplicate of:  Bug #63090: do not eject all USB/Firewire devices. Edit Remove
26
Affects Status Importance Assigned to Milestone
gnome-mount (Ubuntu)
Undecided
Unassigned
nautilus (Ubuntu)
Undecided
Unassigned

Bug Description

I plug in a USB stick and it works ok but shows as "disk". When finished, I want to remove the stick so I right click on the icon and there is only a remove option. When I select this, it does something an soon says "cannot eject volume" and mounts it again and open a window showing its contents. Then I have to just unplug the stick and it gives me the warning of unplugging a device without unmounting.

ProblemType: Bug
Architecture: i386
Date: Sat Mar 31 22:47:49 2007
DistroRelease: Ubuntu 7.04
Uname: Linux esko-desktop 2.6.20-13-386 #2 Sun Mar 25 00:18:53 UTC 2007 i686 GNU/Linux

Alan Young (alanfyoung) wrote :

Right through this evening I've been encountering what seems to be the same bug each time I try to unmount/eject any type of removable drive or removable media (including a cd-rom as well as couple of usb hard drives) from my AMD64 version of feisty (see screenshot below).

This problem occurs whether the devices are mounted singly or in multiple.

As far as I recall, this was not happening yesterday evening, so I'm tempted to attribute this to something I picked up as part of this morning's regular updates - in particular, my suspicions center around the new gnome-mount_0.5-2ubuntu6_amd64.deb package (Modified: Fri 30 Mar 2007 20:03:45 BST) now sitting in my /var/cache/apt/archives directory.

Could this be the culprit here?

Alan Young (alanfyoung) wrote :

Bug #94582 appears to be somewhat similar. (However, I definitely was NOT encountering this particular problem at the time that Bug #94582 was filed.)

David Fokkema (dfokkema) wrote :

Look at Bug #102902, a duplicate of this one, which has a syslog dump. Interestingly, it mentions NetworkManager... Why should this be so?

Vytas (vytas) wrote :

I get the same bug with Nokia 770, but not with my good old USB stick.
Also pumount /dev/sdb1 works fine for me... gnome-volume-manager bug?

Same here. With an external USB HDD I get the bug, but not with an USB stick.

If you need further debug info just tell me :)

Martin Pitt (pitti) wrote :

Can you guys please temporarily move away /usr/share/hal/fdi/policy/10osvendor/10-storage-policy.fdi, then reboot and check if it works then? If so, then bug 63090 would be the root cause. Thanks in advance!

Sander (sanderth) wrote :

Martin:
Your workaround works for me! Thanks.
I hope an update will be released soon.

It works for me too. Thanks!

paracetamolo (marco-stronati) wrote :

In my case too the usb stick works fine while the usb hdd doesn't.
The workaround worked just fine.

This seems to have resolved the issue.

----- Original Message ----
From: Martin Pitt <email address hidden>
To: <email address hidden>
Sent: Friday, April 13, 2007 7:19:29 AM
Subject: [Bug 99538] Re: Feisty usb stick Cannot eject volume

Can you guys please temporarily move away
/usr/share/hal/fdi/policy/10osvendor/10-storage-policy.fdi, then reboot
and check if it works then? If so, then bug 63090 would be the root
cause. Thanks in advance!

--
Feisty usb stick Cannot eject volume
https://bugs.launchpad.net/bugs/99538
You received this bug notification because you are a direct subscriber
of a duplicate bug.

__________________________________________________
Do You Yahoo!?
Tired of spam? Yahoo! Mail has the best spam protection around
http://mail.yahoo.com

Gregg (gclaeys) wrote :

If I umount the drive by command line as root it works (no error). but If i right click on the desktop to "unmount the drive" or if i go by nautilus file browser and tell him to unmount the the drive it give me the error : But it still tell me that "It was not possible to unmount the device".

The work aroud did "work" as for now it does not mount back the usb device after I unmouted it, but it still gave me the error.

uname -a
Linux 2.6.20-15-generic #2 SMP Sun Apr 15 07:36:31 UTC 2007 i686 GNU/Linux

Alan Young (alanfyoung) wrote :

Some of the recent postings here have prompted me to re-test some of the assertions I made in my March 31st bug report.

I first of all try unmounting the following devices from the gui (BEFORE trying Martin Pitt's suggestion):

External USB hard drive: PROBLEM REPLICATED. Right-click on desktop icon; left click on item 10 on context menu (which reads "Eject"): problem re-occurs.

USB Pen Drive: NOT REPLICATED. Right-click on desktop icon; left click on item 10 on context menu (which reads "Eject"): device successfully unmounted.

CD-ROM: NOT REPLICATED. Right-click on desktop icon; left click on item 10 on context menu (which reads "Eject"): CD successfully unmounted and ejected.

I THEN try Martin's suggestion:

sudo mv /usr/share/hal/fdi/policy/10osvendor/10-storage-policy.fdi ~

followed by rebooting.

THIS SOLVES THE PROBLEM WITH EXTERNAL USB HARD DRIVES: Right-click on desktop icon; left click on item 10 on context menu (which now reads "Unmount Volume"): device successfully unmounted, with NO ERRORS REPORTED.

I next move the .fdi file back to /usr/share/hal/fdi/policy/10osvendor/, and reboot: The USB External Hard Drive Problem RETURNS.

I then repeat Martin's suggestion, moving the .fdi file back to my /home directory, and try again - this time WITHOUT REBOOTING: the USB External Hard Drive Problem is ONCE AGAIN SOLVED.

Finally, I check the properties of the (now much-traveled!) 10-storage-policy.fdi file: it was modified on Fri 30 Mar 2007 at 19:22:05 BST, which is completely consistent with when this bug started affecting me.

Curious that for me at least, this problem (prior to implementing Martin's workaround) now seems to be confined to External USB Hard Drives. I'm still pretty sure that back on 31st March, I was having these problems trying to unmount all kinds of removable devices / other media from my AMD64 system. Seems that other people have been having more general problems too...

Stitch (itddilu) wrote :

Hi, for me Martin Pitt's suggestion works also without rebooting....

Thanks !

I can confirm the above problem on the release version of Ubuntu 7.04 with a 250 GB external Western Digital hard drive. I don't get the problem with my 128 MB flash drive or my card reader, but when I try to unmount the external HDD (even if nothing is using it), I get the message "Cannot eject volume" and the volume immediately re-mounts again.

sudo eject "My Book" (as that is the name that comes up for the device) still works.

The workaround provided by Martin Pitt allows the volume to umount again, but I do not hear the audible "click" of the drive (which I assume is the HDD heads parking) that I did with Edgy and previous versions. So, while the workaround lets me unmount the drive again, it does not seem to unmount as "cleanly" as it did in Edgy and earlier. The device does unmount though, because it no longer appears in the list provided by the mount command.

As with Martin Pitt's suggestion (moving the file somewhere else), restoring the Edgy version of the /usr/share/hal/fdi/policy/10osvendor/10-storage-policy.fdi file (which contained many more lines than the Feisty version does) also has the same effect, but, as I said, the unmounting behaviour does not seem as clean as it did in Edgy.

Just to reiterate that this problem has only appeared for me in Feisty; in both Dapper and Edgy I don't have the issue.

umlungu-ch (umlungu) wrote :

Hello there!
I do have the same problem here. But as earlier mentioned, I can umount with <sudo eject "DATA"> or when I move my */10-storage-policy.fdi. But with the second method, I have to umount even partition separately, since it's a USB-Harddrive with ext3 and dos partitions. I hope this information helps you.
My Kernel: Linux NB-01 2.6.20-15-generic on a Thinkpad R51.

Thank you!

It seems the 10-storage-policy.fdi workaround helps, but does not
restore the behaviour from Edgy and previous.

b0ng0 (ddavetaylor) wrote :

I have had the same problem with my Western Digital 250GB External HDD. Although the solution that causes the device to "Unmount" rather than "Eject" lets you remove it without being root, the WD HDD does not 'click' when removed which indicates that it has been properly removed and the HDD has come to rest (whereas the unmounting option just stops it communicating with the PC rather than actually removing it).

When I run eject sdc1 I get the following back:

umount: /media/My Book is not in the fstab (and you are not root)
eject: unmount of `/media/My Book' failed

However, if I run sudo eject sdc1 then the device is not only removed but 'clicks' indicating that it has been properly removed. For the moment I am just using the terminal to remove it, however you should not need to be root to remove a USB device, there's no reason.

Right-clicking on the drive in Kubuntu Edgy 6.10 removed it properly (same as sudo eject sdc1 in Feisty), this was not a problem in Edgy.

UJones (johannes-eckert) wrote :

Ahh great! Thanks to b0ng0 for that nice hint. This exactly is what I recognized. It just unmounts the mount points but doesn't switch off the external hdd.
But with b0ng0's command it just disconnects the drive as it was via right-clicking under Dapper & Edgy.

Thanks a lot dude!

Vytas (vytas) wrote :

pumount /dev/your_device works [as user] if you like command line tools

Tim Cussins (skz) wrote :

Same issue. External USB hard-disk fails to eject, but USB stick is fine.

This could be a clue - I opened the "properties" dialogs for both of the above devices, and looked at the "Drive" tab. The external hard-disk is shown as "Removable: No", whereas the USB stick shows "Removable: Yes (ejectable)"

Any ideas on how to set the disk as "ejectable"? I'll have a dig around this arvo.

vanadium (ftack) wrote :

* Moving the file worked for me on a Pentium III desktop with 256 RAM. The righ-click "Eject" command changed to "Unmount".

* I did not have this issue on a laptop (Dell Latitude 800). Yet, this file was not present on that system. Both of these systems were upgraded from Ubuntu Edgy to Feisty using the graphical update tool.

b0ng0 (ddavetaylor) wrote :

Have a look at reacocard's post here:

http://ubuntuforums.org/showthread.php?t=401591&page=3

I think what he is saying is the problem/solution. It would be nice if the devs would create a fix for this.

Murat Gunes (mgunes) wrote :

I have the same issue with a WD My Book Firewire drive, except that in my case, the drive seems to eject for an instant, but immediately act as if it were plugged in again; I also get the "Cannot eject volume" error.

Tiago Silva (tiagosilva) wrote :

I was having this error with my usb pens since the beta... I assumed it was due to its beta nature!

The only way it unmount my pen disks is by going root and then umounting them.

starox (fredo-starox) wrote :

Same problem here on a ppc G5 with hard drive and usb pens.

bjoern.j (bjoern-jacobs) wrote :

Same problem here with USB sticks and hdds on Ubuntu Feisty 64bit.

FiNeX (finex) wrote :

The workaround on the 10-storage-policy.fdi file resolved my problem (the usb esternal HD doesn't umount correctly: I'd the "cannot eject volume" message error and the drive were mounted again).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments