Ubuntu

Unable to Access Floppy Drive in Ubuntu Hardy LTS (NOT Beta/ Release Candidate)

Reported by USSR on 2008-06-12
8
Affects Status Importance Assigned to Milestone
gnome-mount (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

I cannot access media in my floppy drive on my Ubuntu 8.04 32 bit installation (NOT using Live CD.). Nothing. Absolutely nothing. Just insert the floppy, click on the Menu on top "Places"-> Floppy Drive , then my floppy drive will "seemed to be reading" by having green light flashed, and the light just went off (No more light shown in the floppy drive.). No Windows shown like Floppy Drive, just like my CD , or any other partition or clicking Home Directory from the Menu bar, Places too (Which can view its content). Neither does any warning shown.

Alternatively, I can go to the left side of the window of any directory with a bar that shows places (Eg: Various Partitions, username (The Home Directory), Trash, Floppy Drive etc.)
Double Click on the Floppy drive and the result will be same. Neither can I right click the "Open or Open in the New Window" with effects (The options are NOT grey out , like Remove or Rename) and the "Rescan" does nothing too.

In Windows XP, this does not happen. I am sure my floppy drive is not spoil.
My PC is a Pentium 4 2.26GHz. I am unable to determine my motherboard and I know that my Floppy Drive is a Sony brand. (I do not know the exact model, but it is white in colour.)
Neither am I sure if this is a bug in Ubuntu/GNOME or simply hardware not supported.
I do not edit /etc/fstab and /etc/mtab for this reason (I do it for Mounting NTFS partition, but did not edit as I replaced back into original as my edition to mount these NTFS partition does not work.)

This is my /etc/fstab:

# /etc/fstab: static file system information.
#
# -- This file has been automaticly generated by ntfs-config --
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
# Entry for /dev/hda1 :
UUID=d78bea77-675b-435f-8312-c160d0352d06 / ext3 defaults,errors=remount-ro 0 1
# Entry for /dev/hda5 :
UUID=bdbb6811-a510-40ff-a6f0-92c621829ef9 none swap sw 0 0
/dev/hdc /media/cdrom0 auto rw,user,auto,exec 0 0
/dev/fd0 /media/floppy0 auto rw,user,auto,exec 0 0
UUID=B078AF2C78AEEFF0 /media/hdb1 /windows ntfs defaults,locale=zh_CN.utf8,auto 0 0

Sergio Zanchetta (primes2h) wrote :

Not sure, but assigning to gvfs.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, does mounting the floppy using gnome-mount works correctly?

Changed in gvfs:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
USSR (samuel-lee-1991) wrote :

Sorry, I do not get it. What is using gnome-mount? I only use command line "mount" command.

Sebastien Bacher (seb128) wrote :

could you open a command line, run "gnome-mount -v -b -d /dev/fd0" and attach the log to the bug?

USSR (samuel-lee-1991) wrote :

Ok, i will try that and give you a reply as soon as possible, but which log file would you want? (Where can I find that log file) I am a new Linux user, but experienced Windows user, so I do not get it.(Where I am now using school PC.)

Sebastien Bacher (seb128) wrote :

log = whatever gnome-mount writes when you try to run it, and there is no need to copy commenters on replies, just reply to the bug tracker that's enough

Here's what I get when I run:
gnome-mount -v -b -d /dev/fd0
gnome-mount 0.8
** (gnome-mount:7147): DEBUG: Mounting /org/freedesktop/Hal/devices/volume_uuid_4eef9ce8_db6f_43cf_a669_f7e201119aeb
Device /dev/fd0 is in /etc/fstab with mount point "/media/floppy0"
** Message: /bin/mount said error 8192, stdout='', stderr='mount: wrong fs type, bad option, bad superblock on /dev/fd0,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail or so

I hope this is relevant as I am using Hardy 64 bit (Athlon 64 X2 system)
Bob Pearson

Sebastien Bacher (seb128) wrote :

that shows that the issue is not a gvfs one, gnome-mount doesn't success to mount it either

Changed in gvfs:
status: Incomplete → New
peter b (b1pete) wrote :

Sebastien,

just came across this bug report; why? -because in intrepid the floppy drive was not recognized at install time and there is no entry in fstab and no floppy in /etc/module; I was puzzled.

the panel disk mounter applet does not show any floppy drive.

so, I edited/added in fstab

/dev/fd0 /media/floppy0 auto,umsdos,vfat rw,user,noauto 0 0

and created in /media floppy0 folder and added floppy to /etc/module file. after reboot still no joy.

is intrepid supposed to get the floppy drive (present) configured automatically at install time ? is the node created to this device at install time ?

regards,
peter b

peter b (b1pete) wrote :

sorry, I forgot ....

I want the floppy device to behave in a similar fashion like the usb devices when plugged in - in other words be able to save to floppy the MBR and the PBR's of my partitions using the dd command or, conversly, restore from floppy same.

regards,
peter b

Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in gnome-mount (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers