Ubuntu

"Eject" should eject the CD-ROM drive tray if empty

Reported by Christopher Yeleighton on 2008-03-18
108
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Nautilus
Won't Fix
Medium
One Hundred Papercuts
Low
Unassigned
gnome-mount (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: nautilus

Steps to reproduce:
1. Tell Nautilus to go to the computer.
2. Tell Nautilus to eject the CD-ROM drive.

Expected behaviour:
Eject the CD-ROM drive tray.

Actual behaviour:
Nautilus cannot mount the volume because the drive is empty; it displays a corresponding message box and does nothing.

ProblemType: Bug
Architecture: amd64
Date: Tue Mar 18 14:57:46 2008
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/nautilus
NonfreeKernelModules: nvidia
Package: nautilus 1:2.20.0-0ubuntu7.1
PackageArchitecture: amd64
ProcCmdline: nautilus --no-default-window --sm-client-id default2
ProcCwd: /home/giecrilj
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=pl_PL.UTF-8
 SHELL=/bin/bash
SourcePackage: nautilus
Uname: Linux a1dmin.vola.spe.com.pl 2.6.22-14-generic #1 SMP Tue Feb 12 02:46:46 UTC 2008 x86_64 GNU/Linux

Related branches

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it, because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.
 We have instructions on debugging some types of problems. http://wiki.ubuntu.com/DebuggingProcedures
At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).
Thanks!

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete

1. the specific steps or actions you took that caused me to encounter the problem:
1.1. Tell Nautilus to go to the computer. (Or tell GNOME to browse the computer).
The computer contains the CD-ROM drive.
1.2. Tell the CD-ROM drive to eject.

2. the behaviour I expected:
To eject the CD-ROM drive tray.

3. the behaviour I actually encountered:
Nautilus could not mount the volume because the drive was empty; it displayed a corresponding message box and did nothing.

Sebastien Bacher (seb128) wrote :

The bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=523884

Changed in nautilus:
status: Incomplete → Triaged
Changed in nautilus:
status: Unknown → New
Sebastien Bacher (seb128) wrote :

That's a gnome-mount issue, gnome-mount -e -d device does the same

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-mount - 0.8~svn20080225-0ubuntu2

---------------
gnome-mount (0.8~svn20080225-0ubuntu2) hardy; urgency=low

  * debian/patches/06_allow_eject_drive.patch:
    - allow to use eject on empty drives (lp: #203574)

 -- Sebastien Bacher <email address hidden> Tue, 01 Apr 2008 12:52:35 +0200

Changed in gnome-mount:
status: Triaged → Fix Released
Changed in nautilus:
status: New → Confirmed
Andreas Moog (amoog) wrote :

The fix was reverted:

gnome-mount (0.8~svn20080225-0ubuntu4) hardy; urgency=low

  * debian/patches/06_allow_eject_drive.patch:
    - don't use this change for now, it breaks the svn backport and it's better
      to be able to eject ipods rather than empty cd drives (lp: #211693)

Changed in gnome-mount:
status: Fix Released → Confirmed
Benjamin Drung (bdrung) on 2008-08-26
Changed in gnome-mount:
status: Confirmed → Triaged
Jeffrey Baker (jwbaker) wrote :

This is even more silly in Intrepid now that Nautilus shows a big, fat eject icon next to CD-ROM drives in the sidebar. nautilus 1:2.23.92-0ubuntu1

Strange thing is, typing eject from the commandline works without any problem. So it shouldn't be that hard to get nautilus to do the same thing.

Claudio Satriano (claudiodsf) wrote :

I confirm that the problem with the eject button, mentioned by Jeffrey, still holds in Nautilus 1:2.24.0-0ubuntu1
(on Intrepid, of course)

Claudio Satriano (claudiodsf) wrote :

Don't know if it helps, but I've noticed that if you connect to localhost via ssh:

  ssh -X user@localhost

and then launch

  nautilus --no-desktop

1) NFS mounted directory appear on the sidebar (they do not appear normally), along with the eject icon
2) The eject icon next to the cdrom drive does open the drive tray! However, clicking it again does not close the tray :(

Still using Nautilus 1:2.24.0-0ubuntu1 on Intrepid beta.

bitinerant (bitinerant) wrote :

Confirmed on Ubuntu 8.10 with updates. This is a particularly problematic problem on CD drives without a manual eject button (e.g. MacBook) after inserting an unreadable CD. Until I discovered this bug report, I did not know how to eject my CD without rebooting.

  gnome-mount --text --eject --device=/dev/cdrom # works on good CDs but does not eject unmountable CDs

  /usr/bin/eject # works on all CDs

Changed in gnome-mount:
assignee: desktop-bugs → seb128
assignee: seb128 → nobody
assignee: nobody → seb128
Yfrwlf (yfrwlf) wrote :

This is still occurring in Jaunty as well, but after reading https://bugs.launchpad.net/ubuntu/+source/linux/+bug/356631 specifically the part:

    - extras/cdrom_id/cdrom_id.c: Add a new key ID_CDROM_MEDIA=1 if there
      is a CD present. Also, skip media tests if CDROM_DRIVE_STATUS !=
      CDS_DISC_OK.

Skipping the check to see if a CD is in the drive first sounds like solving this issue. Can someone apply the backports or upgrade to koala and confirm this?

ShawnJGoff (shawn-goff) on 2009-06-18
Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-7
Twig (pfirth) wrote :

>> Can someone apply the backports or upgrade to koala and confirm this?

Still an issue on my Karmic test machine with all updates applied as of 29/06/09

Bryce Harrington (bryce) on 2009-08-26
summary: - "Eject" should eject the CD-ROM drive tray
+ "Eject" should eject the CD-ROM drive tray if empty

I have the same problem, but with pressing the physical "eject" button of a DVD drive... (see bug #429290).

tgpraveen (tgpraveen89) wrote :

Can someone on koala and confirm this now?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

tgpraveen wrote:
> Can someone on koala and confirm this now?
>
Still present in Karmic. It gives the error "No media in drive"
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iQEcBAEBCAAGBQJKyLSWAAoJEIltSrFpUGteY7EH/2UuTzo5KEkSQNgFk5NZ++O4
jtqqwIfG6kKI5QRCw7ZvmAwepZ1tXflAaAegn5G1/eOmYorxhRlyP14TbdhGLhKW
2auQVlodLe5vq6LG2JBaBfeAD1Yp2VkavFFQijKyejms/9r/b5yeet7gam4gJ3XG
9FnqBLGdsLPnaX0ricfA09SoborEIPyahhWQalYFPP6c7M7CQIB1VteBFQSzfsut
R4FtN8W0458C0fgkxLh+wb3sxUdYvGSeKdG6mvI7vHeF8+qjuZJunmCCqh3pZpsJ
1FT2jNrsqcFBM1/8lIemsvowYAPeSrDuXgNwxJn6OYNjlz7MOiT0ToIcqnBIFSs=
=f+f8
-----END PGP SIGNATURE-----

Tony Lewis (gnutered) wrote :

Yes, happens to me in Karmic. It's sporadic - I think the first eject after a reboot works; but now, nothing works - not the eject button, not nautilus, and not the command eject.

Will reboot and try and figure out more.

Lacking anything better, here's the output of "apport-cli /usr/bin/eject":

Architecture: amd64
Date: Tue Oct 6 22:26:59 2009
Dependencies:
 coreutils 7.4-2
 debconf 1.5.27ubuntu2
 debconf-i18n 1.5.27ubuntu2
 dpkg 1.15.4ubuntu2
 findutils 4.4.2-1
 gcc-4.4-base 4.4.1-4ubuntu6
 libacl1 2.2.47-2
 libattr1 1:2.4.43-3
 libc-bin 2.10.1-0ubuntu13
 libc6 2.10.1-0ubuntu13
 libdevmapper1.02.1 2:1.02.27-4ubuntu7
 libgcc1 1:4.4.1-4ubuntu6
 liblocale-gettext-perl 1.05-4build1
 libselinux1 2.0.85-2
 libstdc++6 4.4.1-4ubuntu6
 libtext-charwidth-perl 0.04-5build1
 libtext-iconv-perl 1.7-1build1
 libtext-wrapi18n-perl 0.06-7
 lzma 4.43-14ubuntu1
 perl-base 5.10.0-24ubuntu4
 tzdata 2009n-1
DistroRelease: Ubuntu 9.10
Package: eject 2.1.5+deb1+cvs20081104-6
PackageArchitecture: amd64
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_AU.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-11.38-generic
SourcePackage: eject
Uname: Linux 2.6.31-11-generic x86_64
XsessionErrors:
 (gnome-settings-daemon:2954): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (gnome-settings-daemon:2954): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:2980): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (nautilus:2975): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (gnome-panel:2974): Gtk-WARNING **: gtk_widget_size_allocate(): attempt to allocate widget with width -1 and height 24
 (nautilus:6177): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed
 (nautilus:6235): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed

Matiss Piesins (matissp) wrote :

If I start nautilus as root, i.e. $sudo nautilus, then I can press the small "eject" icon next to cdrom0 entry in the sidebar and it works.

Previously I thought that it is some privilege problem with gnome-mount. But, what if it is a wrong argument being passed to eject command/call?
Arguments for it:
1) Nautilus sidebar shows "CD-RW/DVD+RW drive" as user, but a simple "cdrom0" as root.
2) Running $eject as user works, but it does not work if run with some wrong identifier:
matiss@lauva:~$ eject CD-RW
eject: unable to find or open device for: `CD-RW'
not surprisingly, requesting "cdrom0" is correct:
matiss@lauva:~$ eject cdrom0
matiss@lauva:~$ (laptop's tray opened)

Same problem for me on two recent, fresh installs of Karmic, but here's the twist: This also affects KDE3.5.10 and XFCE 4.6, on two different machines with two completely different DVD devices (and a third that I threw out, thinking it was bad).

Could the same piece of software be responsible for this bug occurring on all three desktop environments?

Begin rant:

This bug was filed over a year and a half ago. Why is it still a problem!? Shortage of developers? Lack of time?

If I try to eject from the button on front, it often refuses, because the computer overrides me!

If I try to use the command line and it usually works - unless the computer overrides me!

If I try to eject using a paperclip in that little hole, it usually works - unless the computer overrides me!

(Do you folks see a pattern yet??)

I've used Linux for several years now, and I've watched some aspects of it really deteriorate over the last few years. Minor bugs I understand, but this kind of stuff defies the normal behavior of the computer (regardless of OS). Whatever caused this bug should have either been fixed or reverted long ago.

If I press the eject button, by $DIETY, that drive had better eject *unconditionally*. I don't care if there's a disc in the drive, I don't care if that disc is mounted or not, and I don't care if some random application throws an error! Eject the flippin' tray!

End rant.

Changed in hundredpapercuts:
milestone: round-7 → none
milestone: none → lucid-round-3
Vish (vish) on 2010-01-26
Changed in hundredpapercuts:
importance: Undecided → Low
Changed in gnome-mount (Ubuntu):
assignee: Sebastien Bacher (seb128) → nobody
Sebastien Bacher (seb128) wrote :

lucid doesn't use gnome-mount and has no eject for empty cdrom drives so there is no error displayed either

Vish (vish) wrote :

-Closing Papercut as we no longer use gnome-mount since Lucid [comment #21]
For further information about papercuts criteria, please read https://wiki.ubuntu.com/PaperCut.

Don't worry though, this bug has been marked as "Invalid" only in the papercuts project.

Changed in hundredpapercuts:
milestone: lucid-round-3 → none
status: Confirmed → Invalid
Changed in nautilus:
importance: Unknown → Medium
Changed in nautilus:
status: Confirmed → Won't Fix
Phillip Susi (psusi) wrote :

This package has been removed from Ubuntu. Closing all related bugs.

Changed in gnome-mount (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.