LiveCD does not mount hard disk partitions (yet)

Bug #16356 reported by Uri David Akavia on 2005-04-22
46
Affects Status Importance Assigned to Milestone
Baltix
High
Mantas Kriaučiūnas
casper (Ubuntu)
Undecided
Unassigned
gnome-mount (Ubuntu)
Wishlist
Tollef Fog Heen

Bug Description

The new Ubuntu live-cd does not create entries for existing filesystems in
/etc/fstab. This seems to be because knoppix-autoconfig is missing from the boot
process (I've played around with previous versions of liveCDs and saw that this
seems the difference).

Since the new Ubuntu CD uses isolinux, instead of miniroot system, I don't know
how to add this shell script to the boot process.

I can attach it on request.

Please do not downgrade this bug to enhancement - I've deliberately kept it with
severity normal. My logic is - if this bug happens when installing Linux (bug
six hundred and something, with partman in the title), then I can assume the
person installing knows enough to fix it.
With the LiveCD, which is used for demonstrative purposes and so forth, it is
not a safe assumption to make. In addition, since Ubuntu is a rootless system,
mounting (and allowing the user to change the files) is more problematic than an
ordinary system.

Thierry Moisan (thierryn) wrote :

Still valid for the Breezy Colony 2 live-cd.

Matt Zimmerman (mdz) wrote :

This feature is being developed according to the specification at
http://udu.wiki.ubuntu.com/MountingHDDFilesystems

Uri David Akavia (uridavid) wrote :

Why not just use the KNOPPIX file, which adds them automatically to /etc/fstab?
And are people here convinced it is an enhacement for the LIVECD?

Matt Zimmerman (mdz) wrote :

*** Bug 20441 has been marked as a duplicate of this bug. ***

I definitely see no reason why this should be just a live CD feature... Users
of an installed system need an easy way to access data on other partitions and
removable media as well.

Bill

Colin Watson (cjwatson) wrote :

(In reply to comment #5)
> I definitely see no reason why this should be just a live CD feature... Users
> of an installed system need an easy way to access data on other partitions and
> removable media as well.

The install CD is already set up this way, as of Breezy.

Timothy Miller (theosib) wrote :

I'm using the latest 5.10 available as of 2005-09-17.

(1) Ubuntu finds my 3ware card and the drives attached! Yay!
(2) My swap partition is found and mounted too!
(3) My other partitions are ignored. I know what they're called and could manually mount them if I needed to, but I'm used
to Knoppix finding them automatically, and it seems like a basic thing to do. Besides, the reason I'm looking at Kubuntu
is because I'm sick of Gentoo and having to every little thing manually. [k]ubuntu was recommended to me by other users as
a very friendly distro that's mostly automatic, so I'm going to assume anything not automatic is a bug. :)

Matt Zimmerman (mdz) wrote :

(In reply to comment #7)
> I'm using the latest 5.10 available as of 2005-09-17.
>
> (1) Ubuntu finds my 3ware card and the drives attached! Yay!
> (2) My swap partition is found and mounted too!
> (3) My other partitions are ignored. I know what they're called and could
manually mount them if I needed to, but I'm used
> to Knoppix finding them automatically, and it seems like a basic thing to do.
 Besides, the reason I'm looking at Kubuntu
> is because I'm sick of Gentoo and having to every little thing manually.
[k]ubuntu was recommended to me by other users as
> a very friendly distro that's mostly automatic, so I'm going to assume
anything not automatic is a bug. :)
>

In this case, it isn't a bug. It's a feature that we haven't yet implemented
(though it is planned).

Colin Watson (cjwatson) wrote :

Tollef was looking at polishing and integrating the initial work I did along
these lines.

Tollef Fog Heen (tfheen) wrote :

Just confirming it to get the unconfirmed count down. Will be revisited for Edgy Eft.

Changed in casper:
status: Unconfirmed → Confirmed
Mantas Kriaučiūnas (mantas) wrote :

I solved this bug in Baltix GNU/Linux 2.0 by patching pmount to allow globs in /etc/pmount.allow file (2 lines patch) and improving 02_ignored_volumes.patch in hal package - "volume.ignore" key should be set to true only when "volume.is_mounted" is true (one line fix, look at bug #48118 ).

Then I simply added one more script in casper-bottom folder from casper package, which adds 2 lines ("/dev/hd*" and "/dev/sd*") into /etc/pmount.allow and changes one line in /etc/hal/fdi/policy/preferences.fdi :
<merge key="storage.automount_enabled_hint" type="bool">true</merge>

Phillip Susi (psusi) wrote :

Is this going to make it into edgy? I ran into this the other day on dapper when I right clicked on the hard drive in gnome and chose mount, I got an error saying pmount failed. I think pmount needs to not refuse to operate on hard disks, but hal should probably not auto mount them either, or at least only mount them in ro mode.

How come you are wrting me on this?

on Wednesday 02/28/2007 Phillip Susi(<email address hidden>) wrote
 > Is this going to make it into edgy? I ran into this the other day on
 > dapper when I right clicked on the hard drive in gnome and chose mount,
 > I got an error saying pmount failed. I think pmount needs to not refuse
 > to operate on hard disks, but hal should probably not auto mount them
 > either, or at least only mount them in ro mode.
 >
 > --
 > LiveCD does not mount hard disk partitions (yet)
 > https://launchpad.net/bugs/16356

--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

         John Covici
         <email address hidden>

Matt Zimmerman (mdz) wrote :

On Wed, Feb 28, 2007 at 08:56:30PM -0000, Phillip Susi wrote:
> Is this going to make it into edgy? I ran into this the other day on
> dapper when I right clicked on the hard drive in gnome and chose mount,
> I got an error saying pmount failed. I think pmount needs to not refuse
> to operate on hard disks, but hal should probably not auto mount them
> either, or at least only mount them in ro mode.

Edgy (Ubuntu 6.10) was released last October; it has long since completed
its development and all new feature development is taking place on Ubuntu
7.04 (Feisty) to be released in April.

Subscribing Martin as he was working on related functionality.

--
 - mdz

Martin Pitt (pitti) wrote :

In feisty you can now mount hard disk partitions (see https://wiki.ubuntu.com/MountAllLocalFilesystems), also on the live CD. Thus this can be regarded as fixed now.

Changed in casper:
status: Confirmed → Fix Released
Mantas Kriaučiūnas (mantas) wrote :

Martin Pitt at 2007-03-01 11:14:23 wrote:
> In feisty you can now mount hard disk partitions (see https://wiki.ubuntu.com/MountAllLocalFilesystems), also on the live CD. Thus this can be regarded as fixed now.

I don't think so. This bug is about mounting hard disk partitions *automatically*, when LiveCD boots, but currently, in Feisty, user must mount partitions manually.

Martin, manual mounting of hard disk partitions is described in bug #48118, so, please don't close this bug until it will be really fixed.

Vincenzo Ciancia (vincenzo-ml) wrote :

Automatically mounting all partitions is a bad idea. The live cd should not access the hard disk of the machine, or it will block for ages when the disk is broken. Now, if feisty already accesses all the partitions for some reason (e.g. reading the labels, or some LVM-related thing) then it is already broken, and I will not complain if partitions are automounted :) Instead, if feisty live does not access the disk automatically, I don't see why we should do that for the purpose of mounting disks. You can always go to "resources->computer" and find your partitions (but, are they listed there? if not, that's another bug). In fact, in my feisty installed system, there is no disk partition in "resources->computer".

I agree auto-mounting from a live CD is a bad idea. Even automatically using swap on the harddrive is bad, as it could erase a hibernated state. Also, auto using the hard drive may cause problems if the reason the person is using a live cd is because the hard drive is failing. The original request was not for automatic mounting, but the ability to mount from the desktop. Presumably this should be done by creating a fstab entry for each partition on the hard-drive and mark it as no auto mounting, and mountable by the default user. Finally, an icon should be added to the desktop, to allow the person to mount simply by clicking on the icon.

Bill

Martin Pitt (pitti) wrote :

I agree, automounting partitions is actively dangerous. Besides, this is a new feature that should be handled as a spec:

  https://blueprints.launchpad.net/ubuntu/+spec/live-system-fs-mounting

In guadalinex we are working in add this feature for an edgy based version. I've done everything that is described by Mantas Kriaučiūnas trying to add support:

 * Apply patch glob-for-pmount.allow-policy.c.diff to pmount
 * Add "/dev/hd*" and "/dev/sd*" to /etc/pmount.allow (it's done from a casper bottom script)
 * Set true storage.auotmount_enabled_hint in /etc/hal/fdi/policy/preferences.fdi <merge key="storage.automount_enabled_hint" type="bool">true</merge>

Mantas also said that hal need to be patched, looking the code i realized that the version that i'm using is already patched (patch: 02_ignored_volumes.patch, version of hal: 0.5.7.1-0ubuntu17).

Not working yet... i've just realize that i changed preferences.fdi (from hal package) to set true "storage.automount_enabled_hint" but i didn't uncommen't the line... so i've to test if this solve my problem.

Still having the same problem with
<merge key="storage.automount_enabled_hint" type="bool">true</merge> uncommented.

Any clues? Mantas?

Ant (m3nt4l1st) wrote :

Ok, I don't really get all this, but at the moment I'm only running Live CD because I'm only using Ubuntu temporarily at the moment (may use it permenantly later) but for now, is there a way I can save preferences and changes I make to the settings on the Live CD - eg. to a USB drive as it can't access my hard drive (which is something to do with what your saying now - sorry I didn't read everything)

thanks - much appreciated

Vincenzo Ciancia (vincenzo-ml) wrote :

Should this be closed in baltix?

Changed in casper:
status: New → Fix Released
John Covici (covici) wrote :

I don't have the hardware which I used then, so I cannot test with the
new release.

on Wednesday 04/23/2008 Vincenzo Ciancia(<email address hidden>) wrote
 > Should this be closed in baltix?
 >
 > ** Changed in: casper (Ubuntu)
 > Status: New => Fix Released
 >
 > --
 > LiveCD does not mount hard disk partitions (yet)
 > https://bugs.launchpad.net/bugs/16356
 > You received this bug notification because you are a direct subscriber
 > of a duplicate bug.

--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

         John Covici
         <email address hidden>

jamesmcm (jamesmcm03) wrote :

The new LiveCD (8.04) mounts my main (SATA) harddrive but fails to mount (or recognise) my USB harddrive - is this a related issue?

It will auto mount usb devices. You need to install usbmount which adds new rules into udev. Then mount into /media/usb[0-7]. It actually works pretty good. If you use usb stick, then make sure turn on vfat.

http://joekuan.wordpress.com/2009/03/03/troubleshooting-on-usbmount/

On Mon, Mar 30, 2009 at 06:23:23PM -0000, Joe Kuan wrote:
> It will auto mount usb devices. You need to install usbmount which adds
> new rules into udev. Then mount into /media/usb[0-7]. It actually works
> pretty good. If you use usb stick, then make sure turn on vfat.
>
> http://joekuan.wordpress.com/2009/03/03/troubleshooting-on-usbmount/

The Ubuntu live CD will automatically mount USB devices without any
additional software or instructions. usbmount is not required or
recommended.

--
 - mdz

Martin Pitt (pitti) wrote :

Indeed. With current Ubuntu (be it live system or installed one), you can mount both removable (USB) and internal hard disks out of the box. In the installed system, mounting internal drives is restricted to admins and will ask for your password (or refuse if you are not an admin).

Przemek K. (azrael) on 2009-12-17
Changed in baltix:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.