[gutsy] Ejecting zip disk works but then gives error messages

Bug #162480 reported by Stanley Sokolow on 2007-11-13
6
Affects Status Importance Assigned to Milestone
gnome-mount (Ubuntu)
Low
Unassigned

Bug Description

Running Gutsy Gibbon 7.10 on an Intel Celeron system. After using my zip disk for read only, when I eject it with Eject command on right-click menu over zip icon, the disk ejects but then an error message appears in lower right of desktop. It says that the system is writing (flush the write buffer) onto the disk and that I shouldn't remove the disk, but it already popped out of the drive. Soon another message pops up in the center of desktop saying that it can't eject the volume (but it already has done it). This is an internal atapi Iomega Zip 100 drive. I haven't tested the eject after writing to the zip disk yet.

First question that comes to mind is why does the system think it needs to flush the write buffer onto the disk when it only has done reads. Maybe it's updating a "touched" date on the disk? Or maybe this is simply a bug.

Second, the eject actually occurs before the system realizes it needs to do the write. This is a bug.

Stan Sokolow
<email address hidden>

Stanley Sokolow (overbyte) wrote :

[Hardy 8.04 alpha 2] On this iso, I get better results with ZIP disks. I can eject by using right-click>Eject on the desktop ZIP icon, I get the popup message about the writing on the zip disk and that user should not remove the disk, but it already did eject the disk. Then a message pops up saying that it's safe to remove the (ejected) disk. If I try to eject using the eject button on the ZIP drive, nothing happens until I eject with the right-click>eject on ZIP disk icon. Then it ejects and gives the message "writing data to device" and also give the error message "cannot eject volume" even though the disk is ejected.

Martin Pitt (pitti) wrote :

Can you please mount the zip disk, then open a terminal, do

  gnome-umount -vbd /dev/sda4

(or whatever device your ZIP disk is, please look at the output of "mount" to find it out) and copy&paste the output here? Thank you!

Changed in gnome-mount:
status: New → Incomplete
Stanley Sokolow (overbyte) wrote :

Martin,
I no longer have the ATAPI ZIP disk installed in my Ubuntu computer, and I'm running release Hardy 8.04.1 now. I have an external USB Zip disk. I will update this bug report after I exercise the USB Zip further.
--Stan

Fredrik Ståhl (fredrik-stahl) wrote :

I have a similar problem with my Zip 100 Plus parallel port drive under Hardy. When ejecting a disk, sometimes it unmounts properly, but sometimes it is as if the disk is ejected before hal recognizes that it is unmounted.

Procedure:

1. Connect zip drive to parallel port and run sudo modprobe imm. The zip drive is recognized as /dev/sdg4 and an icon named "Zip Drive" appears in nautilus.

2. Insert a disk. The "Zip Drive" icon changes to whatever the disk name is. My HFS disks are recognized properly, no problems so far.

3. Right click on the zip disk icon and choose Eject. The popup message "Writing to disk" appears.

4a. If I'm lucky the popup message changes in a second to the one saying that it is safe to remove the disk and the disk ejects automatically. The icon changes back to "Zip Drive". The relevant lines from /var/log/syslog are:

Feb 17 11:14:49 amadeus hald: unmounted /dev/sdg4 from '/media/Fonts 4' on behalf of
uid 1000
Feb 17 11:14:52 amadeus NetworkManager: <debug> [1234865692.079986] nm_hal_device_rem
oved(): Device removed (hal udi is '/org/freedesktop/Hal/devices/volume_part1_size_40
960').
Feb 17 11:14:52 amadeus NetworkManager: <debug> [1234865692.086955] nm_hal_device_rem
oved(): Device removed (hal udi is '/org/freedesktop/Hal/devices/volume_part2_size_51
20').
Feb 17 11:14:52 amadeus NetworkManager: <debug> [1234865692.094285] nm_hal_device_rem
oved(): Device removed (hal udi is '/org/freedesktop/Hal/devices/volume_part3_size_20
4800').
Feb 17 11:14:52 amadeus NetworkManager: <debug> [1234865692.101504] nm_hal_device_rem
oved(): Device removed (hal udi is '/org/freedesktop/Hal/devices/volume_label_Fonts_4
').
Feb 17 11:14:52 amadeus NetworkManager: <debug> [1234865692.107112] nm_hal_device_rem
oved(): Device removed (hal udi is '/org/freedesktop/Hal/devices/volume_part5_size_51
2').
Feb 17 11:14:52 amadeus NetworkManager: <debug> [1234865692.110894] nm_hal_device_rem
oved(): Device removed (hal udi is '/org/freedesktop/Hal/devices/volume_part6_size_51
20').

4b. If I'm not so lucky the disk is ejected with the "Writing to disk" message still displaying and the icon still displays the disk name. Now /var/log/syslog just has the hald line and nothing from NetworkManager:

Feb 17 11:20:28 amadeus hald: unmounted /dev/sdg4 from '/media/Fonts 5' on behalf of uid 1000

Moreover, umounting manually from the command line and then ejecting works every time. So does gnome-umount -vbd which just gives the following:

gnome-mount 0.8
** (gnome-umount:6944): DEBUG: Unmounting /org/freedesktop/Hal/devices/volume_label_Fonts_3
** (gnome-umount:6944): DEBUG: in unmount_done : user_data = 0x0
Unmounted /dev/sdg4

Fredrik Ståhl (fredrik-stahl) wrote :

Damn, it just happened again even though I did a manual gnome-umount before ejecting. So it is unrelated to that.

Sebastien Bacher (seb128) wrote :

do you still get the issue in intrepid or jaunty?

Changed in gnome-mount:
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in gnome-mount (Ubuntu):
status: Incomplete → Invalid
Neanderthal (darkrealm) wrote :

Funny zip behavior(on a old gutsy7.10 distro,and yes still using it)

Something similar happened to my zip when tried to eject.
Im my case it would not even eject.
Complained about a application using the drive.
Some command output.

ubuntu:~$ gnome-umount -vbd /dev/hdb4
gnome-mount 0.6
** (gnome-umount:32082): DEBUG: Will attempts methods on drive object
** (gnome-umount:32082): DEBUG: Unmounting /org/freedesktop/Hal/devices/storage_model_IOMEGA_ZIP_100_ATAPI
** (gnome-umount:32082): DEBUG: Setting up 750ms timer for Flushing Cache dialog
** (gnome-umount:32082): DEBUG: in unmount_done : user_data = 0x0

** (gnome-umount:32082): WARNING **: Unmount failed for /org/freedesktop/Hal/devices/storage_model_IOMEGA_ZIP_100_ATAPI: org.freedesktop.Hal.Device.Volume.Busy : umount: /media/disk: device is busy

ubuntu:~$ sudo umount -v /dev/hdb4
umount: /media/disk: device is busy
umount: /media/disk: device is busy
---------
Well nothing odd with that if you are using the disk.
But by some reason it was nautilus that hanged on to the drive,,(filelock)?
Not until i killed of the "unseen" nautilus process the behavior disappeared.

ps ax ouput
8134 ? S 0:05 nautilus --no-default-window --sm-client-id default2

I think the --sm-client-id was default4 thou before the kill?
However it seems to work as supposed now.
Fault persisted even if rebooted whole computer.
Version of Nautilus 2.20.0
----

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers