Ubuntu

FAT: Unrecognized mount option "usefree" or missing value

Reported by hendrikwout on 2007-10-09
52
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-mount (Ubuntu)
Medium
Martin Pitt

Bug Description

Hi I tried to mount a vfat32 file system, but I get the following error from dmesg:

FAT: Unrecognized mount option "usefree" or missing value

I'm on guttsy powerpc (imac g3) linux-image-2.6.20-15-powerpc. Maybe it's because I'm not running an up to date kernel?
I don't run 2.6.22-14-powerpc because it doesn't boot, see:
https://bugs.launchpad.net/ubuntu/+bug/151013

Related branches

Marco Rodrigues (gothicx) wrote :

You've ntfs-3g installed ?

hendrikwout (hendrikwout) wrote :

Yes ntfs-3g is installed.

hendrikwout (hendrikwout) wrote :

Maybe I should ad some info: the problem is that the filesystem doesn't mount automaticaly from gnome when an usbstick with fat32 is plugged in. Mount from de disk mount gnome-applet doesn't work either. I still can mount it with the command sudo mount /dev/sda1 /media/sda1 but that is too much work.

Matt Zimmerman (mdz) wrote :

Forwarding to Martin Pitt as he made some relevant-looking changes here recently...

Martin Pitt (pitti) wrote :

Right, this option is not yet available in the feisty kernel. However, on the gutsy kernel it is currently a necessary workaround for bug 133567.

hendrikwout (hendrikwout) wrote :

Ok thanks. Now I just have to make the kernel work. Seems a problem on my imac G3 :(

Dan Lenski (lenski) wrote :

Hi all, I have the same problem, but I found a fix :-) I too am running Gutsy-with-Feisty-kernel because the 2.26.22 kernel panics on boot on my system.

THE PROBLEM
------------------

Basically, the problem is with the options that gnome-mount uses. If you run gnome-mount -vt from the command line, you'll see the problem:

$ gnome-mount -vtd /dev/sdh2
gnome-mount 0.6
** (gnome-mount:1378): DEBUG: Mounting /org/freedesktop/Hal/devices/volume_uuid_E0FD_8510
** (gnome-mount:1378): DEBUG: read default option 'shortname=mixed' from gconf strlist key /system/storage/default_options/vfat/mount_options
** (gnome-mount:1378): DEBUG: read default option 'uid=' from gconf strlist key /system/storage/default_options/vfat/mount_options
** (gnome-mount:1378): DEBUG: read default option 'utf8' from gconf strlist key /system/storage/default_options/vfat/mount_options
** (gnome-mount:1378): DEBUG: read default option 'umask=077' from gconf strlist key /system/storage/default_options/vfat/mount_options
** (gnome-mount:1378): DEBUG: read default option 'exec' from gconf strlist key /system/storage/default_options/vfat/mount_options
** (gnome-mount:1378): DEBUG: read default option 'usefree' from gconf strlist key /system/storage/default_options/vfat/mount_options
** (gnome-mount:1378): DEBUG: Mounting /org/freedesktop/Hal/devices/volume_uuid_E0FD_8510 with mount_point='DAN LENSKI', fstype='', num_options=6
** (gnome-mount:1378): DEBUG: option='shortname=mixed'
** (gnome-mount:1378): DEBUG: option='uid=1000'
** (gnome-mount:1378): DEBUG: option='utf8'
** (gnome-mount:1378): DEBUG: option='umask=077'
** (gnome-mount:1378): DEBUG: option='exec'
** (gnome-mount:1378): DEBUG: option='usefree'

** (gnome-mount:1378): WARNING **: Mount failed for /org/freedesktop/Hal/devices/volume_uuid_E0FD_8510
org.freedesktop.Hal.Device.Volume.UnknownFailure : mount: wrong fs type, bad option, bad superblock on /dev/sdh2, missing codepage or helper program, or other error In some cases useful info is found in syslog - try dmesg | tail or so

HERE'S THE FIX:
--------------------

Go into gconf-editor and navigate to /system/storage/default_options/vfat/mount_options, and then remove the "usefree" option from the list. Exit gconf-editor, and try hotplugging your drive again. It works :-)

davescar (davescar) wrote :

Confirmed. This fix works for me. Running gutsy with 2.6.20 kernel.

Malonso (m-alonso) wrote :

I have de same problem and I thought that your fix would work in my case too, but I don't have any such "/system/storage/default_options/vfat/mount_options" file in my file system. Could you help me further?
I get a similar reading when I run "gnome-mount -vtd /dev/sda1", but how can I remove the "usefree"option?

Thanks in advance!

It is not in the filesystem

You have to execute
  gconf-editor

Then you will see the tree for "/system/storage/default_options/vfat/mount_options/"

By the way,
As Dan Lenski and davescar, due to kernel panic from Gusty kernel, I use Feisty kernel on a Gusty upgrade.
Their solution resolved the issue I had with my Samsung YP-K5 (former mp3, now ogg reader)

Thanks

Malonso (m-alonso) wrote :

Thank you, Laurent.
In the end I found it. Now the problem is that I cannot edit the key. It says: "This key is not writable". I've tried to unset the key, but to no avail. do you think that reverting to the Feisty kernel could still slve my problem? You do that with the Synaptic manager, I suppose.

Thanks,

M. Alonso

keepertoad (keepertoad) wrote :

I have similsr issue of no automount for USB flash drives on Ubuntu 7.10, clean install on HP dv6100 laptop. Removing "usbfree" in gconfig-editor>storage>vfat did not work, however, removing rebooting and replacing "usbfree" did work. Not sure I understand why.

Cheers

Malonso (m-alonso) wrote :

Trouble is, I cannot change the key now, it is "not writable". When I've foun a way around it, I'll try your solution.
Thanks.

Tanker Bob (tankerbob) wrote :

What about Kubuntu 7.10? I have this problem with USB mass storage devices as well but there is no gconfig-editor in which to change settings in Kubuntu. Is there another way at that setting?

Eric Nord (ericnord) wrote :

I have the same problem in my 7.10 Xubuntu install (running the old kernel too due to aforementioned troubles). Anybody know where these configs are in Xubuntu?

Eric Nord (ericnord) wrote :

With help from my friend Jouke, this has been solved. Xubuntu uses gnome mount, therefore changing the gconf file solves the problem. gconfeditor is not istalled in xubuntu, but gconftool (a command line utility) is present, and adequate for the task.

andia (andreas-anschuetz) wrote :

I am also running gutsy on a feisty kernel (reason see above) and went through the proposals above. Nothing worked. When running feisty without gutsy the mounting of usb devices worked fine. Is there any other idea on how to solve the mount problem? If I can provide further infos please tell me.

w. glenn oldham (getglenn) wrote :

this problem occurs at random for me, despite the "usefree" mod...

i'm curious tho, how you can determine the correct usb port to try with "gnome-mount -vtd /dev/sdh2"?

if the usb device won't mount

gordon39 (gordon3913) wrote :

Going into Applications/ System Tools/ Configuration Editor/ system/storage/default_options/vfat/mount_options, and then remove the "usefree" option from the list.
Exit gconf-editor, and try hotplugging your drive again.

This worked for me in Ubuntu 7.10.

Thanks Dan Lenski.

keepertoad (keepertoad) wrote :

This is a bit wierd. Removed "usefree" as described above, reboot and everything usb mounts normally, except I sometimes get two icons on the desktop for the same device. As long as i keep hotplugging and unmounting everything seems to work just fine. However, if the machine sits idle for several minutes nothing usb will mount. It's like something is timing out and after that hotplugging usb devices is inop.

I'm about ready to go back to Fiesty just to get decent usb operation.

Any suggestions appreciated.

B.J.

paulderol (dr-jackal-mr-hydra) wrote :

this fix is ineffective for gutsy kernels and the Sansa e260. i can see the entry in lsusb,

Bus 005 Device 002: ID 0781:7420 SanDisk Corp.

and here's ls -l dev/sd*

brw-rw---- 1 root disk 8, 0 2008-01-21 13:37 /dev/sda
brw-rw---- 1 root disk 8, 1 2008-01-21 13:37 /dev/sda1
brw-rw---- 1 root disk 8, 2 2008-01-21 13:37 /dev/sda2
brw-rw---- 1 root disk 8, 5 2008-01-21 13:37 /dev/sda5

i THINK that sda5 is my music player, but i have no good way to tell.

i would LOVE to see this resolved BEFORE hardy comes out, but for now, i'd just like a viable workaround. any suggestions would be just super.

paulderol (dr-jackal-mr-hydra) wrote :

furthermore, the player opens rythymbox when i hotplug, which means this looks like a mounting issue. i don't really know how to manipulate fstab properly, as i have completely broken it before due to foolishness. any and all assistance would be appreciated...

Michael Stein (der-stein) wrote :

Generally removing usefree worked for me on feisty.
One card additionally I had to format with
sudo mkfs.vfat /dev/sdb1
But when I want to remove my sd-card I get the error: Cannot unmount volume; Cannot remove directory
But the directory is removed ...

Martin Pitt (pitti) on 2008-03-03
Changed in gnome-mount:
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-mount - 0.7-2ubuntu2

---------------
gnome-mount (0.7-2ubuntu2) hardy; urgency=low

  * debian/patches/ubuntu-default-mount-options.patch: Drop VFAT option
    'usefree', it's not necessary any more with the current Hardy kernel,
    and incompatible with pre-gutsy kernels. (LP: #151025)

 -- Martin Pitt <email address hidden> Mon, 03 Mar 2008 15:54:25 +0100

Changed in gnome-mount:
status: In Progress → Fix Released
JoE (johan-eneland) wrote :

I tested Hardy Heron Alpha (Ubuntu 8.04) as LiveCD and it mounted USB memories with FAT32 automatically.
So the problem will probably be solved soon.

(Hardy Heron Alpha release from http://cdimage.ubuntu.com/releases/hardy/ .)

Jared (jared-thanhandjared) wrote :

Is there any chance of getting the fix backported to Gutsy?

Removing usefree does not fix this bug in Gutsy

Hi,

Jared [2008-03-21 22:39 -0000]:
> Is there any chance of getting the fix backported to Gutsy?

Not sure what you mean. Gutsy's gnome-mount and hal *do* use usefree
for good reasons.

Jared (jared-thanhandjared) wrote :

I am getting this bug with 2.6.19-4 kernel with Xen. Cant use a more modern kernel unfortunately.

Have removed "usefree" from gconf now, and still the bug appears.

Endolith (endolith) wrote :

This does not appear to be fixed in Hardy. I had to remove the option "usefree" manually from gconf-editor before my drive auto-mounted.

I am sure many people have this problem, but they ask for help on the forums and people just tell them to brute force it with fstab, so they have the bug, too, but they don't know any better because they get it working the hard way.

dn (nobled) wrote :

Weird-- I only began to experience this bug once I upgraded to Hardy from Gutsy; removing usefree worked as a workaround. What could have caused that? [I'm not sure, but Bug #211760 might be a duplicate.]

I only received a generic "Invalid mount option" dialog followed by a blank, text-free error dialog, so I had no idea it was 'usefree' that was the problem until I experimented.

This fix also works for me, I've installed Xubuntu Gutsy

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions