Nautilus crashes while looking the partition icon properties

Bug #119954 reported by heartsmagic on 2007-06-12
34
Affects Status Importance Assigned to Milestone
GTK+
Fix Released
Critical
gnome-mount (Ubuntu)
High
Ubuntu Desktop Bugs

Bug Description

I am using Ubuntu Gutsy Gibbon , 7.10, Gnome 2.19.3, Nautilus 2.19.2.

I figure out that sometimes nautilus crashes. But i didnt know why it was. But tonight i reproduce it and i know how.
Just right click and look at properties of a partition icon on the Desktop. (ie try to put an emleb) Then watch how nautilus crashes and consume all the cpu.

description: updated

I can confirm this in Gutsy. To reproduce the freeze:

1) Open Nautilus and go to computer:///
2) Right click any of the icons except Filesystem and choose "properties"
3) Close the properties window

After that, nautilus freezes using 100% cpu.
This is also reproducible using the icons in the desktop, if they are present.

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. Please try to obtain a backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Confirmed → Needs Info

Backtrace attached.

Changed in nautilus:
status: Needs Info → Confirmed
heartsmagic (heartsmagic) wrote :

Here is my gdb log.

heartsmagic (heartsmagic) wrote :

And here is my valgrind log.

Valgrind log attached.

heartsmagic (heartsmagic) wrote :

I upgraded my system tonight, and now i have Nautilus 2.19.3. The problem still exists.

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. Please try to obtain a debug backtrace http://wiki.ubuntu.com/DebuggingProgramCrash and attach the file to the bug report. This will greatly help us in tracking down your problem.

Changed in nautilus:
status: Confirmed → Needs Info
Sebastien Bacher (seb128) wrote :

could you install libgtk2.0-0-dbgsym libgnomevfs2-0-dbgsym nautilus-dbgsym to get a backtrace of the crash?

Changed in nautilus:
status: Needs Info → Confirmed
heartsmagic (heartsmagic) wrote :

New backtrace is attached.

heartsmagic (heartsmagic) wrote :

Sorry for the previous attachment, i installed the necessary packages and do the same procedure for gettin gdb logs. I dont know if there is any difference.

Sebastien Bacher (seb128) wrote :

The backtrace is similar to tp://bugzilla.gnome.org/show_bug.cgi?id=406462 upstream which is a GTK bug

Changed in gtk:
status: Unknown → Confirmed
Changed in gtk+2.0:
importance: Medium → High
Melissa Draper (melissa) wrote :

Nautilus 2.19.5-0ubuntu1 made this even worse for me.
Freezing now happens on opening the dialog, rather than on closing it.

xtknight (xt-knight) wrote :

I am not able to reproduce it with Gutsy amd64 and nautilus 1:2.20.0-0ubuntu3.

Seems to be fixed here too.

snifer@snifer-laptop:~$ dpkg -l | grep gnome-mount
ii gnome-mount 0.6-1ubuntu3 wrapper for (un)mounting and ejecting storag
snifer@snifer-laptop:~$ dpkg -l | grep nautilus
ii libnautilus-burn4 2.20.0-0ubuntu1 Nautilus Burn Library - runtime version
ii libnautilus-extension1 1:2.20.0-0ubuntu3 libraries for nautilus components - runtime
ii nautilus 1:2.20.0-0ubuntu3 file manager and graphical shell for GNOME
ii nautilus-cd-burner 2.20.0-0ubuntu1 CD Burning front-end for Nautilus
ii nautilus-data 1:2.20.0-0ubuntu3 data files for nautilus
ii nautilus-sendto 0.12-0ubuntu4 integrates Evolution and Pidgin into the Nau

Sebastien Bacher (seb128) wrote :

Seems to be fixed, closing, feel free to reopen if you still get the issue though

Changed in gnome-mount:
status: Confirmed → Fix Released
Changed in gtk:
status: Confirmed → Fix Released
Changed in gtk:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.