Sync gnome-mines 1:3.14.1-2 (main) from Debian unstable (main)

Bug #1400002 reported by Artur Rona on 2014-12-06
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-mines (Ubuntu)
Wishlist
Unassigned

Bug Description

Please sync gnome-mines 1:3.14.1-2 (main) from Debian unstable (main)

Explanation of the Ubuntu delta and why it can be dropped:
  * debian/control:
    - Bump build-depends
  * debian/control:
    - Bump build-depends
  * New upstream release
  * debian/patches/hide-headerbar.patch:
    - Don't show HeaderBar in shells that don't support it well
  * New upstream release:
    - Remove "Hint" action from app menu
    - Add appdata file
    - Fix crash when releasing buttons outside minefield
    - Resize the window when switching to a smaller minefield
    - Fix broken links and typos in user help
    - Fix name of app menu when not launched by GNOME Shell
  * New upstream release:
    - Remove "Hint" action from app menu
    - Add appdata file
    - Fix crash when releasing buttons outside minefield
    - Resize the window when switching to a smaller minefield
    - Fix broken links and typos in user help
    - Fix name of app menu when not launched by GNOME Shell

hide-headerbar.patch is already fixed upstream, see git:
https://github.com/GNOME/gnome-mines/commit/54262644f032ebb4d8799ac091eed93898f76acd

Changelog entries since current vivid version 1:3.12.2-0ubuntu2:

gnome-mines (1:3.14.1-2) unstable; urgency=medium

  * 01_custom_size.patch: patch from upstream git. Allow to configure
    the custom size settings.

 -- Josselin Mouette <email address hidden> Fri, 05 Dec 2014 18:28:26 +0100

gnome-mines (1:3.14.1-1) unstable; urgency=medium

  * New upstream release.
  * Update Homepage URL.
  * Bump Standards-Version to 3.9.6. No further changes.

 -- Michael Biebl <email address hidden> Tue, 14 Oct 2014 16:33:57 +0200

gnome-mines (1:3.14.0-2) unstable; urgency=high

  * Team upload; high urgency for RC bug fix.
  * Add Breaks/Replaces on gnome-accessibility-themes, some icons moved around in 3.14 (closes: #763307).

 -- Julien Cristau <email address hidden> Mon, 29 Sep 2014 10:17:19 +0200

gnome-mines (1:3.14.0-1) unstable; urgency=medium

  * New upstream release.
  * Bump build-dependencies according to configure.ac changes:
    - gtk+ 3.12 and vala 0.24
    - glib 2.36.0
  * Drop debian/patches/hide-headerbar.patch
    - now include in new upstream release.

 -- Andreas Henriksson <email address hidden> Tue, 23 Sep 2014 21:09:36 +0200

gnome-mines (1:3.12.2-2) unstable; urgency=medium

  * Team upload.

  [ Jackson Doak ]
  * Add hide-headerbar.patch: Don't show HeaderBar / app menu on systems that
    don't support it

  [ Andreas Henriksson ]
  * debian/rules: Include gnome-get-source.mk for get-orig-source target.

 -- Andreas Henriksson <email address hidden> Thu, 31 Jul 2014 20:47:00 +0200

gnome-mines (1:3.12.2-1) unstable; urgency=low

  * Team upload.

  [ Jeremy Bicha ]
  * Switch from cdbs to dh7-style rules
  * Bump dh compat to 9

  [ Luca Falavigna ]
  * New upstream release.
  * debian/control.in:
    - Bump build-dependencies minimum required versions.
    - Bump Standards-Version to 3.9.5.

 -- Luca Falavigna <email address hidden> Sat, 19 Jul 2014 15:34:33 +0200

Artur Rona (ari-tczew) on 2014-12-06
Changed in gnome-mines (Ubuntu):
importance: Undecided → Wishlist
Robert Ancell (robert-ancell) wrote :

We can't do this until we have gnome-themes-standard 3.14 and that requires GTK+ 3.14 (see bug 1399046)

Artur Rona (ari-tczew) wrote :

There is gnome-themes-standard (3.14.2.3-0ubuntu1) already uploaded in Vivid. Please consider sync.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-mines (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) wrote :

This bug was fixed in the package gnome-mines - 1:3.14.1-2
Sponsored for Artur Rona (ari-tczew)

---------------
gnome-mines (1:3.14.1-2) unstable; urgency=medium

  * 01_custom_size.patch: patch from upstream git. Allow to configure
    the custom size settings.

 -- Josselin Mouette <email address hidden> Fri, 05 Dec 2014 18:28:26 +0100

gnome-mines (1:3.14.1-1) unstable; urgency=medium

  * New upstream release.
  * Update Homepage URL.
  * Bump Standards-Version to 3.9.6. No further changes.

 -- Michael Biebl <email address hidden> Tue, 14 Oct 2014 16:33:57 +0200

gnome-mines (1:3.14.0-2) unstable; urgency=high

  * Team upload; high urgency for RC bug fix.
  * Add Breaks/Replaces on gnome-accessibility-themes, some icons moved around in 3.14 (closes: #763307).

 -- Julien Cristau <email address hidden> Mon, 29 Sep 2014 10:17:19 +0200

gnome-mines (1:3.14.0-1) unstable; urgency=medium

  * New upstream release.
  * Bump build-dependencies according to configure.ac changes:
    - gtk+ 3.12 and vala 0.24
    - glib 2.36.0
  * Drop debian/patches/hide-headerbar.patch
    - now include in new upstream release.

 -- Andreas Henriksson <email address hidden> Tue, 23 Sep 2014 21:09:36 +0200

gnome-mines (1:3.12.2-2) unstable; urgency=medium

  * Team upload.

  [ Jackson Doak ]
  * Add hide-headerbar.patch: Don't show HeaderBar / app menu on systems that
    don't support it

  [ Andreas Henriksson ]
  * debian/rules: Include gnome-get-source.mk for get-orig-source target.

 -- Andreas Henriksson <email address hidden> Thu, 31 Jul 2014 20:47:00 +0200

gnome-mines (1:3.12.2-1) unstable; urgency=low

  * Team upload.

  [ Jeremy Bicha ]
  * Switch from cdbs to dh7-style rules
  * Bump dh compat to 9

  [ Luca Falavigna ]
  * New upstream release.
  * debian/control.in:
    - Bump build-dependencies minimum required versions.
    - Bump Standards-Version to 3.9.5.

 -- Luca Falavigna <email address hidden> Sat, 19 Jul 2014 15:34:33 +0200

Changed in gnome-mines (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers