update-gnome-menus-cache crashed with SIGABRT in __kernel_vsyscall()

Bug #769349 reported by Ben Wu
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-menus (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-menus

while installing playlinux

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: python-gmenu 2.30.5-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
Date: Sat Apr 23 12:37:56 2011
ExecutablePath: /usr/share/gnome-menus/update-gnome-menus-cache
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
InterpreterPath: /usr/bin/python2.7
ProcCmdline: /usr/bin/python /usr/share/gnome-menus/update-gnome-menus-cache /usr/share/applications
ProcEnviron:
 PATH=(custom, no user)
 LANG=zh_TW.UTF8
Signal: 6
SourcePackage: gnome-menus
StacktraceTop:
 __kernel_vsyscall ()
 raise () from /lib/i386-linux-gnu/libc.so.6
 abort () from /lib/i386-linux-gnu/libc.so.6
 Py_FatalError ()
 ?? ()
Title: update-gnome-menus-cache crashed with SIGABRT in __kernel_vsyscall()
UpgradeStatus: Upgraded to natty on 2011-04-19 (3 days ago)
UserGroups:

Revision history for this message
Ben Wu (ben-wu) wrote :
Revision history for this message
Jamie Strandboge (jdstrand) wrote :

Thanks for taking the time to report this bug and helping to make Ubuntu better. We appreciate the difficulties you are facing, but this appears to be a "regular" (non-security) bug. I have unmarked it as a security issue since this bug does not show evidence of allowing attackers to cross privilege boundaries nor directly cause loss of data/privacy. Please feel free to report any other bugs you may find.

security vulnerability: yes → no
visibility: private → public
Martin Pitt (pitti)
Changed in gnome-menus (Ubuntu):
status: New → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-menus - 3.2.0.1-2ubuntu1

---------------
gnome-menus (3.2.0.1-2ubuntu1) precise; urgency=low

  [ Michael Terry ]
  * Merge from Debian testing, remaining changes:
    - debian/patches/09_app_install_entry.patch: Add Software Center
    - debian/patches/series: Disable 01_default_prefix.patch
    - debian/gnome-menus.postinst: Disable blacklist
    - debian/watch: Look for unstable tarballs

  [ Martin Pitt ]
  * Remove remaining menu cache stuff, as it is not being used any more:
    - Drop debian/update-gnome-menus-cache. (LP: #769349, #771196)
    - debian/gnome-menus.triggers: Drop "gmenucache".
    - Drop 22_desktop-cache.patch (already wasn't applied any more in series)

gnome-menus (3.2.0.1-2) unstable; urgency=low

  [ Jordi Mallach ]
  * Update po-up/ca.po.

  [ Michael Biebl ]
  * Upload to unstable.

gnome-menus (3.2.0.1-1) experimental; urgency=low

  [ Sjoerd Simons ]
  * New upstream release
  * Partial sync from Ubuntu, ensure we're using the same package names and
    initial 3.2.0 packaging
  * debian/patches/01_default_prefix.patch: Refreshed
  * debian/libgnome-menu-3-0.symbols: Add symbols file
  * debian/gnome-menus.install: Install gmenu-simple-editor
  * Remove pysupport depends, gnome-menus bindings go via GI now.

  [ Michael Biebl ]
  * debian/rules:
    - Call dh_python2 for gnome-menus, so python:Depends is set.
  * debian/control.in:
    - Bump Build-Depends on python to (>= 2.6.6-3~) for dh_python2.

  [ Sjoerd Simons ]
  * Stop installing gmenu-simple-editor
 -- Michael Terry <email address hidden> Fri, 23 Dec 2011 15:25:07 -0500

Changed in gnome-menus (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers