desktop files with Category=Science; don't show in the menus

Bug #47426 reported by Vassilis Pandis on 2006-05-30
12
Affects Status Importance Assigned to Milestone
gnome-menus
Fix Released
Medium
gnome-menus (Baltix)
Undecided
Unassigned
gnome-menus (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

For example, copy the following to /usr/share/applications

[Desktop Entry]
Version=1.0
Encoding=UTF-8
Name=Kmatplot Plotter
GenericName=Data Plotter
Comment=A tool for plotting data sets in 2D or 3D
Exec=kmatplot
Icon=kmatplot
Type=Application
Terminal=false
Categories=Math;Science;

It doesn't show.

Now in Categories add "Application". It shows (in Other). "Application" though isn't a registered fd.org category [1].

Thanks.

[1] http://standards.freedesktop.org/menu-spec/latest/apa.html

Sebastien Bacher (seb128) wrote :

Thanks for your bug. That's known upstream: http://bugzilla.gnome.org/show_bug.cgi?id=331142

Changed in gnome-menus:
assignee: nobody → desktop-bugs
status: Unconfirmed → Confirmed
Phil Bull (philbull) wrote :

I think the requirement for the 'Applications' category may have been fixed - packages such as kmplot seem to display in the menus without having this category. There's still a problem with displaying science packages, though - there isn't a science category!

Would it be possible to add such a category in the Applications menu? Science apps currently get split between 'Education' and 'Other', which makes finding science applications more frustrating for users.

I think all that's required is a small modification to applications.menu and to add a new science.directory file in /usr/share/desktop-directories/. This wouldn't add much to the delta for the gnome-menus package, as similar patches have already been applied.

Sebastien Bacher (seb128) wrote :

From the freedesktop specification (http://standards.freedesktop.org/menu-spec/menu-spec-1.0.html) the "Education" category is a main category where "Science" is an additional one, shouldn't those .desktop use "Math;Science;Education" to list a main category then?

Phil Bull (philbull) wrote :

Hmm, fair point. I'm not totally convinced that all apps in the Science category match the Education category too, though.

What do you suggest? As I see it, these are the options at the minute:

 * Modify all relevant .desktop files to include category 'Education'
 * Modify applications.menu so that Science packages go into the Education category in the Applications menu
 * Introduce a Science category to applications.menu
 * Do nothing, leave the packages split across 2-3 categories

Sebastien Bacher (seb128) wrote :

The best option would probably to fix packages which don't list a main category to mention Education or the other best matching one. One extra menu category would require to pick between Education and Science which is not ideal

Phil Bull (philbull) wrote :

OK, I'll try to work on this when I get chance. Probably won't get done for Feisty unfortunately...

Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in gnome-menus:
status: Confirmed → Fix Committed
Changed in gnome-menus:
status: Unconfirmed → Fix Released
Sebastien Bacher (seb128) wrote :

This upload fixes the bug:

 gnome-menus (2.19.2-0ubuntu1) gutsy; urgency=low
 .
   * New upstream version:
     Menu Layout
     - Fix "system-wide" typo (Ubuntu: #28354)
     - Put Preferences before Administration in the System menu
     - Use icons from the icon naming spec
     - Use Universal Access instead of Accessibility
     - Use System instead of Desktop since the menu got renamed
     - Do not require the Application category in the Other submenu
       (Ubuntu: #47426)
     Menu Editor
     - Fix a crash when unselecting the current menu (Ubuntu: #91254)
     - Require pygtk at runtime
     - Use the python executable found by configure
     Misc
     - Require automake 1.9
   * debian/patches/06_desktop_rename.patch:
     - dropped, fixed with the new version
   * debian/patches/08_system_menus_order.patch:
     - dropped, fixed with the new version
   * debian/patches/70_reautogen.patch:
     - updated

Changed in gnome-menus:
status: Fix Committed → Fix Released
Changed in gnome-menus:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.