Applications menu does not get populated with recently installed apps using apt

Bug #1765799 reported by João Loureiro
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-menus (Ubuntu)
Medium
fossfreedom
Bionic
Medium
fossfreedom

Bug Description

[Impact]

 Applications menu for GNOME3 based desktop environments doesn't get populated with recently installed app using apt or GUI apps like gnome-software, budgie-welcome (Ubuntu Budgie)

Users need to physically logout and login again before they see the application appear in their menu.

This is an intermittent issue - some installs work correctly, some installs dont display in the menu. After logging out and logging in, those installs that didnt display, now appear in the menu.

This affects all desktop environments that use gnome-menus to recognise new/changed/deleted applications. Primarily this would be Unity and Budgie Desktop. Not sure about GNOME Shell or other desktop environments

[Test Case]

Install an application using apt (command line), GNOME Software or through budgie-welcome (Ubuntu Budgie only) - The application icon should appear in the menu of the desktop environment being used.

Remove an application through apt, GNOME Software and/or budgie-welcome (ubuntu budgie) - The application icon should disappear from the menu of the desktop environment being used

Repeat the above two test cases several times (e.g. 10x) with different applications

[Regression Potential]

Arguably the risk is that the patch introduces potential instability into the installation sequence that could cause crashes. That's the worst case scenario.

The mitigation here is that the patch is the exact same patch used in 17.04 and 17.10. It was also used in 16.04 and 16.10 - in these two cases the patch did not contain a one line fix introduced in 17.04 that fixed a crashing race issue in budgie-desktop.

[Other Info]

Consultation with the uploader to 18.04 (Jeremy) is a must here to discuss possibly reasons why when merging with Debian, the ubuntu specific patch was not readded.

----

Below is the original description

Applications menu doesn't get populated with recently installed app using apt.

For example, after installing Firefox using apt, its shortcut does not appear immediately in the applications main menu. It only appeared there after I rebooted (maybe logging off also does the job).
A “refresh menu” action has to be triggered somehow after installations.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: gnome-menus 3.13.3-11ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-15.16-generic 4.15.15
Uname: Linux 4.15.0-15-generic x86_64
ApportVersion: 2.20.9-0ubuntu5
Architecture: amd64
CurrentDesktop: Budgie:GNOME
Date: Fri Apr 20 18:39:49 2018
Dependencies:

InstallationDate: Installed on 2018-04-20 (0 days ago)
InstallationMedia: Ubuntu-Budgie 18.04 LTS "Bionic Beaver" - Alpha amd64 (20180418)
SourcePackage: gnome-menus
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
João Loureiro (joaofl) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-menus (Ubuntu):
status: New → Confirmed
Revision history for this message
fossfreedom (fossfreedom) wrote :

I had a quick look at the package difference between the artful version and bionic version of gnome-menus. 80-file-monitor-delayed.patch has been dropped.

This was always critical to ensure Unity (and budgie-desktop) menu systems are updated after an apt based install.

I don't know though why it was dropped during the merge from upstream debian.

sub @Jbicha - thoughts?

Revision history for this message
fossfreedom (fossfreedom) wrote :

Tested this extensively in budgie - installing/removing repeatedly via gnome-software, budgie-welcome, command line. Works everytime.

This patch (as mentioned above) copies back the artful patch 80_file_monitor_delayed.patch - it is unchanged.

In terms of risk I would say none - the same patch has been in 17.04 and 17.10 - and was also in 16.04 and 16.10 minus one tweak I made previously to stop budgie crashing.

Thus this patch has been very well tested over the years!

Revision history for this message
fossfreedom (fossfreedom) wrote :

since the package version is the same, the patch equally applies to both cosmic and bionic.

Please can this be applied to Cosmic - then SRU'd to bionic?

description: updated
tags: added: patch
Changed in gnome-menus (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → fossfreedom (fossfreedom)
importance: Undecided → Low
Changed in gnome-menus (Ubuntu):
status: In Progress → New
Changed in gnome-menus (Ubuntu):
importance: Low → Medium
Jeremy Bicha (jbicha)
Changed in gnome-menus (Ubuntu Bionic):
assignee: nobody → fossfreedom (fossfreedom)
importance: Undecided → Medium
Jeremy Bicha (jbicha)
Changed in gnome-menus (Ubuntu):
status: New → Fix Committed
Changed in gnome-menus (Ubuntu Bionic):
status: New → In Progress
no longer affects: gnome-menus (Ubuntu Cosmic)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-menus - 3.13.3-11ubuntu2

---------------
gnome-menus (3.13.3-11ubuntu2) cosmic; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * Add debian/gbp.conf with ubuntu settings
  * debian/control*: update VCS informations
  * debian/control*: fix VCS URIs

  [ David Mohammed ]
  * Restore 80_file_monitor_delayed.patch:
    - Fix app menus not updating correctly after app install or removal.
      This patch was accidentally dropped in previous merge. (LP: #1765799)

 -- Jeremy Bicha <email address hidden> Thu, 19 Jul 2018 20:37:27 -0400

Changed in gnome-menus (Ubuntu):
status: Fix Committed → Fix Released
Changed in gnome-menus (Ubuntu Bionic):
status: In Progress → Fix Committed
Revision history for this message
Robie Basak (racb) wrote :

> Tested this extensively in budgie - installing/removing repeatedly via gnome-software, budgie-welcome, command line. Works everytime.

Thank you for treating this carefully.

tags: added: verification-needed verification-needed-bionic
Revision history for this message
Robie Basak (racb) wrote : Please test proposed package

Hello João, or anyone else affected,

Accepted gnome-menus into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-menus/3.13.3-11ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Revision history for this message
Robie Basak (racb) wrote :

Unsubscribing ~ubuntu-sponsors.

Revision history for this message
Jacob Vlijm (vlijm) wrote :

Tested 3.13.3-11ubuntu1.1 extensively on different apps, not a single issue occurred.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-menus - 3.13.3-11ubuntu1.1

---------------
gnome-menus (3.13.3-11ubuntu1.1) bionic; urgency=medium

  [ David Mohammed ]
  * Restore 80_file_monitor_delayed.patch:
    - Fix app menus not updating correctly after app install or removal.
      This patch was accidentally dropped in previous merge. (LP: #1765799)

  [ Marco Trevisan (Treviño) ]
  * Update Vcs fields

 -- Jeremy Bicha <email address hidden> Thu, 19 Jul 2018 20:37:27 -0400

Changed in gnome-menus (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for gnome-menus has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers