gnome-menus and bamfdaemon failed to install/upgrade: triggers looping, abandoned

Bug #1589097 reported by Hathaway-dave on 2016-06-04
288
This bug affects 132 people
Affects Status Importance Assigned to Milestone
bamf (Ubuntu)
Medium
Marco Trevisan (Treviño)
Xenial
Undecided
Unassigned
gnome-menus (Ubuntu)
High
Unassigned
Xenial
Undecided
Unassigned

Bug Description

[Impact]

During upgrade from 15.10 to 16.04

gnome-menus and bamfdaemon triggers start looping forever.

[Test case]

Do a distro upgrade from 15.10 to 16.04

[Regression potential]

Nothing known at this stage. There's no behavior change, just a timing one.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: gnome-menus 3.13.3-6ubuntu3
ProcVersionSignature: Ubuntu 4.4.0-22.40-generic 4.4.8
Uname: Linux 4.4.0-22-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
Date: Sat Jun 4 07:35:11 2016
Dependencies:

ErrorMessage: triggers looping, abandoned
InstallationDate: Installed on 2015-10-01 (246 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: gnome-menus
Title: package gnome-menus 3.13.3-6ubuntu3 failed to install/upgrade: triggers looping, abandoned
UpgradeStatus: Upgraded to xenial on 2016-06-04 (0 days ago)

Related branches

Hathaway-dave (hathaway-dave) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-menus (Ubuntu):
status: New → Confirmed
Changed in gnome-menus (Ubuntu):
importance: Undecided → High
Changed in bamf (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
summary: - package gnome-menus 3.13.3-6ubuntu3 failed to install/upgrade: triggers
- looping, abandoned
+ gnome-menus and bamfdaemon failed to install/upgrade: triggers looping,
+ abandoned
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.5.3~bzr0+16.10.20160705-0ubuntu1

---------------
bamf (0.5.3~bzr0+16.10.20160705-0ubuntu1) yakkety; urgency=medium

  * debian/bamfdaemon.triggers: use interest-noawait (LP: #1589097)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Tue, 05 Jul 2016 01:10:52 +0000

Changed in bamf (Ubuntu):
status: In Progress → Fix Released
description: updated

Hello Hathaway-dave, or anyone else affected,

Accepted bamf into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bamf/0.5.3~bzr0+16.04.20160701-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bamf (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.5.3~bzr0+16.04.20160701-0ubuntu1

---------------
bamf (0.5.3~bzr0+16.04.20160701-0ubuntu1) xenial; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * BamfMatcher: allow overriding desktop with the environment var
    BAMF_DESKTOP_FILE_HINT

  [ Andrea Azzarone ]
  * Daemon: manually set to complete the startup notification on view
    state change (LP: #1582430)

  [ Marco Trevisan (Treviño) ]
  * debian/bamfdaemon.triggers: use interest-noawait (LP: #1589097)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 01 Jul 2016 10:44:07 +0000

Changed in bamf (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for bamf has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-menus (Ubuntu Xenial):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers