missing icons for .directory files

Bug #1201128 reported by CatKiller on 2013-07-14
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-icon-theme (Ubuntu)
Wishlist
Unassigned
gnome-menus (Ubuntu)
Wishlist
Unassigned

Bug Description

Directory files have been shipped with incorrect Icon= fields. For example, ActionGames.directory contains Icon=weather-storm.

This should instead read Icon=applications-action (1) which is included in many icon sets (2), leaving this kind of substitution to the theme author using symlinks. Including references to these substitutions directly in the .directory files is an inappropriate and unecessary kludge which breaks themes, including the default one.

I've only checked the Games .directory files so far, since that is what I was doing when I encountered the bug, but they all exhibit this problem. I'm using Ubuntu 13.04, but it's the kind of thing that could have been sitting undone for a while. It's probably worth checking whether this bug exists upstream or whether it's been introduced by the Ubuntu team.

Upon further checking, Bug #421294 is a particular case of this bug, where the line reads Icon=system-run rather than Icon=applications-puzzles. From this report and Bug #421695 it seems likely that this bug was introduced in Karmic.

(1) or similar - I'm not entirely sure on whether this will shake out as applications-action or applications-games-action; Gnome currently goes one way and KDE the other but, either way, symlinks are cheap and it can be sorted out through freedesktop.

(2) Ubuntu's own Humanity icon set includes icons of this form, but they are not used because of this bug.

CatKiller (catkiller) wrote :

On further investigation it looks like this bug got picked up from Debian by Sebastien Bacher on 2008-06-13.

jhansonxi (jhansonxi) wrote :

Ubuntu 12.04 (Precise Pangolin) x86_64/amd64
apt-cache madison gnome-menus
gnome-menus | 3.4.0-0ubuntu1 | http://mirror.team-cymru.org/ubuntu/ precise/main amd64 Packages

Some game directories are referencing icons that don't exist or are from packages that don't exist anymore:

BlocksGames.directory: Icon=gnome-gnometris
KidsGames.directory: Icon=gnome-amusements
RolePlayingGames.directory: Icon=stock_person
SportsGames.directory: Icon=stock_scores

No icons defined:
AdventureGames.directory
StrategyGames.directory
SimulationGames.directory

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-menus (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-menus - 3.8.0-1ubuntu4

---------------
gnome-menus (3.8.0-1ubuntu4) saucy; urgency=low

  * Update some of the directory icon names (LP: #1201128)
 -- Jeremy Bicha <email address hidden> Sun, 08 Sep 2013 14:31:02 -0400

Changed in gnome-menus (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) on 2013-09-08
summary: - .directory files contain references to inappropriate icons
+ missing icons for .directory files
Changed in gnome-menus (Ubuntu):
importance: Undecided → Wishlist
status: Fix Released → Confirmed
Changed in gnome-icon-theme (Ubuntu):
importance: Undecided → Wishlist
status: New → Confirmed
CatKiller (catkiller) wrote :

Still affects Saucy. Still affects Trusty.

CatKiller (catkiller) wrote :

The "fix" was entirely inadequate. Just three files, replacing one arbitrarily inappropriate icon with another, and not the ones that people have complained about. There are standard names for these, included within the default Ubuntu theme. Use those. If you really must use some other icon, call it the appropriate thing and then symlink to whatever icon you've pulled out of the hat. It isn't difficult. Failure to do so highlights how little you value the consistency of the user experience.

CatKiller (catkiller) on 2014-06-29
description: updated
CatKiller (catkiller) wrote :

@jbicha: My previous comment reads like an attack on you personally. It wasn't intended to be. I'm grateful that you attempted a fix, even though your approach didn't actually address the problem described in the initial report. The lack of resources and low priority for this kind of papercut issue shows how far the Ubuntu project has departed from the user-focused philosophy that initially made it good. Hence, the frustration.

CatKiller (catkiller) wrote :

Still an issue on Xenial.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-menus - 3.31.4-2ubuntu1

---------------
gnome-menus (3.31.4-2ubuntu1) disco; urgency=medium

  * Sync with Debian. Remaining changes:
    - debian/gnome-menus.postinst, debian/gnome-menus.prerm,
      debian/gnome-menus.dirs:
      + Remove since we don't use the Debian GNOME menu blacklist
    - debian/gnome-menus.triggers: Drop "gmenucache".
    - Add 09_app_install_entry.patch:
      + Add Ubuntu Software / GNOME Software to the traditional apps menu
    - Add 70_ubuntu-directories.patch
      + Add Ubuntu-specific directories back to POTFILES.in
    - Add ubuntu_gcc_translations.patch:
      + Make the unity-control-center categories translatable (lp: #1515911)
    - Add 80_file_monitor_delayed.patch:
      + Fix app menus not updating correctly after app install or removal

gnome-menus (3.31.4-2) unstable; urgency=medium

  * Follow upstream and stop using intltool for our update-po rule
  * Run debian/rules update-po
  * Add translate-Debian-directories.patch from Ubuntu
  * Run dh_auto_test

gnome-menus (3.31.4-1) unstable; urgency=medium

  * New upstream release
    - Drop the Sundry menu
  * Drop obsolete Build-Depends on intltool
  * Refresh patches
  * Drop 12_alacarte.path: obsolete with new release

gnome-menus (3.31.3-1) unstable; urgency=medium

  * New upstream release:
    - Includes updates for renamed .desktop files
  * Bump debhelper compat to 11
  * Update Vcs fields for migration to https://salsa.debian.org/
  * Add -Wl,-O1 to our LDFLAGS
  * Bump Standards-Version to 4.3.0
  * debian/desktop-files/:
    - Update some of the directory icon names (LP: #1201128)
  * Drop patches applied in new release:
    - 03_kde-legacydirs.patch
    - 30_xdg_syntax.patch
    - 31_nl_translation.patch
  * Refresh patches

 -- Jeremy Bicha <email address hidden> Mon, 21 Jan 2019 20:19:06 -0500

Changed in gnome-menus (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers