gnome-sound-recorder crashed pushing the record button

Bug #90674 reported by Jurjen Stellingwerff on 2007-03-08
36
Affects Status Importance Assigned to Milestone
GNOME media utilities
Expired
Critical
gnome-media (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-media

Start the sound-recorder... push record.
It seams like the alsa recording system doesn't work for ekiga/jokosher/krecord and sound-recorder.
Is there another way to help debugging this? No problems with my sound card including recording under edgy.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Thu Mar 8 19:43:51 2007
DistroRelease: Ubuntu 7.04
ExecutablePath: /usr/bin/gnome-sound-recorder
Package: gnome-media 2.17.91-0ubuntu1 [modified: usr/bin/gnome-audio-profiles-properties usr/bin/cddb-slave2-properties usr/bin/vumeter usr/bin/gnome-volume-control usr/bin/gnome-cd usr/bin/gnome-sound-recorder usr/bin/gstreamer-properties]
PackageArchitecture: i386
ProcCmdline: gnome-sound-recorder
ProcCwd: /home/jurjen
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/bin/X11:/usr/games
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: gnome-media
Stacktrace:
 #0 0x080525cb in ?? ()
 #1 0x00000000 in ?? ()
StacktraceTop:
 ?? ()
 ?? ()
Uname: Linux jurjen 2.6.20-9-generic #2 SMP Mon Feb 26 03:01:44 UTC 2007 i686 GNU/Linux
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev scanner slocate video

Sebastien Bacher (seb128) wrote :
Download full text (131.8 KiB)

Debug backtrace for the crash:

#0 0x080525cb in record_cb (action=0x8084890, window=0x8152058)
    at gsr-window.c:1912
        priv = (GSRWindowPrivate *) 0x8152100
#1 0xb7e1a9d9 in IA__g_cclosure_marshal_VOID__VOID (closure=0x8213800,
    return_value=0x0, n_param_values=1, param_values=0xbfba0f3c,
    invocation_hint=0xbfba0e4c, marshal_data=0x8052340) at gmarshal.c:77
        data1 = (gpointer) 0x8084890
        data2 = (gpointer) 0x0
        __PRETTY_FUNCTION__ = "IA__g_cclosure_marshal_VOID__VOID"
#2 0xb7e0d62b in IA__g_closure_invoke (closure=0x8213800, return_value=0x0,
    n_param_values=1, param_values=0xbfba0f3c, invocation_hint=0xbfba0e4c)
    at gclosure.c:490
        marshal = (
    GClosureMarshal) 0xb7e1a990 <IA__g_cclosure_marshal_VOID__VOID>
        marshal_data = (gpointer) 0x0
        __PRETTY_FUNCTION__ = "IA__g_closure_invoke"
#3 0xb7e1e103 in signal_emit_unlocked_R (node=0x8181048, detail=0,
    instance=0x8084890, emission_return=0x0, instance_and_params=0xbfba0f3c)
    at gsignal.c:2440
        tmp = <value optimized out>
        handler = (Handler *) 0x8187180
        accumulator = (SignalAccumulator *) 0x0
        emission = {next = 0x0, instance = 0x8084890, ihint = {
    signal_id = 127, detail = 0, run_type = G_SIGNAL_RUN_FIRST},
  state = EMISSION_RUN, chain_type = 4}
        class_closure = (GClosure *) 0x8181010
        handler_list = (Handler *) 0x8187180
        return_accu = (GValue *) 0x0
        accu = {g_type = 0, data = {{v_int = 0, v_uint = 0, v_long = 0,
      v_ulong = 0, v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0,
      v_pointer = 0x0}, {v_int = 0, v_uint = 0, v_long = 0, v_ulong = 0,
      v_int64 = 0, v_uint64 = 0, v_float = 0, v_double = 0, v_pointer = 0x0}}}
        signal_id = 127
        max_sequential_handler_number = 291
        return_value_altered = 1
#4 0xb7e1f627 in IA__g_signal_emit_valist (instance=0x8084890, signal_id=127,
    detail=0,
    var_args=0xbfba117c "�[nI\220H\b\b\220H\b\b�\021��(H?I\220H\b\b0� @�\021���G?Ip�㷠G?I�\021��٩��\220H\b\b��(\b����p�����������(\022��+���0� \b")
    at gsignal.c:2199
        _flags = <value optimized out>
        _vtable = <value optimized out>
        _cvalues = {{v_int = 0, v_long = 0, v_int64 = 0, v_double = 0,
    v_pointer = 0x0}, {v_int = -1078324988, v_long = -1078324988,
    v_int64 = 3216642308, v_double = 1.5892324593422979e-314,
    v_pointer = 0xbfba1104}, {v_int = 1, v_long = 1,
    v_int64 = -4631370179962470399, v_double = -0.10182738304138185,
    v_pointer = 0x1}, {v_int = -1078324928, v_long = -1078324928,
    v_int64 = -5195696770264723136, v_double = -1.9448015309825241e-39,
    v_pointer = 0xbfba1140}, {v_int = 134760592, v_long = 134760592,
    v_int64 = 134760592, v_double = 6.6580578920428722e-316,
    v_pointer = 0x8084890}, {v_int = 0, v_long = 0, v_int64 = 0, v_double = 0,
    v_pointer = 0x0}, {v_int = 0, v_long = 0, v_int64 = 0, v_double = 0,
    v_pointer = 0x0}, {v_int = 0, v_long = 0, v_int64 = 0, v_double = 0,
    v_pointer = 0x0}}
        _lcopy_format = <value optimized out>
        _n_values = <value optimized out>
        return_value = {g_type = 3085249872, data = {{v_int =...

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=416775

Changed in gnome-media:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: Unconfirmed → Confirmed
Changed in gnome-media:
status: Unknown → Unconfirmed
Sebastien Bacher (seb128) wrote :

Do you still get the bug?

Upstream bugzilla comment

"Could you reproduce this bug and type "list" in gdb, so we can see what it's
doing when it's crashing? (The source code has changed since you submitted the
bug)"

Changed in gnome-media:
status: Confirmed → Incomplete
Changed in gnome-media:
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in gnome-media:
status: Incomplete → Invalid
Changed in gnome-media:
status: Incomplete → Invalid
Sebastien Bacher (seb128) wrote :

there is a duplicate with other informations

Changed in gnome-media (Ubuntu):
status: Invalid → Triaged
summary: - [apport] gnome-sound-recorder crashed pushing the record button
+ gnome-sound-recorder crashed pushing the record button
Changed in gnome-media:
status: Invalid → New
Changed in gnome-media:
importance: Unknown → Critical
Changed in gnome-media:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.