gnome-volume-control doesn't restore remote PA audio sink after restore from hibernate/sleep

Bug #686172 reported by Martin-Éric Racine on 2010-12-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-media (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gnome-media

I have a remote host running PA in system mode connected to my stereo and my laptop connecting to it, as selected via the gnome-volume-control. However, when returning from hibernate or sleep, gnome-volume-control-applet doesn't try to restore the connection to the remote audio sink. Instead, it launches with a connection to the local PA and I have to go and launch g-v-c from the g-v-c-applet and restore the remote connection manually from the audio output tab. Ideally, g-v-c-applet would restore the connection itself, if the same host is spotted via Avahi upon returning from hiberante/sleep.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: gnome-media 2.31.6-0ubuntu2
Uname: Linux 2.6.36-1000-generic i686
Architecture: i386
Date: Mon Dec 6 22:15:53 2010
ProcEnviron:
 LANGUAGE=fi_FI:fi:en_US:en
 PATH=(custom, user)
 LANG=fi_FI.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-media

Martin-Éric Racine (q-funk) wrote :

Looks like a Wishlist bug to me -- it doesn't appear as there is automatic enabling of audio devices when the reappear. In this aspect it would behave the same as a local device, too. In this aspect, I think I can confirm the bug.

Changed in gnome-media (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers