Crash when testing speakers

Bug #628899 reported by Timo Wiren on 2010-09-02
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
gnome-media (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: gnome-media

gnome-volume-control crashes when testing speakers. The following message is printed to ~/.xsession-errors:
ERROR:gvc-speaker-test.c:390:get_channel_map_for_card: assertion failed: (stream)

Tested on Ubuntu Maverick 10.10 64-bit daily image 2010-09-02.
gnome-media version: 2.31.6-0ubuntu2.

Sound chip: Intel HDA integrated on DG45ID mobo. aplay -l shows:
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 3: INTEL HDMI 0 [INTEL HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

tags: added: iso-testing
Timo Wiren (timo-wiren) on 2010-09-02
description: updated
Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

If you are using Ubuntu with the Gnome desktop environment - launch nautilus and navigate to your /var/crash directory and double click on the crash report you wish to submit.
If you are using Kubuntu or Xubuntu you can file the crash using /usr/share/apport/apport-qt --crash-file=/var/crash/_my_crash_report.crash in a terminal - where _my_crash_report.crash is the crash you would like to report.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in gnome-media (Ubuntu):
importance: Undecided → Medium
status: New → Invalid
Alan Lord (theopensourcerer) wrote :

I'm seeing the exact same problem, but I do not have a /var/crash directory.

If I start the gnome-volume-control from the command line, go to the hardware tab and click the "Test Speakers" button, the app crashes. Every Time.

alord@lobsang:~$ gnome-volume-control
ERROR:gvc-speaker-test.c:390:get_channel_map_for_card: assertion failed: (stream)

(Surely the offending file and line number where the error is happening is enough for a dev to start looking at it?)

lspci -v for my sound h/w is as follows:

00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller
        Subsystem: ASRock Incorporation Device 0888
        Flags: bus master, fast devsel, latency 0, IRQ 22
        Memory at f95f8000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: <access denied>
        Kernel driver in use: HDA Intel
        Kernel modules: snd-hda-intel

I'm on an up-to-date Maverick, installed from a daily iso today 09/10/10.

Changed in gnome-media (Ubuntu):
status: Invalid → Confirmed
Alan Lord (theopensourcerer) wrote :

Having just rebooted my PC, GVC is not currently crashing. I will continue to monitor.

Ian Chard (ian-chard) wrote :

I'm having this problem as well on an Acer Revo R3610. I've attached the crash dump file.

Derek (bugs-m8y) wrote :

Same problem. Was trying to determine why sound stopped working on upgrade to Natty.
All channels open in alsamixer, but crashes on test speakers in gnome-volume-control.

00:1b.0 Audio device: Intel Corporation 82801JD/DO (ICH10 Family) HD Audio Controller (rev 02)
 Subsystem: Dell Device 0276

System has HDMI using:
01:00.1 Audio device: ATI Technologies Inc RV710/730
 Subsystem: Dell Device aa38

But was trying to use the analog sound.

Derek (bugs-m8y) wrote :

In my case, problem went away after killing pulseaudio and restarting it.

Interestingly, while gnome-volume-control showed both audio sources (digital/analog), pavucontrol only listed the HDMI one, and even though gnome-volume-control showed analog as selected, muting the visible HDMI source in pavu, muted the gnome volume.

Killing pulse, and restarting, listed both sources in pavu, and the assertion stopped happening.

Raymond (superquad-vortex2) wrote :

speaker-test crash after select "mono duplex" in sound preference on Ubuntu 11.04 Live CD

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers