[Dapper] Sound Recorder doesn't respect input selection on second record

Bug #53448 reported by Sami Haahtinen
26
Affects Status Importance Assigned to Milestone
GNOME media utilities
Fix Released
Medium
gnome-media (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Sound recorder in Dapper doesn't respect input selection on second recording. On the first recording input selection is respected and the correct input is used.

Steps to reproduce:
1. Start sound recorder.
2. Select input
3. Record
4. stop recording
5. Select input again (it has been reset)
6. record

When recording is started the second time, input is reset back to capture before the recording actually starts.

Related branches

Revision history for this message
Ashish Kulkarni (ashkulz) wrote :

This looks like it is related to #42022.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks for your bug. That looks like the same issue than bug #33666. I've marked the other one as duplicate since your description has some easy stop to get the issue. Marking as equivalent of http://bugzilla.gnome.org/show_bug.cgi?id=335556 upstream

Changed in gnome-media:
assignee: nobody → desktop-bugs
importance: Untriaged → Medium
status: Unconfirmed → Confirmed
Changed in gnome-media:
status: Unknown → Unconfirmed
Revision history for this message
Miek Gieben (miek) wrote :

This bug is still there in Edgy, but somewhat different. When I do the second
record gnome-sound-recorder disables CAPTURE on the capture device of my sound blaster live. So I can only record once, close sound recorder, enable CAPURE again and start gnome-sound-recorder again.

I've now upgraded to alsa-1.0.13 (from Debian unstable) but this makes
no difference.

I've also had issues with Ekiga, but this may be the same ALSA bug?

Revision history for this message
Michael Wohlmuther (mwohlmuther) wrote :
Revision history for this message
RichPicker (rich-braden) wrote :

Same in Edgy. Quite a few bugs for a system that is supposedly 'stable.' And there seems to be no end to the bugs. Sound Recorder worked perfectly fine for me the past month - used it several times. What did 'you' include in the software updates that changed things to create this bug?

Revision history for this message
eric auvert (eric-auvert-deactivatedaccount) wrote :

Same problem in Feisty.
Exactly the same issue as Miek.

Revision history for this message
Jarno Suni (jarnos) wrote :

I have tested in Dapper and Feisty.

Sound card: SBLive! Value [CT4832]
$ lspci | grep "Creative Labs"
0000:00:0f.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 06)
0000:00:0f.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 06)

In Dapper:

Patch: launch gnome-alsamixer. Uncheck all recs except your choise of input.
After that the sound recorder will automatically switch to right input when you start recording (althought sometimes when two rec chosen and then recorded, and then one rec is chosen, it can not choose the right input). On the other hand, I could only record microphone when rec checked for Capture (and "Record from input: Capture" in sound recorder). It happened a few times, after that I lost ability to record, or strictly speaking, recording became is very low.
Different mixers are not well synced. When rec is checked in gnome-alsamixer, Capture and AC97 sliders affect in line out 1 when I talk to microphone.

In Feisty:

Recording second time resets input to be AC97. I can not play my recordings by the sound recorder.
I can record by audacity, if rec is checked for capture in gnome-alsamixer. Playing with Microphone, Capture, and AC97 settings affects in line out 1 when I talk to microphone.

Very odd thing is that the recording ability seems to change at times. I thought in the beginning that it would be enough adjust microphone setting in a mixed and choose "record from input: Microphone" in the Sound Recorder to be able to record from microphone. This is little bit too difficult for an end used...

Revision history for this message
Jarno Suni (jarnos) wrote :

If you want more details of my problems in recording from mic please see
https://answers.launchpad.net/ubuntu/+source/ekiga/+question/7130

Revision history for this message
Daniel Holbach (dholbach) wrote :

Fixed Upstream.

Changed in gnome-media:
status: Confirmed → Fix Committed
Revision history for this message
Sebastien Bacher (seb128) wrote :

gnome-media (2.19.92-0ubuntu1) gutsy; urgency=low

  * New upstream version
    Changes since 2.18.0:
    - Fix the profiles not being editable in Sound-Juicer and Rhythmbox
    - Use themeable icons in a lot of places
    - Use gnome-doc-utils instead of scrollkeeper to install documentation
    - Fix playback of the last track when in track mode (gnome-cd)
    - Fix a lot of crashers and bugs (gnome-sound-recorder)
      (LP: #53448, #94111, #103139)
  * debian/gnome-media-common.install:
    - updated
  * debian/patches/03_menu_changes.patch:
    - updated
  * debian/patches/06_autoconf.patch:
    - updated
  * debian/patches/80_from_bugzilla_fix_recorder_playback.patch,
    debian/patches/81_from_bugzilla_no_crash_on_new_record.patch,
    debian/patches/90_from_bugzilla_set_modal.patch:
    - dropped, fixed with the new version

 -- Sebastien Bacher <email address hidden> Fri, 07 Sep 2007 21:01:23 +0200

Changed in gnome-media:
status: Fix Committed → Fix Released
Changed in gnome-media:
status: New → Fix Released
Changed in gnome-media:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.