Ubuntu

Keyboard Volume Buttons Don't Work While Volume Control Open

Reported by Dan F on 2006-07-05
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
gnome-media (Ubuntu)
Undecided
Ubuntu Desktop Bugs

Bug Description

I have an IBM Multimedia keyboard with volume buttons on it. If you click once on the volume control in the gnome panel, the buttons don't work. If you double click on that volume icon to get the Volume Control window then the buttons work fine and the volume changes on the slider. Otherwise, if you are just in Ubuntu normally, the buttons work fine, bringing up a nice display on the screen.

I'm using Ubuntu 6.06, not Kubuntu or Edubuntu or anything.

frogzoo (frogzoo) wrote :

Same here:
Dapper
Gnome 2.14.2

Same problem here on Ubuntu 6.10 (Edgy).

Sebastien Bacher (seb128) wrote :

Thank you for your bug. What do you call "don't work"? Do you click on the slider and dnd it? Do you click on a button? Does the slider refuse to move or is the sound volume not changing?

Changed in gnome-media:
assignee: nobody → desktop-bugs
status: Confirmed → Needs Info
Daniel Holbach (dholbach) wrote :

As described in the previous comments, your report lacks the information we need to investigate the problem further. We'll close this report for now - please reopen it if you can give us the missing information.

Changed in gnome-media:
status: Needs Info → Rejected

Reopening since I'm able to reproduce this bug (see screenshot in attachment).

Steps to reproduce:
1) Single click the volume control applet in the top panel so it remains open.
2) Press the keyboard volume controls + or -

Result:
The master volume remains unchanged, nothing happens when pressing the keyboard volume controls.

Changed in gnome-media:
status: Rejected → Confirmed
Sebastien Bacher (seb128) wrote :

Pascal, I'm not convinced that the same "bug". Do you have the focus on the slider widget (like dot border around it)? The original bug seems to describe the use of volume keys, not "+" or "-" on the keyboard, are you sure that's the same bug?

Sebastien,
Just to clarify: in my previous comment I really meant pressing the volume keys (they have an indication + or - on my keyboard), I did NOT mean + or - keys on the numpad of the keyboard and the focus is NOT on the slider. Sorry for the possible confusion.
I believe this is the same bug as described by Dan F.

Sebastien Bacher (seb128) wrote :

Do you consider that the volume key should do the same thing than when the applet slider is not open then (in which case the bug is a duplicate from the "can't take screenshot with the keyboard key for that when a menu is open" which is due to GTK) or do you think that the multimedia key should act like + and - (that's probably not worth doing because the multimedia key events are not standard, assigned from a capplet and that would make the code complicated for a very special case, you usually either use the multimedia keys without opening the applet slider or use your mouse to interact with the applet)

Sebastien,
I believe the volume buttons should adjust the volume whether the volume applet slider is open or not, so yes this is similar to bug #32860.

Sebastien Bacher (seb128) wrote :

marking duplicate then

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments