Impossible to launch gnome-volume-control application in Ubuntu Karmic

Bug #439815 reported by Attila Hammer on 2009-10-01
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-media (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-volume-manager

Dear Developers!

If I try launch Applications/sound and video/volume control application, only an error message is displayed:
Information
Waiting sound system to respond.
Cancel

 I sending a screenshot with error message.

Thanks,

Attila

ProblemType: Bug
Architecture: i386
Date: Thu Oct 1 07:54:35 2009
DistroRelease: Ubuntu 9.10
Package: gnome-volume-manager (not installed)
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
SourcePackage: gnome-volume-manager
Uname: Linux 2.6.31-10-generic i686

Chris Coulson (chrisccoulson) wrote :

Please don't run gnome-volume-manager. It's functionality is deprecated by gvfs, completely unmaintained, and likely to cause more problems than it solves. gnome-volume-manager is going to be removed from the archive soon.

Changed in gnome-volume-manager (Ubuntu):
status: New → Won't Fix
Chris Coulson (chrisccoulson) wrote :

You actually assigned this to the wrong package. Your screenshot shows gnome-volume-control, which is a completely unrelated piece of software.

Please post the output of "gnome-volume-control --debug"

Thanks

affects: gnome-volume-manager (Ubuntu) → gnome-media (Ubuntu)
Changed in gnome-media (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: Won't Fix → Incomplete
Chris Coulson (chrisccoulson) wrote :

Have you uninstalled Pulseaudio?

Yes, because pulseaudio full blocked with Orca Screen Reader.
But if I remember correct, pulseaudio is default disabled since Jaunty
when accessible profile is selected during installation.
Now I installed again with pulseaudio. After logged out and login back
again, pulseaudio full blocked with Orca screen reader. But
gnome-volume-control application correct launched.

After this, I remove again pulseaudio with following command:
sudo apt-get purge pulseaudio
When logout and login again, Orca works correct, and
gnome-volume-control starts correct, I don't no why?

Attila

Hi, I can confirm the same problem in my machine.
I run gnome-volume-control from the system/preferences/sound menu.
Pulseaudio seems to be installed and the result of the command service pulseaudio status is:
* PulseAudio configured for per-user sessions

Attila Hammer (hammera) wrote :

Jose, please wait, I now downloading current daily live cd. I look what
happen when I booting the live cd and choosing accessibility profile.

Attila

Chris and Jose, I downloaded latest Karmic daily live cd, and try
booting with following steps:
1. I choose default language, and press enter key.
2. I press f5 key, and choose screen reader option with 3 down arrow
key. After this I press enter key.
3. Press enter key again, the system begin booting.

When the graphics environment is loaded, I rerun Orca screen reader
because not talking by default.
After this I try launch gnome-volume-control application. The problem is
present, the application waiting the sound system response.

Attila

Jeremy Lincicome (w0jrl1) wrote :

I am having the same issue on my Asus eeepc-900A. Removing Pulseaudio doesn't fix the issue.

Jackphone (jackphone) wrote :

$ gnome-volume-control --debug
** (gnome-volume-control:3348): DEBUG: Enabling debugging

** (gnome-volume-control:3348): WARNING **: Connection failed, reconnecting...

** (gnome-volume-control:3348): WARNING **: Connection failed, reconnecting...

** (gnome-volume-control:3348): WARNING **: Connection failed, reconnecting...

** (gnome-volume-control:3348): WARNING **: Connection failed, reconnecting...

** (gnome-volume-control:3348): WARNING **: Connection failed, reconnecting...

** (gnome-volume-control:3348): WARNING **: Connection failed, reconnecting...

** (gnome-volume-control:3348): WARNING **: Connection failed, reconnecting...
$

Sebastien Bacher (seb128) wrote :

the new comment errors are due to pulseaudio not running

gene (eugenios) wrote :

I had to remove pulseaudio because it's been very unstable and started giving me kernel dumps on Karmic. Therefore I had to remove it and got a similar problem.
Not only I do not see the volume applet. Quite a few applets like pidgin,tomboy, stardict, ekiga, linphone, nm are all gone on GNOME for me now (left upper corner)
Interestingly, these applets show up when called on the fluxbox !
I might have to report a separate bug too

sonescheiße (online-de) wrote :

same problem here, i deleted pulseaudio cause it only works for one of 6 users : / It is only possible for 1 user to use audio...

Now gnome-volume-controll will not start, same error like Jackphone posted above.

gene (eugenios) wrote :

I rebuild a package gnome-media-2.28.1 from source. The configuration was done by:

./configure --disable-pulseaudio --enable-gstmix --enable-gstprops --enable-grecord --disable-scrollkeeper
 Then I used "fakeroot make" with checkinstall to compile it.

I can now run gnome-volume-control with oss and/or alsa mixers... However, I still get problems with most of my gnoem applets on GNOME!
Nevertheless, haven't had any system locks (which most likely were due to pulseaudio server) ever since I removed the package.

I have re-compiled the relevant GNOME packages for users who can't or don't want to run PulseAudio.

https://launchpad.net/~dtl131/+archive/ppa

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers