No microphone on Dell Studio XPS 1340

Bug #436222 reported by Mike Basinger on 2009-09-24
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
gnome-media (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: pulseaudio

Neither my external or internal microphone work in Ubuntu Karmic Alpha 6 (updated 24 Sept 2009).

ProblemType: Bug
Architecture: i386
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: STAC92xx Analog [STAC92xx Analog]
   Subdevices: 2/2
   Subdevice #0: subdevice #0
   Subdevice #1: subdevice #1
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: dbasinge 2249 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xf0880000 irq 17'
   Mixer name : 'Nvidia MCP7A HDMI'
   Components : 'HDA:111d7675,10280271,00100103 HDA:10de0007,10280271,00100100'
   Controls : 27
   Simple ctrls : 15
Date: Thu Sep 24 16:01:41 2009
DistroRelease: Ubuntu 9.10
NonfreeKernelModules: nvidia wl
Package: pulseaudio 1:0.9.18-0ubuntu3
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-10.35-generic
SourcePackage: pulseaudio
Uname: Linux 2.6.31-10-generic i686

Mike Basinger (mike.basinger) wrote :

Looking @ your amixer output, all the capture elements are muted and/or
zeroed. Try adjusting them.

On Sep 24, 2009 6:10 PM, "Mike Basinger" <email address hidden> wrote:

** Attachment added: "AlsaDevices.txt"
  http://launchpadlibrarian.net/32405046/AlsaDevices.txt

** Attachment added: "AplayDevices.txt"
  http://launchpadlibrarian.net/32405059/AplayDevices.txt

** Attachment added: "BootDmesg.txt"
  http://launchpadlibrarian.net/32405071/BootDmesg.txt

** Attachment added: "Card0.Amixer.values.txt"
  http://launchpadlibrarian.net/32405086/Card0.Amixer.values.txt

** Attachment added: "Card0.Codecs.codec.0.txt"
  http://launchpadlibrarian.net/32405117/Card0.Codecs.codec.0.txt

** Attachment added: "Card0.Codecs.codec.3.txt"
  http://launchpadlibrarian.net/32405142/Card0.Codecs.codec.3.txt

** Attachment added: "CurrentDmesg.txt"
  http://launchpadlibrarian.net/32405163/CurrentDmesg.txt

** Attachment added: "Dependencies.txt"
  http://launchpadlibrarian.net/32405183/Dependencies.txt

** Attachment added: "PciMultimedia.txt"
  http://launchpadlibrarian.net/32405197/PciMultimedia.txt

-- No microphone on Dell Studio XPS 1340
https://bugs.launchpad.net/bugs/436222 You received this ...

Mike Basinger (mike.basinger) wrote :

Got internal mic working but still does not work with external mic in microphone jack. the Pulse control only sees one mic. Switching analog to digital or mic in to line in alsamixer.

Mike Basinger (mike.basinger) wrote :
Chris Beaven (smileychris) wrote :

Same issue on my Dell Studio 15

Daniel T Chen (crimsun) wrote :

Does installing linux-backports-modules-alsa-karmic resolve this symptom?

Chris Beaven (smileychris) wrote :

Haven't tried backports, but I fixed it via alsamixer.

Definitely should be a way to switch between this in the gui Sound Preferences dialog though.

Daniel T Chen (crimsun) wrote :

See also bug 418617

affects: pulseaudio (Ubuntu) → gnome-media (Ubuntu)
Changed in gnome-media (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

Daniel, why do you consider that a gnome-media issue?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers