Can't record a second sound clip

Bug #412738 reported by Anthony Batchelor on 2009-08-12
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GNOME media utilities
Expired
Medium
gnome-media (Ubuntu)
Low
Ubuntu Desktop Bugs
gnome-sound-recorder (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: gnome-media

I was trying to record various drum machine samples, but whenever I try to record a second sample, the first one plays again. To get around this, I have to restart Sound Recorder.

The name of the window updates (Untitled-N+1) but it just replays the first recording.

Ubuntu Jaunty: 9.04
gnome-media:
  Installed: 2.26.0-0ubuntu3
  Candidate: 2.26.0-0ubuntu3
  Version table:
 *** 2.26.0-0ubuntu3 0
        500 http://gb.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/gnome-sound-recorder
NonfreeKernelModules: fglrx
Package: gnome-media 2.26.0-0ubuntu3
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-media
Uname: Linux 2.6.28-14-generic x86_64

Anthony Batchelor (toeknee) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for the report, that works fine for me with Karmic, may you please try the same there? Thanks in advance.

Changed in gnome-media (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Anthony Batchelor (toeknee) wrote :

Not easily. I can't upgrade that system until Karmic is out, and the processor unfortunately doesn't have virtualisation extensions. I can run a VM on a different machine and try from there.

I forgot to mention, that the recording was done from an external sound card (M-audio fast track - USB), if that makes a difference.

Can you check under Jaunty to see if you can reproduce the problem?

Pedro Villavicencio (pedro) wrote :

The issue is that i don't have that device to test with and as said it works fine for me here. This might need to be confirmed by someone with similar setup and being able to test in Karmic, thanks.

Anthony Batchelor (toeknee) wrote :

Ah sorry, I thought you only tried it in Karmic.

If it's working for you in Jaunty and Karmic, then it seems more likely that it is an issue where the hardware setup is affecting the software, rather than just the software itself.

Adam Niedling (krychek) wrote :

This is still an issue in Lucid. Steps to reproduce:

1: record something
2: save it
3: record something else
4: press play button

Expected result: the second recording plays

Actual result: the first recording plays

You cannot listen to the second recording until you save it.

Changed in gnome-media (Ubuntu):
status: Incomplete → New
Adam Niedling (krychek) wrote :

This is still an issue in Maverick.

Adam Niedling (krychek) wrote :

This is still in issue in Oneiric. I even get an error that says: resource cannot be found.

Adam Niedling (krychek) wrote :

Still an issue in Precise.

Yu Ning (yuningdodo) wrote :

Hi, I am trying to fix this bug.

I think the problem is that sound recorder does file switching in the 'message::eos' handler, however the message is not generated at all. I am not sure if this is a bug in gstreamer, but we could at least bypass this by send the message manually when recording stopped by user.

You could find the details in https://code.launchpad.net/~yuningdodo/gnome-media/fix-missing-eos-in-sound-recording/+merge/130283

Yu Ning (yuningdodo) wrote :

There is a upstream report for this bug: https://bugzilla.gnome.org/show_bug.cgi?id=490576

Yu Ning (yuningdodo) wrote :

Maybe I should provide a patch instead of a branch.

The attachment "fix-missing-eos-in-sound-recording.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in gnome-media:
importance: Unknown → Medium
status: Unknown → Confirmed
Adam Niedling (krychek) wrote :

Sound Recorder does nothing when I press the Record button in Ubuntu 13.04.

Sound recording does work in Skype thou so the issue must be in the Sound Recorder app.

Adam Niedling (krychek) wrote :

In my previous comment I was talking about bug #1106908.

Adam Niedling (krychek) wrote :

Still cannot be tested in Ubuntu 13.10 because of bug #1106908.

Adam Niedling (krychek) wrote :

Cannot be tested because the sound recorder doesn't work. Bug #1157654.

Changed in gnome-media:
status: Confirmed → Expired
Adam Niedling (krychek) wrote :

Finally it's possible to record sound in Ubuntu 15.10 but when I tried to record a second clip it simply overwrited the first one...

Adam Niedling (krychek) wrote :

The second sound recording still overwrites the first one. And the play button does not work.

tags: added: xenial
Adam Niedling (krychek) wrote :

Still is still an issue in 18.04. It's even worse, you have to delete the first sound clip before you can record anything else.

Adam Niedling (krychek) wrote :

It's even worse again. It crashes when you try to play a recorded clip.

** (org.gnome.SoundRecorder:7019): CRITICAL **: 20:08:18.154: g_object_info_get_n_fields: assertion 'info != NULL' failed
**
Gjs:ERROR:gi/object.cpp:478:bool ObjectInstance::field_getter_impl(JSContext*, JS::HandleObject, JS::HandleString, JS::MutableHandleValue): assertion failed: (field)
Félbeszakítva (core készült)

Bug #1796649

tags: added: cosmic
Adam Niedling (krychek) wrote :

I make a recording, close the app, reopen again, make another recording. First one gets overwritten by the second. Kinda serious problem.

tags: added: disco
Meg Ford (meg387) wrote :

Hi, gnome-media has been deprecated for years now. Someone just pointed me to this bug this really should be closed since the current sound recorder is a completely new codebase and has nothing to do with the code from 2009. If the users here are experiencing a problem with the current sound recorder, it might be either this bug: https://bugzilla.gnome.org/show_bug.cgi?id=790682 or this one: https://gitlab.gnome.org/GNOME/gnome-sound-recorder/issues/44

If so please try updating to the latest version of sound-recorder and see if that fixes your issue.
If you still experience this bug after updating please open a bug report in GNOME Gitlab and include the information about what version of Ubuntu and what version of the sound recorder you are running. https://gitlab.gnome.org/GNOME/gnome-sound-recorder/issues

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.