gnome-sound-recorder: "Record from input" doesn't show all available inputs

Bug #378333 reported by Stephen Warren on 2009-05-19
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
gnome-media (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-media

When I run gnome-sound-recorder, there's a GUI element labelled "Record from input" and a drop-down that displays a single option "Capture".

The Gnome volume control indicates that I have two sound input sources; one "Capture: Monitor of Intel ICH6 - Intel ICH6 (PulseAudio Mixer)" (which I assume records whatever is being played) and another "Capture: Intel ICH6 - Intel ICH6 (PulseAudio Mixer)" (which I assume would record from a mic plugged into the mic in socket)

So, it's surprising that I can't select these options in gnome-sound-recorder.

What's worse is that if I plug in a USB headset with speakers and a mic (Plantronics, not sure of the model #), then the volume control applet shows two additional capture sources; "Capture: Monitor of Plantronics Headset - USB Audio (PulseAudio Mixer)" and also "Capture: Plantronics Headset - USB Audio (PulseAudio Mixer)"

Again, if I restart gnome-sound-recorder after plugging in this USB headset, and seeing the new sources in the volume control applet, then gnome-sound-recorder still won't show anything but "Capture" in the "Record from input" list.

Needless to say, this means that I can't record any audio (since either the option "Capture" is simply invalid, or perhaps because the default is the laptop built-in mic, but my laptop doesn't actually have a mic)

Sebastien Bacher (seb128) wrote :

Thanks for the bug report. This particular bug has already been reported, but feel free to report any other bugs you find.

Changed in gnome-media (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Invalid
Stephen Warren (srwarren) wrote :

OK, which other bug is it? I could only find closed bugs when I searched before...

Sebastien Bacher (seb128) wrote :

don't know about the number but there has been several similar complain, look to alsa gnome-media gnome-applets issues

Stephen Warren (srwarren) wrote :

Reopening. Simply closing the bug claiming that it's a dup without proof is non-sensical.

Changed in gnome-media (Ubuntu):
status: Invalid → New
Sebastien Bacher (seb128) wrote :

you really think you will make whoever work on this bug look at your issue by using confrontational behaviour?

Stephen Warren (srwarren) wrote :

No, my behaviour is not confrontational. In fact, to be honest, I found your behaviour (just closing the bug without any useful information at all) quite aggressive.

* If the bug is not a bug, then by all means close it (and state why, so that everyone else who is affected by this problem and finds this bug by Google/... will understand).

* If the bug is a duplicate, mark it as such, and state which specific bug it's a duplicate of. You need to state why so that (a) I can go subscribe to the "parent" bug. (b) Everyone else who finds this bug by Google/... will find useful information, not just yet another dead-end. Calling a dup "invalid" is also pretty insulting.

* Otherwise, the bug must stay open; it's a valid bug that needs to be fixed. I can't see why this isn't self-evident.

This is simply normal bug processing practice!

Sebastien Bacher (seb128) wrote :

the way you describe would work ideally, the issue is that we got so many bugs and duplicate that we would either spend the week looking for duplicates numbers or keep hundred of duplicates open and make the bug list un-usable for people who work on bugs which would defeat the purpose of bug reporting.
The current way is a compromise between those, we close bugs that we know to be duplicates and let the user search for the corresponding open bug.

Stephen Warren (srwarren) wrote :

That doesn't make sense; if I could have found the bug in the first place, I wouldn't have filed a new one...

This policy also doesn't help the other people who find all the dups via google, see they've all just been closed out, and have to file a new one because they can't find the original.

Delmir (delmir) wrote :

Would some one please point me the fix of this issue (only "capture" available in sound recorder)? I've spent many hours looking for it. BTW, It used to work fine on 7.10, but almost all the other options vanished after upgrade to 9.04. Any help or link would be highly appreciated.

Stephen Warren (srwarren) wrote :

I've just read through all the gnome-media bugs on launchpad. There is no bug besides this one that describes this problem.

Stephen Warren (srwarren) wrote :

I just went to bugzilla.gnome.org, and
a) Read the titles of all open bugs against Gnome-Sound-Recorder
b) Searched bugs in all states (open, closed, ...) for comments that mention "pulse" and then again for "pulseaudio".

None of those bugs describe this problem.

Delmir (delmir) wrote :

Would removing PULSE fix the problem? If so, should we replace PULSE with something else?

Delmir (delmir) wrote :

Bump. Did anyone had a chance to look at this?

Stephen Warren (srwarren) wrote :

This particular bug seems to have been made obsolete my Lucid (tested daily 1/31). The "Record from Input" option no longer appears in gnome-sound-recorder. Instead, it uses the system-wide default/current input stream selected by "sound preferences", and does appear to record OK.

I don't recall if i originally reported this against Jaunty or Karmic. It's possible it's also fixed in Karmic; I haven't checked. The bug can probably be closed as "Fix Released".

Delmir (delmir) wrote :

Okay. I just noticed that "PulseAudio Volume Control" did not install after upgrade from 8.04 to 9.04. I'm now able to record from different input streams once again, although it takes a lot of hoop-jumping. We could easily set it from the dropdown menu from the application being used, and now we have to play back and forth with PulseAudio Volume Control. Anyway, for those looking on how to get recording working once again, you can find more details here: https://wiki.ubuntu.com/PulseAudio.

PS.: Thanks for those maintaining this nice system/distro, but it seems to be that a nice feature was removed or "degraded".

papukaija (papukaija) wrote :

So this bug should be closed as suggested in comment 14?

Changed in gnome-media (Ubuntu):
status: New → Incomplete
Delmir (delmir) wrote :

Would it be too hard to re-implement that feature ("Record from input") back? It was so nice to have it right there and it was very handy. Should we have instead in the same place a link or a button that starts up pulse audio control open at the "Recording" tab, perhaps? Anyway, I found a way record what I needed, but again a VERY GOOD FEATURE was removed. It's so disappointing !8-(.

papukaija (papukaija) on 2010-07-21
tags: added: wishlist
Changed in gnome-media (Ubuntu):
status: Incomplete → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers