gnome-volume-control only goes to 100%

Bug #325215 reported by Rocko on 2009-02-04
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
GNOME media utilities
Fix Released
Low
gnome-media (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-media

Better integration is needed between gnome-volume-control and pulseaudio re volume control. This is probably a wishlist item.

Pulseaudio allows you to adjust volume between 0 and 480%. This is fantastic, especially for computers with low inputs and outputs like mine. But the volume sliders in gnome-volume-control only go to 100%. So:

a) When you adjust the pulseaudio slider, the corresponding gnome-volume-control slider moves, but stops at 100% and doesn't display the actual value.

b) If you try to adjust the gnome-volume-control-slider, it immediately resets the pulseaudio volume slider back to 100%.

The attached image illustrates this. The pulseaudio volume controls are obtained by running PulseAudioManager and then selecting Manager from its notification panel control and then double-clicking on the appropriate device in the Devices tab. In Jaunty, the gnome-volume-control is in the notification panel as well.

The gnome volume control applet in the notification panel does know that the volume is over 100% (its pop-up hint says, for instance "Output: 127% 29.77 db", but its slider also is limited to 100% and if you use this slider to adjust the volume, it resets it to 100%.

What I think should happen is that the gnome-volume-control sliders shouldn't be limited to 100%, and if pulseaudio directs that the volume has gone above 100%, gnome-volume-control's sliders should reflect this correctly.

Version information:
ubuntu 9.04
gnome-media 2.25.5-0ubuntu1
pulseaudio 0.9.14-0ubuntu3

Rocko (rockorequin) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that's an upstream bug and should be sent to bugzilla.gnome.org by somebody having the issue

Changed in gnome-media (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Andrea Grandi (andreagrandi) wrote :

Maybe this could be the explanation for this problem I'm having: http://ubuntuforums.org/showthread.php?p=7135502#post7135502

Since I installed Ubuntu 9.04 Jaunty, volume is very low on my Asus EeePC 901 (it worked fine with ubuntu 8.10).

Sebastien Bacher (seb128) wrote :

Could you try if that's still an issue on karmic?

Rocko (rockorequin) wrote :

Yes, karmic is exactly the same. Pulseaudio's volume control app and Gnome's volume control only go to 100%, but the pulseaudio device manager's volume control allows 480%, and the behaviour is as described in the original report.

You also still can't adjust headphone volume, etc, or the login/logout sounds from Gnome's volume control, so there Karmic has a regression in functionality compared to Jaunty/Intrepid - I think those were logged as separate bugs, however.

Sebastien Bacher (seb128) wrote :

Could you send the bug upstream since you get the isuse?

Rocko (rockorequin) wrote :

I opened http://bugzilla.gnome.org/show_bug.cgi?id=591285 but there isn't an 'assigned to' URL entry to record this.

Changed in gnome-media (Ubuntu):
status: New → Triaged
Changed in gnome-media:
status: Unknown → New
Nic (ntetreau) wrote :

The upstream bug has been marked as fixed, but I still have this issue in Karmic as of today...

Nic (ntetreau) wrote :

What I meant to say is that the applet's slider is still limited to 100% even though the the properties dialogue or pavucontrol output goes up to 150%. That means that the sound jumps from 150% directly to 100% if I adjust it using the keyboard or the applet. Then, I cannot go back up above 100% unless I go back into the properties or pavucontrol.

tgpraveen (tgpraveen89) wrote :

@Nic
Please file a separate bug about the applet behaviour not adopting new changes.

dman7 (dmitriskj) wrote :

The link [http://bugzilla.gnome.org/show_bug.cgi?id=591285] doesn't work. Has anyone fixed this since last time? If so, where could I find the patch? Thanks

Rocko (rockorequin) wrote :

@dman7: That link works for me. It says the patch is at https://bugzilla.gnome.org/attachment.cgi?id=143284. But the patch is already included in Ubuntu 10.04 and I suspect 9.10 also.

Changed in gnome-media:
importance: Unknown → Low
status: New → Fix Released
Jean-Philippe Fleury (jpfle) wrote :

Is there an upstream bug report about the applet?

Jean-Philippe Fleury (jpfle) wrote :

I didn't find any upstream bug report about the applet, so I created this one:

https://bugzilla.gnome.org/show_bug.cgi?id=632720

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.