Ubuntu now has both gnome volume and pulse sound on the panel

Bug #324807 reported by Dave Morley on 2009-02-03
30
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-media (Ubuntu)
Medium
Ubuntu Desktop Bugs
Jaunty
Medium
Ubuntu Desktop Bugs

Bug Description

RELEASE: Jaunty
CD/DVD VARIANT: Ubuntu 32bit Desktop Cd
ISO BUILD: 20090203

SYMPTOMS: The live cd has only pulse audio for volume. However once installed I was informed of 34 updates. I installed the updates and now have 2 volume icons on the panel. 1 is gnome-volume the other is pulse-audio's

CAUSE: unknown

STEPS TO REPRODUCE:
1/ Install from the 20090203 cd
2/ Install the updates from update manager
3/ See the 2 volume controlers

Related branches

Connor Imes (rocket2dmn) wrote :

I can confirm this behavior on the latest Jaunty updates (Feb 3, 2009). I wonder if this is related to the poor sound quality I experienced with the login sound after I logged back in.
The two applets that appear seem to be gnome-volume-control-applet (source: gnome-media) and mixer_applet2 (source: gnome-applets). I would guess that the problem originates in gnome-utils which was upgraded today, so I will file this bug under that package.

Connor,

gnome-utils is not involved in the volume capplet, so I would change the component to gnome-media, but the thing that puzzle me is it was not updated in the past days. I wonder if some schemas were changed.
The change seems to appeared during 2th of February, GMT

Davmor2, do you remember the updates that were proposed to you?

Dave Morley (davmor2) wrote :
Download full text (10.7 KiB)

The following is from the /var/log/apt/term.log:

Log started: 2009-02-03 10:37:43
(Reading database ... 102346 files and directories currently installed.)
Preparing to replace libx11-data 2:1.1.99.2-1build1 (using .../libx11-data_2%3a1.1.99.2-1ubuntu2_all.deb) ...
Unpacking replacement libx11-data ...
Preparing to replace libx11-6 2:1.1.99.2-1build1 (using .../libx11-6_2%3a1.1.99.2-1ubuntu2_amd64.deb) ...
Unpacking replacement libx11-6 ...
Preparing to replace acpi-support 0.116 (using .../acpi-support_0.117_amd64.deb) ...
 * Disabling power management...
   ...done.
Removing obsolete conffile /etc/acpi/events/ibm-sleepbtn ...
Removing obsolete conffile /etc/acpi/events/ibm-lockbtn ...
Removing obsolete conffile /etc/acpi/thinkpad-lockorbattery.sh ...
Removing obsolete conffile /etc/acpi/events/ibm-hibernatebtn ...
Removing obsolete conffile /etc/acpi/events/lenovo-lockbtn ...
Removing obsolete conffile /etc/acpi/events/ibm-videobtn ...
Removing obsolete conffile /etc/acpi/events/thinkpad-mute ...
Removing obsolete conffile /etc/acpi/always-mute.sh ...
Removing obsolete conffile /etc/acpi/events/thinkpad-volume-down ...
Removing obsolete conffile /etc/acpi/events/thinkpad-volume-up ...
Removing obsolete conffile /etc/acpi/events/thinkpad-zoom ...
Removing obsolete conffile /etc/acpi/thinkpad-zoom.sh ...
Removing obsolete conffile /etc/acpi/events/thinkpad-thinklight ...
Removing obsolete conffile /etc/acpi/thinkpad-thinklight.sh ...
Removing obsolete conffile /etc/acpi/events/tosh-brightness-up ...
Removing obsolete conffile /etc/acpi/events/tosh-brightness-down ...
Removing obsolete conffile /etc/acpi/events/tosh-mute ...
Removing obsolete conffile /etc/acpi/events/tosh-sleep ...
Removing obsolete conffile /etc/acpi/events/sony-hibernate ...
Removing obsolete conffile /etc/acpi/events/sony-brightness-up ...
Removing obsolete conffile /etc/acpi/events/sony-brightness-down ...
Removing obsolete conffile /etc/acpi/sonybright.sh ...
Removing obsolete conffile /etc/acpi/events/thinkpad-brightness-down ...
Removing obsolete conffile /etc/acpi/events/thinkpad-brightness-up ...
Removing obsolete conffile /etc/acpi/thinkpad-brightness-up.sh ...
Removing obsolete conffile /etc/acpi/thinkpad-brightness-down.sh ...
Unpacking replacement acpi-support ...
Preparing to replace alsa-utils 1.0.18-1ubuntu7 (using .../alsa-utils_1.0.18-1ubuntu8_amd64.deb) ...
Unpacking replacement alsa-utils ...
Preparing to replace libgnome2-common 2.24.1-1ubuntu2 (using .../libgnome2-common_2.24.1-1ubuntu3_all.deb) ...
Unpacking replacement libgnome2-common ...
Preparing to replace libgnome2-0 2.24.1-1ubuntu2 (using .../libgnome2-0_2.24.1-1ubuntu3_amd64.deb) ...
Unpacking replacement libgnome2-0 ...
Preparing to replace deskbar-applet 2.25.5-0ubuntu1 (using .../deskbar-applet_2.25.90-0ubuntu1_amd64.deb) ...
Unpacking replacement deskbar-applet ...
Preparing to replace ghostscript 8.64.dfsg.1~svn9415-0ubuntu1 (using .../ghostscript_8.64.dfsg.1~svn9432-0ubuntu1_amd64.deb) ...
Cleaning up font configuration of gs...
Cleaning up category psprint..
Cleaning up category cmap..
Cleaning up category cid..
Cleaning up category truetype..
Cleaning up category gsfontderivative..
Clea...

Connor Imes (rocket2dmn) wrote :

I've attached my term.log, I haven't updated since this bug appeared yesterday, and my updates are similar to davmor's. I don't know exactly what to file this bug under since neither gnome-media or gnome-applets have been updated recently, and there must be something that is loading them anyway. Volume Control is enabled in System->Preferences, but there is no mention of mixer_applet.

I'll will change the package to gnome-media for now. However, perhaps we have a pulseaudio problem, or more specifically, pulseaudio-module-gconf? These were included in the updates and the pulseaudio related applet appeared.

yes you're now having both but that's going to be replaced during jaunty cycle for the one in intrepid.

Changed in gnome-media:
assignee: nobody → desktop-bugs
milestone: none → ubuntu-9.04-beta
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-media - 2.25.5-0ubuntu2

---------------
gnome-media (2.25.5-0ubuntu2) jaunty; urgency=low

  * debian/control.in,
    debian/gnome-media-common.install,
    debian/rules:
    - enable the intrepid version of the mixer capplet rather than the new one
      (lp: #324807)

 -- Sebastien Bacher <email address hidden> Thu, 05 Feb 2009 16:13:35 +0100

Changed in gnome-media:
status: Confirmed → Fix Released

Why is Ubuntu resisting change on the issue of volume applets?

Sebastien Bacher (seb128) wrote :

what do you mean exactly there? why not using the new capplet in jaunty? look at the list of bugs, the new capplet can't control alsa directly or control other channel or enable numeric sources

Fair enough, I will try to control myself in future.

Id2ndR (id2ndr) wrote :

Is the new mixer which is integrate to pulseaudio present upstream in gnome ?

The one that is used in Ubuntu is no longer in GNOME, and the one that is in GNOME is not used in Ubuntu.

shockawe5 (shockawe5) wrote :

Is the new mixer really not going to be in Jaunty? Is there a way we can still use it, even if it's not going to be the default?

I'm not a developer, and I don't want to sound like I'm complaining for no reason, but this new applet really should be in Jaunty. This was really the last step in completing the transition to Pulseaudio: a nice GUI to tie it all together. Switching back to the old mixer really doesn't fix the bug, it just postpones it.

Martin (agima) wrote :

Alex, I agree on your opinion in general but on the other side the new pulseaudio enabled mixer is missing some important features. You can't move streams between devices (as in pavucontrol) and there are the problems Sebastien already mentioned. I hope these problems will be solved upstream and ubuntu will then ship the new version. But I don't believe it will be ready for jaunty. What a bummer!

To use it anyway you'll need to recompile the package with --enable-pulseaudio.

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers