rhythmbox adding songs to ipod no sound

Bug #190818 reported by Marcos on 2008-02-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
GNOME media utilities
Confirmed
Medium
Rhythmbox
Invalid
Undecided
Unassigned
gnome-media (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

I have a small collection of OGG songs playing on rhythmbox, they play just fine everywhere, but when I use rhythmbox to transfer songs to my ipod nano 3G, they do pass after being encoded, but once I try to play them they show the info and length of the song but does not actually play. SOME songs do get to be playable, some don't after the conversion.

Pedro Villavicencio (pedro) wrote :

Thanks for your report, Does your iPod have support for OGG ? IIRC they don't,

Changed in rhythmbox:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Marcos (marcosrdz) wrote :

No iPod has OGG Support, it's firmware doesn't beleive in opensource ;-). But rhythmbox converts the transfrred OGGs into MP3s, but the majority of the conversion result end up in a mute file inside the ipod's database.

Sebastien Bacher (seb128) wrote :

Could you attach an example which is not converted correctly?

Basilio Kublik (sourcercito) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New".

Thanks again!

Changed in rhythmbox:
status: New → Invalid
status: Incomplete → Invalid
Marcos (marcosrdz) wrote :

If i transfer mp3 files to the ipod with rhythmbox they are successfully transferred and play perfectly, but if i transfer an ogg or flac file it gets converted, transfered and added to the itunesdb but the ipod wont play it, but the converted file does play fine on the computer

Changed in rhythmbox:
status: Invalid → New
status: Invalid → New
Sebastien Bacher (seb128) wrote :

the aac issue is a known one, do you have an ogg example to attach?

Changed in rhythmbox:
status: New → Incomplete
Marcos (marcosrdz) wrote :

Here is an OGG

Changed in rhythmbox:
status: Incomplete → New
Matt Giuca (mgiuca) wrote :

This problem just started happening to me after I wiped Gutsy and installed Hardy. (ie. I can transfer OGG to iPod using RhythmBox, it gets transcoded to an M4A file but the iPod refuses to play it, even though RhythmBox itself can still play it).

Tried it on the above OGG file (If Trees Could Speak) to confirm, and got the same behaviour as my OGG files.

RhythmBox v 0.11.5

Pedro Villavicencio (pedro) wrote :

Please send this upstream since you're getting the issue and can answer the questions from the rhythmbox developers, for instructions on how to do it, please take a look to https://wiki.ubuntu.com/Bugs/Upstream/GNOME ; leaving this as incomplete until that, thanks in advance.

Changed in rhythmbox:
status: New → Incomplete
Matt Giuca (mgiuca) wrote :

OK this is already reported upstream, so replies should be directed to this thread:
http://bugzilla.gnome.org/show_bug.cgi?id=459933

Thanks Pedro

Matt Giuca (mgiuca) wrote :

Ah so I just followed a chain of bugs to get myself a pretty good workaround.

This bug seems only to happen for AAC encoding. Switch over to MP3.

This was problematic for me because I couldn't get "CD Quality, MP3" to appear in the dropdown list under Edit -> Preferences -> Music -> Preferred Format. You need to have Ubuntu packages BOTH liblame0 and gstreamer0.10-plugins-ugly-multiverse installed. Then MP3 will appear in the "Preferred Format" dropdown for Rhythmbox and it will transcode to MP3 instead of AAC.

Changed in rhythmbox:
status: Incomplete → Triaged
status: New → Unknown
Changed in rhythmbox:
status: Unknown → New
tonfa (bboissin) wrote :

Alternatively, just edit the preferred format for aac and change "faac" to "faac profile=2" that way it will generate files actually readable by the ipod.

Changed in rhythmbox:
status: New → Confirmed
affects: rhythmbox (Ubuntu) → gnome-media (Ubuntu)
Changed in rhythmbox:
importance: Unknown → Undecided
status: Confirmed → New
status: New → Invalid

In the Ubuntu 10.10 when I transfer a mp3 to Ipod it don't play the music, but add info to database.

I try with Amarok and it play.

Changed in gnome-media:
importance: Unknown → Medium
status: Unknown → Confirmed
Rodrigo Donado (frezeeer) wrote :

The files are in the iPod, you can open them from Rhythmbox, and the iPod has the space "taken" by the mp3, but they don't play.

arual (arual) wrote :

I have the same problem on Ubuntu 10.10. It seems that Rhythmbox transfers the files but somehow "loses" the .mp3 extension in the process. The files themselves are not damaged, because they work fine if I transfer them on the ipod using itunes on windows after re-adding the extension manually.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.