gstreamer-properties: testing input fails with "Failed to construct test pipeline for ..."

Bug #144628 reported by Juan Pablo Salazar Bertín on 2007-09-25
16
Affects Status Importance Assigned to Milestone
GNOME media utilities
Expired
Medium
gnome-media (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-media

I'm experiencing same behaviour as in bug #37184.

Steps to reproduce:
1. Run gstreamer-properties.
2. Select ALSA or OSS as plugin for default input.
3. A message with an error like: "Failed to construct test pipeline for 'ALSA - Advanced Linux Sound Architecture'" will come up, depending on which input you select.

Last lines from debug output:

0:00:16.703259000 7489 0x804e408 INFO GST_STATES gstbin.c:2058:gst_bin_change_state_func:<pipeline0> child 'alsasrc2' changed state to 4(PLAYING) successfully
0:00:16.703332000 7489 0x804e408 INFO GST_STATES gstbin.c:1519:gst_bin_get_state_func:<pipeline0> getting state
0:00:16.703387000 7489 0x804e408 INFO GST_STATES gstelement.c:1876:gst_element_get_state_func:<pipeline0> waiting for element to commit state
0:00:19.703502000 7489 0x804e408 INFO GST_STATES gstelement.c:1880:gst_element_get_state_func:<pipeline0> timed out

ProblemType: Bug
Architecture: i386
Date: Mon Sep 24 20:16:13 2007
DistroRelease: Ubuntu 7.10
Package: gnome-media 2.20.1-0ubuntu1
PackageArchitecture: i386
SourcePackage: gnome-media
Uname: Linux snifer-laptop 2.6.22-12-generic #1 SMP Sat Sep 22 18:14:28 GMT 2007 i686 GNU/Linux

Full debug output.
It was killed at the moment where the error message popped up.

elyk (elyk53) wrote :

I am experiencing a similar bug, with the same error message in gstreamer-properties. If I run the gnome sound config applet and test "Sound Capture" from there, I get the message "gconfaudiosrc ! audioconvert ! audioresample ! gconfaudiosink profile=chat: Could not open resource for writing."
I'm running a dell Vostro 1500 with Intel HDA Audio, Sigmatel STAC 9205 chipset

Similar output here.
Graphical output attached.

Sebastien Bacher (seb128) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=480193

Changed in gnome-media:
assignee: nobody → desktop-bugs
importance: Undecided → Medium
status: New → Triaged
Changed in gnome-media:
status: Unknown → New
Changed in gnome-media:
status: New → Confirmed
Changed in gnome-media:
importance: Unknown → Medium
Changed in gnome-media:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.