Sound recorder does not work

Bug #1157654 reported by Jacek Nykis on 2013-03-20
358
This bug affects 115 people
Affects Status Importance Assigned to Milestone
GNOME media utilities
Expired
Critical
gnome-media (Debian)
Fix Released
Unknown
gnome-media (Ubuntu)
High
Unassigned
Nominated for Trusty by Alberto Salvia Novella
Nominated for Utopic by Alberto Salvia Novella

Bug Description

Sound recorder 3.4 does not work.

 - Does not show any activity under "Level".
 - Nothing happens after clicking the record button, choosing record from the menu or after pressing Ctrl+R.
 - Recording works in other applications.
 - Input tab under sound settings shows activity on input.

It would be interesting to know if other applications using pulseaudio can record on your system. (Maybe try playing with parecord command?)

A pulseaudio log of you reproducing the issue in sound recorder could also be helpful: https://wiki.ubuntu.com/PulseAudio/Log
And for good measure, general sound info: https://wiki.ubuntu.com/Audio/AlsaInfo

James Lewis (james-fsck) wrote :

I have the same issue, seen in the video here:-

https://www.youtube.com/watch?v=TDTw3Q4mTmQ

Other applications can record using pulseaudio, I regularly use pulseaudio to manage 4 or 5 possible input sources and several outputs depending on the application. This appears to be an issue specifically with Sound Recorder. I have verified it on 2 machines now.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-media (Ubuntu):
status: New → Confirmed
Changed in pulseaudio (Ubuntu):
status: New → Confirmed
James Lewis (james-fsck) wrote :

Also, note that the original poster observed:-

* recording is fine in audacity

This seems to confirm that this is the same issue.

Jacek Nykis (jacekn) wrote :

I tested parecord command and it works fine. I recored sound using:
parecord -r file
and I could paly it fine using:
parecord -p file

Jacek Nykis (jacekn) wrote :
Jeremy Bicha (jbicha) on 2013-06-14
Changed in pulseaudio (Ubuntu):
importance: Undecided → Medium
Changed in gnome-media (Ubuntu):
importance: Undecided → Medium
James Lewis (james-fsck) wrote :

Still seeing this issue in 13.10

Raymond (superquad-vortex2) wrote :

did recorder only record mono ?

are there any difference recoding mono or stereo in auadcity ?

the capture volume also has 30dB gain in addition to int Mic boost

what are the percentage and dB in the output of

pactl list sources

when you change the slider in capture screen in gnome sound preference

0.040| 0.000) D: [pulseaudio] alsa-mixer.c: Path analog-input-microphone-internal (Internal Microphone), direction=2, priority=89, probed=yes, supported=yes, has_mute=yes, has_volume=yes, has_dB=yes, min_volume=0, max_volume=3, min_dB=-17.25, max_dB=60

do these values match the above dB values from 0% to 100% ?

James Lewis (james-fsck) wrote :

As far as I remember, it worked for both mono and stereo sources.

Audacity can record mono and stereo sources, the only observable difference is the number of channels recorded.

??

0db 100%

pactl list sources attached.

No idea how to answer the last question, I do not have gnome installed.

Adam Niedling (krychek) on 2013-12-20
tags: added: saucy
James Lewis (james-fsck) wrote :

Still faulty in Trusty... although gnome-media is no-longer installed by default and is not in the main repo... so probably this will not be an issue in future... I hear romours of a shiny new sound recorder?

tags: added: trusty
Raymond (superquad-vortex2) wrote :

Have you check whether the left and right channels out out phase or not ?

Artscoop93 (artscoop93) wrote :

The app does not work properly in 13.10 and 14.04. The only available input is Master, and the "Save as" combobox is empty, where it should list folder shortcuts.
The sound level progressbar is greyed and playing a sound (Open an MP3) freezes the app.

rpr nospam (rpr-nospam) wrote :

I can confirm that the Sound Recorder does not work on a clean install of Ubuntu 14.04 x86 on a Dell laptop.

As a workaround I installed Audio Recorder from https://launchpad.net/~osmoma/+archive/audio-recorder

$ sudo add-apt-repository ppa:osmoma/audio-recorder
$ sudo apt-get update
$ sudo apt-get install audio-recorder

Micouin Claude (mlnglst) wrote :

Hi.
I've just installed a Ubunt14.04 amd64 and gnome-sound-recorder does not work. It's the same problem as we can see in the video of James Lewis.
If I clik on the red button one more time, I've got this response in a terminal :
(gnome-sound-recorder:9720): GStreamer-WARNING **: Element 'gconfaudiosource' already has parent

I can record sound on my computer using Adacity without problems.

Thanks.

Michel-Ekimia (michel.ekimia) wrote :

Hi just discovered this which is a high blocking issue for our oem computers.

does anybody works on this ? what is exactly teh root of the problem ?

At said in <https://bugzilla.gnome.org/show_bug.cgi?id=677199#c0>, the root cause of the bug is the GNOME Sound Recorder being unable to set up its choices of codecs with the used gstreamer version.

Changed in gnome-media (Ubuntu):
status: Confirmed → Triaged
no longer affects: pulseaudio (Ubuntu)
Michel-Ekimia (michel.ekimia) wrote :

The gnome bug talks about Gstreamer 0.10 , we shuold focus on trusty and check why it does not work with gstreamer 1.0 instead

Changed in gnome-media:
importance: Unknown → Critical
status: Unknown → New
Changed in gnome-media:
status: New → Expired
Michel-Ekimia (michel.ekimia) wrote :

So should we open a new bug for trusty ?

Changed in gnome-media (Debian):
importance: Undecided → Unknown
status: New → Unknown

The bug has been marked upstream as expired by mistake, since GNOME 3.4 is still a supported version as explained in <https://wiki.gnome.org/Bugsquad/TriageGuide>.

So I have reopened the upstream report.

Changed in gnome-media:
importance: Critical → Unknown
status: Expired → Unknown

Since this bug renders essential functionality of the package broken, it has a priority of high.

Changed in gnome-media (Ubuntu):
importance: Medium → High
description: updated
tags: added: utopic
Changed in gnome-media (Debian):
status: Unknown → New
Changed in gnome-media:
importance: Unknown → High
status: Unknown → Invalid
Adam Niedling (krychek) wrote :

14.04 is the third consecutive Ubuntu release in which the sound recorder does not work. It was about time someone noticed.

The package version of gnome-media in current development releases of Debian and GNOME is 3.4, but:

 - The upstream GNOME developers are not longer supporting it (https://bugzilla.gnome.org/show_bug.cgi?id=677199)
 - GNOME Sound Recorder in this package hasn't been working since November 2011 (https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=649510)
 - The package has been kept in this version since May 2013 (https://packages.debian.org/search?keywords=gnome-media)
 - GNOME Sound Recorder has been rewritten from scratch in JavaScript (https://bugzilla.gnome.org/show_bug.cgi?id=677199#c9)

I have reported this issue to the following teams:

 - Debian GNOME
 - Ubuntu Quality
 - Debian Multimedia

So we can make clear which is the next action to be taken.

Changed in gnome-media:
importance: High → Unknown
status: Invalid → Unknown
Changed in gnome-media:
importance: Unknown → Critical
status: Unknown → Expired
grinch (grinch) wrote :

Why has this been marked "expired"? It has not expired, because it has not been fixed
The sound recorder program is still listed in ubuntu application directory for 14.04 desktop users, but IT DOES NOT WORK

@ grinch

You can go to the upstream bug tracker and see yourself.

grinch (grinch) wrote :

thank you for trying to help, but that does not answer my question

@ grinch

The answer is the package is not longer supported by the GNOME project, but by the Debian operating system only.

grinch (grinch) wrote :

Thank you for the response.

If GNOME no longer supports it, and it Still Does Not Work, why is it included in Application directory for Ubuntu 14.04?
It has been like this for years, certainly something Ubuntu should have corrected by now

@ grinch

Ubuntu includes the package because its architecture is based on Debian's; and what Debian is using right now is this package, till they upgrade it.

And the reason why this bug isn't corrected is plainly because the triaging work-flow isn't agile enough right now for handling errors at the cadence Ubuntu releases have.

Canonical took this decision probably because it would be difficult to create a constant flow of improvement with software being stabilized for a long time. So they relied that Ubuntu would be able to fix problems in the future in shorter periods of time, after some continuous improvement in bug management processes and getting more people interested in using the operating system.

grinch (grinch) wrote :

I realize you are not Ubuntu, so realize I am not trying to argue with you about this. I appreciate discussing it however, as the decision or lack of action mystifies me.

None of those are valid reasons for Ubuntu to leave this package listed. If this were a recent bug that might be different, but this application has not worked since version 12.04, over 2 years ago.
That is plenty of time for either developer to fix bug/issue, or for Canonical/Ubuntu to remove the application from the application directory, because the developer dropped the ball.

grinch:
 > I realize you are not Ubuntu, so realize I am not trying to argue with
 > you about this.

Exactly: I am myself, even when coordinating Ubuntu papercuts quality :-D

grinch:
 > I appreciate discussing it however, as the decision or
 > lack of action mystifies me.

I can tell you two secrets:

  - One is the software quality assurance is in its infancy, and some
work is still to be done. And operating systems usually ignore this by
testing software for long periods of time.

  - The other is I only sell with the work finished. Even when I have
been spending my hole attention on this issue and I believe there will
be a huge difference, the reality is that it's only warranted what
already is.

grinch:
 > That is plenty of time for either developer to fix bug/issue, or for
 > Canonical/Ubuntu to remove the application from the application
 > directory, because the developer dropped the ball.

Since the package is borrowed from Debian, only Debian could do that.
But Ubuntu is still able to fix the package itself.

Regards.

Jackson Doak (noskcaj) wrote :

Gnome-sound-recorder is now a separate package and will be dropped from gnome-media in the next ubuntu release

Changed in gnome-media (Ubuntu):
status: Triaged → Won't Fix
status: Won't Fix → Incomplete
uwe (maabdulhaq) wrote :

I know this is not a forum, but wouldn't suggesting alternative package/tool that is indeed supported by ubuntu be a good idea, as the problem can also be described as "I dont have a simple recording tool" ...

@ Jackson Doak

Even when the package is going to be dropped in the next Ubuntu release the bug still needs to be fixed for the Trusty release, where the package will continue being the same till April 2017.

Changed in gnome-media (Ubuntu):
status: Incomplete → Triaged
Aleksei (tav-susp) wrote :

#33
exactly...(((

Changed in gnome-media (Debian):
status: New → Fix Released
Adam Niedling (krychek) wrote :

It's working in Ubuntu 15.10!!!

Adam Niedling (krychek) wrote :

When I tried to record a second clip it simply overwrited the first one... not so good.

@ Adam Niedling

Please:

1. Report that as a separate bug.
2. Paste the new report link here.
3. Then the rest of people mark it as affecting you too.

Thank you.

Adam Niedling (krychek) wrote :

Alberto: actually it's not a new bug, it's been around long before this one. It's bug #412738.

(omg overwrited=overwrote, I must've been tired...)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.