Maps app no longer works because MapQuest disabled access

Bug #1602035 reported by Jeremy Bicha on 2016-07-11
86
This bug affects 17 people
Affects Status Importance Assigned to Milestone
GNOME Maps
Fix Released
High
Ubuntu GNOME
High
Unassigned
gnome-maps (Debian)
Fix Released
Unknown
gnome-maps (Ubuntu)
High
Unassigned
Trusty
High
Unassigned
Wily
High
Unassigned
Xenial
High
Unassigned
livecd-rootfs (Ubuntu)
High
Unassigned
Xenial
High
Adam Conrad
ubuntu-gnome-meta (Ubuntu)
High
Unassigned
Xenial
High
Unassigned

Bug Description

As of today, MapQuest has disabled their free map tile feed. This means the Maps app no longer displays anything except a warning pointing to

http://devblog.mapquest.com/2016/06/15/modernization-of-mapquest-results-in-changes-to-open-tile-access/

Screenshot attached.

[Impact]
GNOME Maps is included by default in Ubuntu GNOME 15.10 and 16.04. The app currently is useless.

Triaged as "High" because it "prevents the application or any dependencies from functioning correctly at all". https://wiki.ubuntu.com/Bugs/Importance

This also breaks libchamplain (a library for embedding maps into your app). Once a fix is released, apps using libchamplain will likely need to be patched to use a different map provider.

[Test Case]
Install gnome-maps. Open the Maps app. Do you see maps?

Note that maps are cached so you may not notice the feed has been disabled unless you try viewing a specific area at a close enough zoom that you have not viewed recently.

[Regression Potential]
Upstream changes to switch to Mapbox has potential to break unrelated features.

https://mail.gnome.org/archives/desktop-devel-list/2016-July/msg00003.html

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :
Changed in gnome-maps (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in ubuntu-gnome:
importance: Undecided → High
status: New → Triaged
Jeremy Bicha (jbicha) on 2016-07-11
Changed in gnome-maps (Ubuntu Trusty):
importance: Undecided → High
status: New → Triaged
Changed in gnome-maps (Ubuntu Wily):
status: New → Triaged
importance: Undecided → High
Changed in gnome-maps (Ubuntu Xenial):
status: New → Triaged
importance: Undecided → High
Jeremy Bicha (jbicha) on 2016-07-12
summary: - Maps app no longer works because Mapquest disabled access
+ Maps app no longer works because MapQuest disabled access
description: updated
Changed in gnome-maps:
importance: Unknown → High
status: Unknown → Confirmed
Changed in gnome-maps (Ubuntu Trusty):
status: Triaged → Confirmed
Changed in gnome-maps (Ubuntu Xenial):
status: Triaged → Confirmed
Jeremy Bicha (jbicha) on 2016-07-12
Changed in gnome-maps (Ubuntu Trusty):
status: Confirmed → Triaged
Changed in gnome-maps (Ubuntu Xenial):
status: Confirmed → Triaged
Changed in gnome-maps (Debian):
status: Unknown → Confirmed
Jeremy Bicha (jbicha) on 2016-07-13
description: updated
Jeremy Bicha (jbicha) on 2016-07-13
no longer affects: ubuntu-gnome-meta (Ubuntu Trusty)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-gnome-meta - 0.61

---------------
ubuntu-gnome-meta (0.61) yakkety; urgency=medium

  * Refreshed dependencies
  * Removed gnome-maps from desktop-recommends (LP: #1602035)
  * Bump Standards-Version to 3.9.8

 -- Jeremy Bicha <email address hidden> Wed, 13 Jul 2016 09:53:21 -0400

Changed in ubuntu-gnome-meta (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-gnome-meta (Ubuntu Wily):
status: New → Confirmed
Changed in ubuntu-gnome-meta (Ubuntu Xenial):
status: New → Confirmed
Jeremy Bicha (jbicha) on 2016-07-14
no longer affects: ubuntu-gnome-meta (Ubuntu Wily)
Changed in libchamplain (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in libchamplain (Ubuntu Xenial):
importance: Undecided → High
status: New → Triaged
Jeremy Bicha (jbicha) on 2016-07-14
Changed in ubuntu-gnome-meta (Ubuntu Xenial):
importance: Undecided → High
status: Confirmed → In Progress
Changed in ubuntu-gnome-meta (Ubuntu):
importance: Undecided → High
Jeremy Bicha (jbicha) on 2016-07-14
description: updated
description: updated

Hello Jeremy, or anyone else affected,

Accepted ubuntu-gnome-meta into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-gnome-meta/0.58.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-gnome-meta (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Jeremy Bicha (jbicha) wrote :

Upgrading ubuntu-gnome-desktop to 0.58.1 from -proposed does not mark remove gnome-maps nor mark it for autoremoval but that's ok for now.

I'm waiting to mark this verified-done since we don't yet have a xenial ubuntu-gnome .iso without gnome-maps.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-gnome-meta - 0.58.1

---------------
ubuntu-gnome-meta (0.58.1) xenial; urgency=medium

  * Refreshed dependencies
  * Removed gnome-maps from desktop-recommends (LP: #1602035)

 -- Jeremy Bicha <email address hidden> Thu, 14 Jul 2016 11:35:57 -0400

Changed in ubuntu-gnome-meta (Ubuntu Xenial):
status: Fix Committed → Fix Released
Adam Conrad (adconrad) on 2016-07-20
Changed in livecd-rootfs (Ubuntu):
status: New → Invalid
Changed in livecd-rootfs (Ubuntu Xenial):
assignee: nobody → Adam Conrad (adconrad)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package livecd-rootfs - 2.408.2

---------------
livecd-rootfs (2.408.2) xenial; urgency=medium

  * Switch ubuntu-gnome from using tasks to metapackages (LP: #1602035)

 -- Adam Conrad <email address hidden> Wed, 20 Jul 2016 01:46:41 -0600

Changed in livecd-rootfs (Ubuntu Xenial):
status: New → Fix Released
Changed in livecd-rootfs (Ubuntu):
importance: Undecided → High
Changed in livecd-rootfs (Ubuntu Xenial):
importance: Undecided → High
Changed in gnome-maps:
status: Confirmed → Fix Released

Upstream seem to have released a fix for this issue, when will it be backported in?

virgosun (hdefendme) wrote :

Will it be available for gnome-shell --version
GNOME Shell 3.18.5
?

Changed in gnome-maps (Debian):
status: Confirmed → Fix Released
description: updated
Changed in gnome-maps (Ubuntu Xenial):
status: Triaged → Fix Committed
Changed in gnome-maps (Ubuntu Wily):
status: Triaged → Won't Fix
Changed in gnome-maps (Ubuntu):
status: Triaged → Fix Committed
Jeremy Bicha (jbicha) on 2016-08-01
no longer affects: libchamplain (Ubuntu)
no longer affects: libchamplain (Ubuntu Xenial)
Amr Ibrahim (amribrahim1987) wrote :

3.18.3.1 was just released.

3.18.3.1 - Aug 01, 2016
======================

Changes since 3.18.3:

- Do not use libchamplain enums since they were not introspectable
  on older versions of libchamplain.

https://git.gnome.org/browse/gnome-maps/log/?h=gnome-3-18

Martin Pitt (pitti) wrote :

Hello Jeremy, or anyone else affected,

Accepted gnome-maps into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-maps/3.18.3-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Robert Ancell (robert-ancell) wrote :

Amr - the version of libchamplain in Xenial (0.12.13) has the introspectable enums so this the fix in gnome-maps is not required.

Amr Ibrahim (amribrahim1987) wrote :

Thanks Robert for clarifying.

Jeremy Bicha (jbicha) wrote :

I tried gnome-maps from xenial-proposed on Ubuntu GNOME 16.04.1 in VirtualBox. It does show maps...but there's a grey area on the right side of the maps view that persists even when I try resizing the screen. So I reset my VirtualBox and installed gnome-maps from -proposed a second time and the gray area was still there. Screenshot attached.

I filed https://bugzilla.gnome.org/769424 about this issue.

tags: added: verification-failed
removed: verification-needed
Jeremy Bicha (jbicha) wrote :

The grey area is GTK bug 1609088. I confirmed the fix for that bug fixes the grey area so I'm marking this fix verified.

tags: added: verification-done
removed: verification-failed
Mike Cornelison (kornelix-i) wrote :

I tested 3.18.3 and it seems to work fine. I did not notice any gray space on the right.
I ask if libchamplain will now have mapbox as a tile source.

Jeremy Bicha (jbicha) wrote :

Mike, I split the libchamplain part of this bug off to bug 1608308. It needs to be coordinated upstream since gnome-maps has an agreement with Mapbox but I don't think it's been asked yet if that agreement will extend to other core GNOME apps, nor has it been decided whether Mapbox support will be included in libchamplain if it will be used by multiple GNOME apps. Third-party apps will need to make their own agreement with Mapbox or another provider.

Download full text (3.2 KiB)

 Thanks. I understand.

I was hoping for a way to specify a license key for libchamplain to use.

Otherwise I have to write code to replace the functionality of
libchamplain.

regards
Mike

On 04.08.2016 19:36, Jeremy Bicha wrote:

> Mike, I split the libchamplain part of this bug off to bug 1608308. It
> needs to be coordinated upstream since gnome-maps has an agreement with
> Mapbox but I don't think it's been asked yet if that agreement will
> extend to other core GNOME apps, nor has it been decided whether Mapbox
> support will be included in libchamplain if it will be used by multiple
> GNOME apps. Third-party apps will need to make their own agreement with
> Mapbox or another provider.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1602035 [1]
>
> Title:
> Maps app no longer works because MapQuest disabled access
>
> Status in Gnome Maps:
> Fix Released
> Status in Ubuntu GNOME:
> Triaged
> Status in gnome-maps package in Ubuntu:
> Fix Committed
> Status in livecd-rootfs package in Ubuntu:
> Invalid
> Status in ubuntu-gnome-meta package in Ubuntu:
> Fix Released
> Status in gnome-maps source package in Trusty:
> Triaged
> Status in gnome-maps source package in Wily:
> Won't Fix
> Status in gnome-maps source package in Xenial:
> Fix Committed
> Status in livecd-rootfs source package in Xenial:
> Fix Released
> Status in ubuntu-gnome-meta source package in Xenial:
> Fix Released
> Status in gnome-maps package in Debian:
> Fix Released
> Status in gnome-maps package in Fedora:
> Unknown
>
> Bug description:
> As of today, MapQuest has disabled their free map tile feed. This
> means the Maps app no longer displays anything except a warning
> pointing to
>
> http://devblog.mapquest.com/2016/06/15/modernization-of-mapquest- [2]
> results-in-changes-to-open-tile-access/
>
> Screenshot attached.
>
> [Impact]
> GNOME Maps is included by default in Ubuntu GNOME 15.10 and 16.04. The app currently is useless.
>
> Triaged as "High" because it "prevents the application or any
> dependencies from functioning correctly at all".
> https://wiki.ubuntu.com/Bugs/Importance [3]
>
> This also breaks libchamplain (a library for embedding maps into your
> app). Once a fix is released, apps using libchamplain will likely need
> to be patched to use a different map provider.
>
> [Test Case]
> Install gnome-maps. Open the Maps app. Do you see maps?
>
> Note that maps are cached so you may not notice the feed has been
> disabled unless you try viewing a specific area at a close enough zoom
> that you have not viewed recently.
>
> [Regression Potential]
> Upstream changes to switch to Mapbox has potential to break unrelated features.
>
> https://mail.gnome.org/archives/desktop-devel- [4]
> list/2016-July/msg00003.html
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-maps/+bug/1602035/+subscriptions [5]

Links:
------
[1] https://bugs.launchpad.net/bugs/1602035
[2] http://devblog.mapquest.com/2016/06/15/modernization-of-mapquest-
[3] https://wiki.ubuntu.com/Bugs/Importance
[4] https://mail.gnome.org/archives/desktop-devel-
[5] https:/...

Read more...

Jeremy Bicha (jbicha) wrote :

Mike, could you file a bug with GNOME directly about that issue against the libchamplain package? See https://wiki.ubuntu.com/Bugs/Upstream/GNOME

Mike Cornelison (kornelix-i) wrote :
Download full text (3.1 KiB)

 Broad discussion of gnome maps and libchamplain:
 https://bugzilla.gnome.org/show_bug.cgi?id=769352 [7]

I could not figure out whether my request is already one of the options
being considered or even planned.

I filed a bug anyway: https://bugzilla.gnome.org/show_bug.cgi?id=769559
[8]

On 05.08.2016 14:38, Jeremy Bicha wrote:

> Mike, could you file a bug with GNOME directly about that issue against
> the libchamplain package? See
> https://wiki.ubuntu.com/Bugs/Upstream/GNOME [1]
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1602035 [2]
>
> Title:
> Maps app no longer works because MapQuest disabled access
>
> Status in Gnome Maps:
> Fix Released
> Status in Ubuntu GNOME:
> Triaged
> Status in gnome-maps package in Ubuntu:
> Fix Committed
> Status in livecd-rootfs package in Ubuntu:
> Invalid
> Status in ubuntu-gnome-meta package in Ubuntu:
> Fix Released
> Status in gnome-maps source package in Trusty:
> Triaged
> Status in gnome-maps source package in Wily:
> Won't Fix
> Status in gnome-maps source package in Xenial:
> Fix Committed
> Status in livecd-rootfs source package in Xenial:
> Fix Released
> Status in ubuntu-gnome-meta source package in Xenial:
> Fix Released
> Status in gnome-maps package in Debian:
> Fix Released
> Status in gnome-maps package in Fedora:
> Unknown
>
> Bug description:
> As of today, MapQuest has disabled their free map tile feed. This
> means the Maps app no longer displays anything except a warning
> pointing to
>
> http://devblog.mapquest.com/2016/06/15/modernization-of-mapquest- [3]
> results-in-changes-to-open-tile-access/
>
> Screenshot attached.
>
> [Impact]
> GNOME Maps is included by default in Ubuntu GNOME 15.10 and 16.04. The app currently is useless.
>
> Triaged as "High" because it "prevents the application or any
> dependencies from functioning correctly at all".
> https://wiki.ubuntu.com/Bugs/Importance [4]
>
> This also breaks libchamplain (a library for embedding maps into your
> app). Once a fix is released, apps using libchamplain will likely need
> to be patched to use a different map provider.
>
> [Test Case]
> Install gnome-maps. Open the Maps app. Do you see maps?
>
> Note that maps are cached so you may not notice the feed has been
> disabled unless you try viewing a specific area at a close enough zoom
> that you have not viewed recently.
>
> [Regression Potential]
> Upstream changes to switch to Mapbox has potential to break unrelated features.
>
> https://mail.gnome.org/archives/desktop-devel- [5]
> list/2016-July/msg00003.html
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/gnome-maps/+bug/1602035/+subscriptions [6]

Links:
------
[1] https://wiki.ubuntu.com/Bugs/Upstream/GNOME
[2] https://bugs.launchpad.net/bugs/1602035
[3] http://devblog.mapquest.com/2016/06/15/modernization-of-mapquest-
[4] https://wiki.ubuntu.com/Bugs/Importance
[5] https://mail.gnome.org/archives/desktop-devel-
[6] https://bugs.launchpad.net/gnome-maps/+bug/1602035/+subscriptions
[7] https://bugzilla.gnome.org/show_bug.cgi?id=769352
[8] https://bugzilla.gnome.org/show_bug.cgi?id=76955...

Read more...

affects: gnome-maps (Fedora) → ubuntu-translations
Changed in ubuntu-translations:
importance: Unknown → Undecided
status: Unknown → New
no longer affects: ubuntu-translations
Jeremy Bicha (jbicha) on 2016-08-08
Changed in gnome-maps (Ubuntu Trusty):
assignee: nobody → Jeremy Bicha (jbicha)
status: Triaged → In Progress
Jeremy Bicha (jbicha) on 2016-08-08
Changed in gnome-maps (Ubuntu Trusty):
assignee: Jeremy Bicha (jbicha) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-maps - 3.18.3-0ubuntu1

---------------
gnome-maps (3.18.3-0ubuntu1) xenial; urgency=medium

  * New upstream release:
    - Use Mapbox tiles (LP: #1602035)

 -- Robert Ancell <email address hidden> Mon, 01 Aug 2016 09:41:36 +1200

Changed in gnome-maps (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for gnome-maps has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Hello Jeremy, or anyone else affected,

Accepted gnome-maps into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-maps/3.10.3.1-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gnome-maps (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Jeremy Bicha (jbicha) on 2016-08-11
tags: added: verification-done
removed: verification-needed
Jeremy Bicha (jbicha) wrote :

From Ubuntu GNOME 14.04.5, I installed gnome-maps from trusty-proposed. gnome-maps displays its maps (both street and satellite) ok now. (Note that gnome-maps in trusty is affected by bug 1274433 which requires a reboot or something after the initial install of gnome-maps. I don't think upgrades are affected.)

Martin Pitt (pitti) on 2016-08-22
Changed in gnome-maps (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-maps - 3.10.3.1-0ubuntu1

---------------
gnome-maps (3.10.3.1-0ubuntu1) trusty; urgency=medium

  * New upstream release
    - Use Mapbox tiles (LP: #1602035)
  * debian/patches/git_remove_e4x.patch: Dropped, applied in new release

 -- Jeremy Bicha <email address hidden> Mon, 08 Aug 2016 12:24:41 -0400

Changed in gnome-maps (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in livecd-rootfs (Ubuntu):
status: Invalid → Fix Released
Changed in ubuntu-gnome:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.