gnome-lirc-properties 0.3.1-0ubuntu1 is broken

Bug #350825 reported by lemonade on 2009-03-29
26
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gnome-lirc-properties (Ubuntu)
Undecided
Unassigned
Nominated for Jaunty by netije

Bug Description

Binary package hint: gnome-lirc-properties

After upgrade to Jaunty, gnome-lirc-properties seems to have some issues getting authentication from DBus:

"ERROR:dbus.proxies:Introspect error on :1.401:/: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.AccessDenied: Rejected send message, 1 matched rules; type="method_call", sender=":1.397" (uid=1000 pid=17245 comm="/usr/bin/python /usr/bin/gnome-lirc-properties ") interface="org.freedesktop.DBus.Introspectable" member="Introspect" error name="(unset)" requested_reply=0 destination=":1.401" (uid=0 pid=17263 comm="/usr/bin/python -m gnome_lirc_properties.backend "))"

One way to replicate this issue:

1. Click unlock and authenticate
2. Use different remote control
3. Click custom configuration
4. Click Ok

Jose Herran (jherran) wrote :

I can confirm the issue. I receive the same error trying to configure my apple remote.

Curtis Hovey (sinzui) wrote :

This bug relates to bug #318769

This section in /etc/dbus-1/system.d/org.gnome.LircProperties.Mechanism.conf

  <policy user="root">
    <allow own="org.gnome.LircProperties.Mechanism"/>
  </policy>

must be written as

  <policy user="root">
    <allow own="org.gnome.LircProperties.Mechanism"/>
    <allow send_destination="org.gnome.LircProperties.Mechanism"
           send_interface="org.gnome.LircProperties.Mechanism"/>
  </policy>

To permit the conf files to be written.

I can replicate this in Jaunty 64-bit. Is there an update/fix in the repositories? Or should we manually fix-it?
Thanks, Nikos

I am also experiencing this. I changed that file and it still doesn't work.

Lemmiwinks (lemmiwinks) wrote :

I got the same error. The manual fix also does not work for me.
I would really appreciate a fix for that :-)

I tried (also) the manual fix but no luck :-(
Nikos

duke (duke-junks) wrote :

I have exact the same problem with Jaunty 64 bit. I tried to uninstall version 0.3.1 and reinstalled the old version 0.2.7, but still had the same error. It seems that the DBUS, or python code or something else is the problem, not gnome-lirc-properties itself.

In Remote Control Properties -> IR Remote Control, Custom Configuration -> Basic Configuration -> "Detect" I get the error:

Remote Configuration Failed

Rejected send message, 1 matched rules; type="method_call", sender=":1.80" (uid=1000 pid=14287 comm="/usr/bin/python /usr/bin/gnome-lirc-properties ") interface="org.gnome.LircProperties.Mechanism" member="DetectParameters" error name="(unset)" requested_reply=0 destination=":1.83" (uid=0 pid=14810 comm="/usr/bin/python -m gnome_lirc_properties.backend "))

Don't know what it means or if it helps the issue. When I try to replicate the issue described in the bug report, I get the error:

Cannot Save Custom Configuration

Rejected send message, 1 matched rules; type="method_call", sender=":1.80" (uid=1000 pid=14287 comm="/usr/bin/python /usr/bin/gnome-lirc-properties ") interface="org.gnome.LircProperties.Mechanism" member="WriteRemoteConfiguration" error name="(unset)" requested_reply=0 destination=":1.85" (uid=0 pid=15127 comm="/usr/bin/python -m gnome_lirc_properties.backend "))

Don't know if this is related. I run jaunty 64Bit.

Same (as MeisterLampe) here (Jaunty 64-bit).
Nikos

mello73 (mello73) wrote :

to make it work modify /etc/dbus-1/system.d/org.gnome.LircProperties.Mechanism.conf this way:

  <policy context="default">
    <allow send_destination="org.gnome.LircProperties.ExternalToolDriver"/>
  </policy>

must be written as

  <policy context="default">
    <allow send_destination="org.gnome.LircProperties.ExternalToolDriver"/>
    <allow send_destination="org.gnome.LircProperties.Mechanism"/>
  </policy>

mello73 (mello73) wrote :

forgot to tell you....

obviously you must reload dbus:

sudo /etc/init.d/dbus reload

Bhavani Shankar (bhavi) wrote :

mello73 thanks for the tip

will prepare a package

Changed in gnome-lirc-properties (Ubuntu):
status: New → In Progress
assignee: nobody → Bhavani Shankar (bhavi)
Bhavani Shankar (bhavi) wrote :

hello all

I ve made a 32bit package in my PPA as a trivial fix

https://edge.launchpad.net/~bhavi/+archive/experimental/+build/1134094/+files/gnome-lirc-properties_0.3.1-0ubuntu2_all.deb

please test out and report back

Comments welcome!

Regards

Is it possible to have a 64-bit package as well?
Nikos

Bhavani Shankar (bhavi) wrote :

Nikos,

well the package is published only for 32 bit since its release in the repos

let me check the deps and I ll report back

Bhavani Shankar (bhavi) wrote :

its not possible as a 64bit package is not available for gnome-doc-utils which is a dep for this package

Regards

:-(

...

I'll give it a try anyway... or should I not?

I would expect another error than the following:
" Error: Dependency is not satisfiable: python-support (>= 0.90.0) ".

Isn't this supposed to be covered by the python-support package found in the repositories?

Bhavani Shankar (bhavi) wrote :

again the package is available only for 32 bit mate

https://launchpad.net/ubuntu/+source/python-support/1.0.3ubuntu1

So I doubt it works on 64 bit

Regards

From your reply (which I misinterpreted) I thought that it is not possible to have a 64-bit package. I am no expert but there are various 32-bit apps that run under 64-bit OSes. This is why I gave it a try.

Excuse my ignorance and thank you for your time :-)
Nikos

Bhavani Shankar (bhavi) wrote :

nah use dpkg --force-architecture and you can have a shot

or

refer these links

http://brainstorm.ubuntu.com/idea/2993/

http://brainstorm.ubuntu.com/idea/6366/

regards

It still would take to install python-support (>= 0.90.0) first. In the repositories only version 0.87 is available ( I think ). Maybe I'll give it a try some time within the next days.

Bhavani Shankar (bhavi) wrote :

ok Nikos I ll try to rebuild it for jaunty in a couple of days time

Regards

Thanks for your efforts Bhavani :-)
Kindest regards

l3iggs (l3iggs) wrote :

mello73's fix worked for me, thanks!

Bhavani Shankar (bhavi) wrote :

Okay

generating a diff and getting sponsors in

Thanks

Bhavani Shankar (bhavi) wrote :
Changed in gnome-lirc-properties (Ubuntu):
status: In Progress → Confirmed
assignee: Bhavani Shankar (bhavi) → nobody
Daniel Holbach (dholbach) wrote :

Bhavani: a few things:
 - Never use or suggest the use of "dpkg --force-architecture".
 - the package is "Architecture: all" which means it is the same on all architectures (python code), I just built and installed it on amd64.
 - Please make use of https://wiki.ubuntu.com/UbuntuDevelopment/PatchTaggingGuidelines

Bhavani Shankar (bhavi) wrote :

Okay daniel sorry for that

Reassigning

Regards

Changed in gnome-lirc-properties (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Bhavani Shankar (bhavi)
Bhavani Shankar (bhavi) wrote :

Done daniel,

Here is the modified diff

Regards

Changed in gnome-lirc-properties (Ubuntu):
status: In Progress → Confirmed
assignee: Bhavani Shankar (bhavi) → nobody
Johannes Schmid (jhs.schmid) wrote :

I think this was fixed upstream here: http://git.gnome.org/cgit/gnome-lirc-properties/commit/?id=715c91972695c28f3c11e1961e64e8cad60f9ac8

I have not verified though it it works for Ubuntu as Bastian is usually testing his stuff on Fedora.

Bhavani Shankar (bhavi) wrote :

yeah I updated the package to 0.3.1 long time ago and still ubuntu seemed to have issues with dbus

Regards

Murray Cumming (murrayc) wrote :

Bhavani, the change that Johannes mentioned was after 0.3.1.

Bhavani Shankar (bhavi) wrote :

Ah sorry murray didnt see that ... but the change was included in ubuntu long time back (even before 0.3.1 I think)

gnome-lirc-properties (0.2.7-0ubuntu2) jaunty; urgency=low

  * debian/patches/ubuntu_dbus_policy.patch:
    - Patch from GNOME: #563853 to allow method calls via D-Bus. LP: #318771.

 -- Scott James Remnant < <email address hidden>> Mon, 19 Jan 2009 15:43:28 +0000

and I merged the patch while updating the package to 0.3.1 in ubuntu

So the bug is still relevant I think

Regards

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-lirc-properties - 0.3.1-0ubuntu2

---------------
gnome-lirc-properties (0.3.1-0ubuntu2) karmic; urgency=low

  * Update ubuntu_dbus_policy.patch to fix authentication issues with dbus
    Thanks to mello73 for the tip! LP: #350825
  * Standards-Version is 3.8.3 No other changes.

 -- Bhavani Shankar <email address hidden> Sat, 29 Aug 2009 20:49:10 +0530

Changed in gnome-lirc-properties (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers