Please update gnome-lirc-properties to 0.2.6

Bug #218691 reported by Murray Cumming on 2008-04-17
10
Affects Status Importance Assigned to Milestone
gnome-lirc-properties (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: gnome-lirc-properties

gnome-lirc-properties 0.2.6 fixes some problems that sometimes prevented it from writing configuration files after auto-detection. Without this, the auto-detection can appear to have worked, but the keys are not recognized in the test area.

This is at least a problem with the popular StreamZap remote control, because recent versions of lirc in Ubuntu fail to write a correct /etc/lirc/lird.conf configuration file when the user tries to configure it during lirc install. gnome-lirc-properties can now adapt to that and similar problems in future.

Here is the full list of changes from the NEWS file:

0.2.6:

* Check the lirc configuration files at startup and offer to fix them if
  necessary.
  (Mathias Hasselmann)
* Auto-detection: Write the configuration files even if the auto-detection
  result is the same as what was currently selected, in case the
  configuration files are incorrect.
  (Mathias Hasselmann, Murray Cumming)
* Handle some other small errors while parsing/writing configuration files.
  (Mathias Hasselmann)
* Build:
  - Add -disable-confdir-check to prevent checking for lircd.conf.
  - Cleaned up the .desktop file.
  (Bastien Nocera)
* Documentation:
  - Updated the screenshots.

Murray Cumming (murrayc) wrote :

A recent lirc package had another change that broke gnome-lirc-properties' support for the popular Snapstream Meda Firefly receiver. I strongly suggest that you upgrade to fix these problems, caused by the lirc package. It seems risk free.

Here is the full list of changes from the NEWS file:

0.2.7:

* Try to restart the key listener when it fails. This seems to happen sometimes,
  and the restart is usually successful.
  (Mathias Hasselmann) Bug #529909
* Ask for PolicyKit authorization before rewriting a broken configurations at
  startup.
* Support the Snapstream Firefly even when it is called "Snapstream Firefly"
  instead of "Snapstream_Firefly_R1000" in the configuration files, because
  this seems to have changed in debian/ubuntu's lirc package.
* Fix a crash at startup when the configured remote control's name is no longer
  in the lirc configuration files in the lirc package.
  (Murray Cumming) Bug #529854.
* Do not lose vendor, model and contributor names when re-opening custom
  configuration.
  (Murray Cumming) Bug #530504.
* Improve error handling with upload and update.
  (Murray Cumming) Bug #529853 and Bug #529903
* Use bug-buddy.
  (Bastien Nocera) Bug #530360
* Improve keyboard mnemonics
  (Murray Cumming) Bug #530349 (Wouter Bolsterlee).
* Improved strings for translators.
  (Murray CumminG) Bug #530348 (Wouter Bolsterlee).

Cesare Tirabassi (norsetto) wrote :

Since you and Mathias are both upstream, and Mathias is also the maintainer of the Ubuntu package, wouldn't be better to attach a diff.gz for sponsoring?
Also, I just made public the following crash reports, it would be nice if you guys can check them out:

bug 226745
bug 226114
bug 224954

Your opinion on bug 221177 would also be valuable.

Thanks.

Changed in gnome-lirc-properties:
importance: Undecided → Wishlist
status: New → Incomplete
Murray Cumming (murrayc) wrote :

> Since you and Mathias are both upstream, and Mathias is also the maintainer of the Ubuntu package, wouldn't be better to attach a diff.gz for sponsoring?

He is? The maintainer is listed as Ubuntu MOTU Developers <email address hidden>. I don't think Mathias is a MOTU.

Murray Cumming (murrayc) wrote :

> bug 226745
> bug 226114
> bug 224954
>
> Your opinion on bug 221177

The first two are duplicates, fixed by this upstream version. I'm not sure what to do for the other two. We'll figure something out, but probably not in the next few weeks. Please don't wait for these fixes before updating to the latest upstream.

Mathias Hasselmann (hasselmm) wrote :

Commented on 224954 and 221177.
Murray: Guess Cesare refers to the REVU system (https://wiki.ubuntu.com/REVU, http://revu.tauware.de/) and finding sponsors on #ubuntu-revu at Freenode.

Cesare Tirabassi (norsetto) wrote :

@Mathias,

REVU is not used anymore once your initial package has been accepted. For updates, you just attach a diff.gz to an update bug report (like this one) and subscribe u-u-s for sponsoring (we use the watch file to retrieve your upstream tarball).
You can find some additional details here:

https://wiki.ubuntu.com/SponsorshipProcess

Sebastien Bacher (seb128) wrote :

having the new version in intrepid and then maybe consider an hardy update would be nice, is there anybody still working on those?

Changed in gnome-lirc-properties:
status: Incomplete → Confirmed
Changed in gnome-lirc-properties:
assignee: nobody → christophe.sauthier
Murray Cumming (murrayc) wrote :

The new upstream release depends on an unreleased (0.8.4) release of lirc, so I guess this shouldn't be packaged yet. I have requested a new upstream lirc release.

After talking with Murray, I'll do the 0.2.7 update for intrepid (and try an SRU for it)
And we'll wait for the 0.2.8 that the new lirc is released...

Changed in gnome-lirc-properties:
status: Confirmed → In Progress

gnome-lirc-properties (0.2.7-0ubuntu1) intrepid; urgency=low

  * New upstream version (LP: #218691)
    - Fix crash with ValueError in __init__() (LP: #226745)
    - Fix crash with error in io() (LP: #224954)
    - Better method for filtering type of IR device (LP: #221177)
  * debian/rules removal of rmdir of the locale dir, since it is not empty
    anymore.

 -- Christophe Sauthier <email address hidden> Fri, 25 Jul 2008 15:15:15 +0200

Changed in gnome-lirc-properties:
assignee: christophe.sauthier → nobody
status: In Progress → Confirmed
Cesare Tirabassi (norsetto) wrote :

1) There is a missing copyright in debian/copyright (Copyright (C) 2008 Openismus GmbH (www.openismus.com))
2) Pointer in debian/copyright points to GPL-3, not GPL-2
3) Missing copyright in po/nl.po (Wouter Bolsterlee <email address hidden>, 2008 ?)
4) help/gnome-lirc-properties.pot is not cleaned up by the clean target
5) Current Standards-Version is 3.8.0
6) If linux-input-layer-lircd.conf and receivers.conf are configuration files they should be installed in /etc

Mathias Hasselmann (hasselmm) wrote :

> 6) If linux-input-layer-lircd.conf and receivers.conf are configuration files they should be installed in /etc
- linux-input-layer-lircd.conf definitly is not a configuration file. It is used as templated for writing Linux Input Layer configurations. Adminstrors do not want to modify this file.
- receivers.conf is some kind of database. Adminstrors do not want to modify this file: If this file needs changes, this changes should be reported upstream.

Adminstrors do not want to modify this file.

Changed in gnome-lirc-properties:
assignee: nobody → christophe.sauthier

gnome-lirc-properties (0.2.7-0ubuntu1) intrepid; urgency=low

  * New upstream version (LP: #218691)
    - Fix crash with ValueError in __init__() (LP: #226745)
    - Fix crash with error in io() (LP: #224954)
    - Better method for filtering type of IR device (LP: #221177)
  * debian/rules removal of rmdir of the locale dir, since it is not empty
    anymore.
  * Bump to Standard-Version 3.8.0
  * debian/copyright:
    - corrected the location of the GPL-2
    - Addition of the copyright of Openismus GmbH

 -- Christophe Sauthier <email address hidden> Mon, 28 Jul 2008 14:42:20 +0200

gnome-lirc-properties (0.2.7-0ubuntu1) intrepid; urgency=low

  * New upstream version (LP: #218691)
    - Fix crash with ValueError in __init__() (LP: #226745)
    - Fix crash with error in io() (LP: #224954)
    - Better method for filtering type of IR device (LP: #221177)
  * debian/rules
    - removal of rmdir of the locale dir, since it is not empty anymore.
    - clean up of help/gnome-lirc-properties.pot
  * Bump to Standard-Version 3.8.0
  * debian/copyright:
    - corrected the location of the GPL-2
    - Addition of the copyright of Openismus GmbH

 -- Christophe Sauthier <email address hidden> Mon, 11 Aug 2008 14:42:36 +0200

Changed in gnome-lirc-properties:
assignee: christophe.sauthier → nobody
Sebastien Bacher (seb128) wrote :

the update looks good I'm sponsoring the upload

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-lirc-properties - 0.2.7-0ubuntu1

---------------
gnome-lirc-properties (0.2.7-0ubuntu1) intrepid; urgency=low

  * New upstream version (LP: #218691)
    - Fix crash with ValueError in __init__() (LP: #226745)
    - Fix crash with error in io() (LP: #224954)
    - Better method for filtering type of IR device (LP: #221177)
  * debian/rules
    - removal of rmdir of the locale dir, since it is not empty anymore.
    - clean up of help/gnome-lirc-properties.pot
  * Bump to Standard-Version 3.8.0
  * debian/copyright:
    - corrected the location of the GPL-2
    - Addition of the copyright of Openismus GmbH

 -- Christophe Sauthier <email address hidden> Mon, 11 Aug 2008 14:42:36 +0200

Changed in gnome-lirc-properties:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers