[12.04] WARNING: gnome-keyring:: no socket to connect to

Bug #914305 reported by Michael Basse
82
This bug affects 22 people
Affects Status Importance Assigned to Milestone
GNOME Keyring
Invalid
Critical
gnome-keyring (Debian)
Fix Released
Unknown
gnome-keyring (Ubuntu)
High
Unassigned

Bug Description

the latest dist-upgrade on 12.04 (10.01.12) gives a WARNING about gnome-keyring

WARNING: gnome-keyring:: no socket to connect to

until now i dont see any missing functionalitiy because of this Warning

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: gnome-keyring 3.2.2-1ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-7.13-generic 3.2.0-rc7
Uname: Linux 3.2.0-7-generic i686
ApportVersion: 1.90-0ubuntu1
Architecture: i386
Date: Tue Jan 10 15:46:23 2012
EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110426)
ProcEnviron:
 PATH=(custom, no user)
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-keyring
UpgradeStatus: Upgraded to precise on 2011-12-04 (37 days ago)

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :
Revision history for this message
GreyGeek (greygeek77) wrote :

I am running Kubuntu 12.04 fully updates as of 10:50PM tonight, 01/11/12.

I have the same warning, but it is also followed by
(BibleTime 2.8.1) WARNING: Not a BibleTime Bookmark XML file
Segmentation fault (core dumped)

Total removal and reinstall doesn't help.

Revision history for this message
GreyGeek (greygeek77) wrote :

I forgot to add these lines from my authentication log:

01/11/12 10:09:50 PM jerry-Aspire-7739 gnome-keyring-daemon[2165] couldn't set environment variable in session: The name org.gnome.SessionManager was not provided by any .service files
01/11/12 10:09:50 PM jerry-Aspire-7739 gnome-keyring-daemon[2165] unsupported key algorithm in certificate: 1.2.840.10045.2.1

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-keyring (Ubuntu):
status: New → Confirmed
Revision history for this message
Diego Schulz (dschulzg) wrote :

I'm trying to use aiccu (SixXS) and the daemon won't start because of the same bug. This means no IPv6 connectivity for me.

I'm also running Ubuntu 12.04 fully updated ten minutes ago.

Package: gnome-keyring
Priority: optional
Section: gnome
Installed-Size: 4184
Maintainer: Ubuntu Developers <email address hidden>
Original-Maintainer: Josselin Mouette <email address hidden>
Architecture: amd64
Version: 3.2.2-1ubuntu2

Revision history for this message
Diego Schulz (dschulzg) wrote :

Edited this file: /etc/pkcs11/modules/gnome-keyring-module
and commented this line:

module: gnome-keyring-pkcs11.so

and the problem is gone for now.

Revision history for this message
Diego Schulz (dschulzg) wrote :

Furthermore, I noticed the p11-kit package was NOT installed in my system, which I suspect is required by gnome-keyring.
I installed it and reverted the /etc/pkcs11/modules/gnome-keyring-module to its original state but the bug appeared again.

Revision history for this message
Brian Knoll (brianknoll) wrote :

I think somebody who has access to do so should raise the priority of this bug to a higher level. This bug has been known to break certain network services, even services which have no apparent legitimate need to be using gnome-keyring at all. It would be best if this bug were fixed prior to the LTS release, as it is quite annoying, and does break some functionality.

Revision history for this message
Brian Knoll (brianknoll) wrote :

I also want to mention that this appears to be related to upstream Debian bug #649408, and breaks both network services and applications.

Revision history for this message
Brian Knoll (brianknoll) wrote :

I just wanted to add one example of a critical network service which is broken by this bug, to demonstrate the broken functionality. CUPS appears to be broken by this bug. I cannot print, and when I look in my CUPS error log I see a bunch of messages about the daemon having problems connecting to gnome-keyring, which it should not be doing in the first place.

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

I can confirm what Brian is saying.

Evolution is also broken because it cant use gnome-keyring and asking always for a password. Also cups is not working here

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

Brian, can you please test the workaround from comment #6?

Revision history for this message
Sebastien Bacher (seb128) wrote :

is that still an issue in precise (the Debian bug indicates it should be fixed in the current version)

what desktop environment do people have the issue use?

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

Hi Sebastian,
its still affecting me on Lubuntu 12.04

Revision history for this message
Brian Knoll (brianknoll) wrote :

I just performed a full update of all packages on my 12.04 installation, rebooted, and tried again:

-----
# lpq
WARNING: gnome-keyring:: no socket to connect to
mfc is ready
no entries
-----

So the warning is still there. This installation was a regular install with the Gnome 2 desktop environment from Lucid, then I upgraded it to 12.04. I think now it has Gnome packages installed but it also has the Unity environment. It is just a VM I set up for testing the next release, so I don't ever log into the desktop, I just SSH into it, but the desktop is there to pick up compatibility issues that might arise, so I can report bugs.

Revision history for this message
Sebastien Bacher (seb128) wrote :

The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

Upstreambug created https://bugzilla.gnome.org/show_bug.cgi?id=669171 and added into bugwatch

Revision history for this message
Michael Basse (michael-alpha-unix) wrote :

already fixed upstream

https://bugzilla.gnome.org/show_bug.cgi?id=665961

commit 5ca7387952f99bf318d337df2d853f5bc3c0ddd2
Author: Stef Walter <email address hidden>
Date: Mon Dec 19 13:08:51 2011 +0100

    rpc-layer: Correctly handle case where gnome-keyring-daemon not running

     * In the gnome-keyring-pkcs11.so module return stand in info
       when the gnome-keyring-daemon info is not running.
     * In addition no slots will be listed

tags: added: patch-accepted-upstream
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thanks, bringing issues to people who write the code works usually better than discussing them for ages on distribution trackers

Changed in gnome-keyring (Ubuntu):
importance: Undecided → High
Changed in gnome-keyring:
importance: Unknown → Critical
status: Unknown → Invalid
Changed in gnome-keyring (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-keyring - 3.2.2-2ubuntu1

---------------
gnome-keyring (3.2.2-2ubuntu1) precise; urgency=low

  * Synchronizing on Debian including fix for '"gnome-keyring:: no socket to
    connect to" errors in non GNOME sessions' (lp: #914305)
 -- Sebastien Bacher <email address hidden> Wed, 01 Feb 2012 15:38:26 +0100

Changed in gnome-keyring (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Brian Knoll (brianknoll) wrote :

I want to mention that the workaround listed in comment #6, involving commenting out the module, does indeed work over here.

Changed in gnome-keyring (Debian):
status: Unknown → Fix Released
Revision history for this message
Peter Lemieux (seijisensei) wrote :

I discovered this bug today after installing elinks into a Kubuntu 13.04 system. Apparently elinks wants to access the keyring. It does not keep the program from loading or working, but it does throw a warning every time the program is opened from the command prompt.

Revision history for this message
Bill Vance (b2ll) wrote :

Running Kubuntu 12.04 here, and I'd like to add that the gnome keyring bug(s)
also affects Mysql-Workbench, as its absxence means passwords aren't remembered.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.