gnome panels suddenly have a 25 second delay after session load

Bug #593226 reported by DjznBR on 2010-06-13
78
This bug affects 14 people
Affects Status Importance Assigned to Milestone
gnome-keyring (Ubuntu)
Low
Unassigned

Bug Description

After a few updates, gnome panels now have a 25 second delay after the session is loaded entirely. The desktop shows up, the icons in the desktop show up, but the panels are invisible for 25 seconds... They seem invisible because then you kill gnome-panel from terminal, the desktop icon positions move and then they are back again some milimeters where they were, implying that at least the panel space is being loaded. Killer bug! No apparent stuff on .xessions-errors, default applets. Deleted .gconf .gnome2 .gconfd and problem did not go away. Affects all users.

Dave Gilbert (ubuntu-treblig) wrote :

I doubt this is the linux package, but anyway, I've seen similar behaviour if one of the startup applications blocks for a while; the challenge is finding which one.

I'd go to system->preferences->startup applications and look down the list of applications and remove any that are definitely not needed and see if you can find which one is blocking stuff.

Dave

DjznBR (djzn-br) wrote :

I think I made a mistake, this is suited to gnome panel or ubuntu desktop bugs. Will test now if turning off applications of startup session helps.

DjznBR (djzn-br) wrote :

Turned off every single thing in the System -> Preferences -> Startup Applications. Panel delay still up.

DjznBR (djzn-br) wrote :

To put it better, I turned off everything at once.

affects: linux (Ubuntu) → gnome-panel (Ubuntu)
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please try to obtain a backtrace following the instructions at http://wiki.ubuntu.com/DebuggingProgramCrash and upload the backtrace (as an attachment) to the bug report. This will greatly help us in tracking down your problem.

Changed in gnome-panel (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

when did the issue start?

Greg Eden (grege) wrote :

Affecting me as well.

Therre is a thread going in the forums. Seems to have started with an update about two - three days ago.

http://ubuntuforums.org/showthread.php?t=1506585&highlight=gnome+slow+start

I also tried turning off all startup programs = no effect, still delay of 20 seconds

I made a new user, no improvement.

If log out and log in again comes up straight away, issue manifests from cold start.

Does not effect Kubuntu, but does effect Xubuntu as well. When I rejig as Kubuntu everything starts and loads at normal speeds. With Xubuntu I got the same delay before desktop appears.

Python programs seem to be taking a while to start as well, but could just be my imagination.

Robert Roth (evfool) wrote :

Could you please try to remove the Clock applet and restart, to see if gnome-panel starts faster? Thank you.

Greg Eden (grege) wrote :

Killed the clock, then one by one removed everything. The problem remains.

I ran gconftool-2 --recursive-unset /apps/panel to restore default panel. Panel restored, but problem remains.

I have four machines running Ubuntu and it only affects one.

I am using a 2.6.34 kernel on two machines, one has the problem, the other does not. So, that is not it.

This machine is using the Open Source ATI video driver the others are not (Nvidia and Intel).

I have several PPAs active plus a few third party repos, and am now thinking this is the source of my issues. It is not the Chromium daily builds as that is active on all of my machines.

Anyone without third party repos have this issue?

DjznBR (djzn-br) wrote :

I called it a day yesterday... I was unable to trace this bug. I made a clean install, but I can give you some hints of what it could be. As I tweak the system a lot, I must say that had the following applications installed.

- VirtualBox Full Edition
- Radeon VGA driver for HD 3200.
- My GDM was passwordless

- I removed all panel applets, but something intrigued me after I called it a day. The weather applet, which was grabbing forecast from a city nearby. It could be this applet...

Another thing that had been annoying me was frequent boots followed by turn-offs. The moment ubuntu start booting, it turns the computer off. Once in a while. So that was annoying me. I believe it was related to frequent Catalyst "installs" and "de-installs", because everytime I try a new Catalyst, is just to be frustrated as hell, and then there is the whole uninstallation process.

I made a clean install and installed all the full updates, so far, no problems, but as soon as this bug appears, I will be reporting. It must be some alien component doing something to the system.

Sebastien Bacher (seb128) wrote :

would be nice to figure what the users having this issue installed when they started getting the issue. the /var/log/dpkg.log log has the list of changes. do you use lucid-proposed or lucid-updates?

DjznBR (djzn-br) wrote :

I just CAN'T believe my eyes... problem is back.... steady and firm.

DjznBR (djzn-br) wrote :

OK, I just spotted the cause of this bug. When you select "System -> Administration -> Users and Groups" and you modify the password settings and select "Do not ask for a password when session starts" is what is possibly triggering this behaviour, so it is a GDM issue, possibly.

Try to reproduce the bug by doing this configuration. Cleaning the system was good to me anyway, it narrowed down what is triggering.

If you know of any possible log to read, please refer which file it is.

I hope this bug is cornered now.

Dave Gilbert (ubuntu-treblig) wrote :

Is this to do with some hardware attached to that machine? I'm thinking that the difference with not asking for a password is that the login speed is pretty quick; maybe some hardware that it is waiting for hasn't caught up yet but something on the panel is waiting for it?
(Just a guess)

Dave

DjznBR (djzn-br) wrote :

I really don't think so. I had passwordless configuration in Karmic and in Lucid. The difference is that in Lucid you can actually set this through the GUI now. It had worked since the release, until a gnome-overall update in the past week or two.

Greg Eden (grege) wrote :

I do not think it is anything to do with passwords. Mine has always been set to login with username and password.

As it does not effect Kubuntu it would have to be something Gnome GTK GDM

As it also effects Xubuntu, then you would think GTK GDM

As it also happens with applets removed and most auto started apps turned off then it gets tricky

Greg Eden (grege) wrote :

My autostarting list

Check new hardware drivers
Certificate and key storage
Disk Notifications
Policy Kit Authentication Agent
Power manager
Print Que Applet
Pulse Audio
Secret Storage Service
SSH Key Agent
Update Notifier
User Foldeers Update

I will turn them off one by on and see what happens.

Greg Eden (grege) wrote :

None of the autostart programs was the culprit. Certificate and key storage would not turn off, it just restores itself if you turn it off.

I reconfigured to use KDM as login manager and problem unchanged, GDM unlikely candidate.

My dpkg log has a burst of activity over the last week, any of them could be the cause. My thoughts on Python in earlier post were wrong, it is starting normally. There was a Gnome Panel and panel Data update on the 9th of June (or i installed it on the 9th of June).

Greg Eden (grege) wrote :

A user called Wolferl in the forums has tracked down the issue to libpam-gnome-keyring

I can confirm that by activating proposed updates in Synaptic and updating, it triggered a libpam update that solved the problem for me.

DjznBR (djzn-br) wrote :

I had passwordless option since Karmic. I did a full clean install of Lucid, and used the passwordless option since the release day. As I said, when this whole thing started, I checked my logs and the startup applications. Turned off everything, nothing worked. Then I got pissed and did a new full system clean install. After the first reboot, I updated the system with all packages due. It was a 178MB download.

I kept using the system normally, with normal GDM asking password. But the moment I went to the "User and Groups" configuration and turned on the option "Do not ask for a password upon session start", the problem immediately started. Right after the next logoff and back on.

I think you can emulate this with a virtual machine, install a clean ubuntu, update the whole system. Create more 2 users and tell all users to skip password from the preferences of User and Groups. Restart the system and see what happens. By the way, i386 here.

Greg Eden (grege) wrote :

@DjznBR

I have just tried auto login in, passwordless login and normal gdm password login and they are all back to normal.

Activate proposed updates and update libpam (I just did all the updates that appeared) and see what happens.

DjznBR (djzn-br) wrote :

Ok, I followed your advice and enabled the lucid-proposed updates. I have installed all of them as of tonight. It didn't solve the issue. Firstly I installed the libpam packages and related, after that appindicator related packages and kerberos-related... Didn't work and finally I selected all of them, and it did not worked.

Greg Eden (grege) wrote :

back to square one

Greg Eden (grege) wrote :

Just checked mine and it is still fixed.

Only other thing is that I also enabled backports and updated.

So now I have fixed mine without really knowing how.

Anyway, try backports.

DjznBR (djzn-br) wrote :

LOL.. I hope nothing of this screws the system again, I will try backports.

DjznBR (djzn-br) wrote :

I haven't seen anything related to GDM or Gnome in the backports, and it's not supported. I think I am gonna wait for the development of this, meanwhile I will just login with a password... (works instantaneously).

Freddie (freddie-signup) wrote :

Since this problem occurred (I don't know when as it's another user who uses gnome and reported the issue to me) I've ran multiple full updates and the problem persisted.

However, I had allowed her to login with no password. Using the System->Administration->Users and Groups dialogue reported that her account was disabled (presumably as it had no password). As root I used passwd to set her account password to a non-null value and then the Users and Groups dialogue reported nothing special about her account (The dialogue always reported that the password was asked at login). On login she was still not asked for a password (as I'd configured pam to require no password, see below) but the problem persisted.

I'd allowed her to login with no password since before GNOME had an option allowing this - I'd put a line in /etc/pam.d/gdm which read

auth sufficient pam_listfile.so item=user sense=allow file=/etc/gdm/nopassusers.txt onerr=fail

(and added her username to /etc/gdm/nopassusers.txt). Commenting out this line meant that gdm asked her for her password and the problem was gone.

Further, I tried un-commenting this line and removing her from nopassusers.txt and the problem stayed fixed. I then created a new user. With the line uncommented: if the new user was in nopassusers.txt problem occurred, if not no problem (even though the user had a properly defined password). the option "Don't ask for password on login" in the Users and Groups dialogue was greyed out for me (as root or not), and searching gave no clues, so I can't test that.

So for me this looks as if it's arising from pam and gdm somewhere.

anantshri (anant-shrivastava) wrote :

bug effected but a quick search at ubuntuforum yielded following thread

http://ubuntuforums.org/showthread.php?t=1506585&page=2

with two possible solutions zeroing in on the defaulter to be gnome keyring application.

Solution 1 :

I have removed the login keyring (Applications/Passwords and Encryption Keys) and that solved the issue.
I had this intuition because the gnome-keyring package update 2.92.92.is.2.30.1-0ubuntu1 had this in the changelog: "Remove accidental storage of user's login password in login keyring." I do not know if this has anything to do with the bug, but the keyring was empty anyway (all my passwords are stored in the default keyring).

Solution 2 :
Good news, I think.

I have it under scrutiny, but after testing it several times I think it is solved. This is what I have discovered and how I solved it (I hope).

The problem occurs with the latest version of GNOME KEYRING: files 'libpam-gnome-keyring' and 'gnome-keyring'.

I downgraded them to the previous version, and then blocked that version: 2.92.92.is.2.30.0-0ubuntu3 (instead of 2.92.92.is.2.30.1-0ubuntu2)

Can anyone check or confirm this solution please?

Note : solutions copied verbatium from forum link provided above.

liamdawe (liamdawe) wrote :

I also have this issue with both 32 and 64bit Ubuntu and happens on every login.

The purple background + mouse cursor loads up and you seem to have to just sit their and wait until the panels and your actual desktop loads up - seems like such an obvious thing to slip through bug testing.

schneiderwenz (schneiderwenz) wrote :

I checked anantshri's solution and it solved the issue for me (thanks anantshri =)
I used the following console commands for package downgrade:

sudo aptitude install libpam-gnome-keyring=2.92.92.is.2.30.0-0ubuntu3
sudo aptitude install gnome-keyring=2.92.92.is.2.30.0-0ubuntu3

My fingerprint sensor is also working (it also did with 2.92.92.is.2.30.1-0ubuntu2 before, but i had to deactivate it, because the "missing panel" issue only occured when I included "auth sufficient pam_fprint.so" in "/etc/pam.d/common-auth").

DjznBR (djzn-br) wrote :

I can confirm that the commands above HAVE FINALLY FIXED the problem to me.

sudo aptitude install libpam-gnome-keyring=2.92.92.is.2.30.0-0ubuntu3
sudo aptitude install gnome-keyring=2.92.92.is.2.30.0-0ubuntu3

Guess I won't be updating these two packages in the next updates :-)

anantshri (anant-shrivastava) wrote :

thanks for the thanks but the actually credit goes to the Poster @ http://ubuntuforums.org/showthread.php?t=1506585&page=2 from whee i placed the solution here.

Noel J. Bergman (noeljb) wrote :

I'm seeing this problem with Maverick today. Installed packages are:

 ii gnome-keyring 2.92.92.is.2.30.1-0ubuntu2
 ii libpam-gnome-keyring 2.92.92.is.2.30.1-0ubuntu2

firesock (firesock-ml) wrote :

As DjznBR said, it's solved with
sudo aptitude install libpam-gnome-keyring=2.92.92.is.2.30.0-0ubuntu3
sudo aptitude install gnome-keyring=2.92.92.is.2.30.0-0ubuntu3

It solves the slow opening issue of the gnome-panel and the malfunctioning of the network-manager-gnome.

Thank you very much for your help. I hope this would be fixed in the future with an update. Please let us know :)

Sebastien Bacher (seb128) wrote :

the bug is similar to bug #595518, could users having the issue gives detail on what user configuration they use? do you have a local user or a nfs or nis one? do you use a password or some special login tweak? do you use standard pam password or other way to log in?

affects: gnome-panel (Ubuntu) → gnome-keyring (Ubuntu)
Freddie (freddie-signup) wrote :

I used the pam tweak described in post 27 (configuring pam to accept no password from certain users). All users of my machine are local, using gdm. I'm on debian sid with libpam-gnome-keyring 2.30.1-2 and gnome-keyring 2.30.1-2.

P.S. firesock, et al: downgrading is not a solution but a temporary work around. The problem needs to be fully understood so that future updates do not to also cause this problem.

DjznBR (djzn-br) wrote :

Users: I have only local users.
Password: Users have a password, but I turn off the asking password option through the dialogue Users & Groups. No special tweaking. It's is a standard pam password.

firesock (firesock-ml) wrote :

I'm using GDM with local user only.
I use fingerprint reader to log in, with fprint as the fingerprint reader software.
In /etc/pam.d/common-auth I have configured the follow sentence to allow access with the fingerprint reader:
auth sufficient pam_fprint.so

If the fingerprint reader fails, it asks me the password.

No other special features.

Freddie: OF COURSE I know it's a temporary solution.

Dvanzo (danielvanzo) wrote :

Vostro 1500 Lucid...

Applied the posted workaround with no luck. The same 25 seconds delay between login and panels...

What can I do?

Regards!!

Sebastien Bacher (seb128) wrote :

the issue could be fixed in bug #583428 in the case of no-password logins...

Gretha (g-r-e-cramer) wrote :

This might indeed be some a password-related issue. Since recently, some time after I log in as a user, an unexpected authorization dialogue box pops up, saying that an application (it eerily does not say which) asks for authorization; and my two (standard) desktop panels are very very slow to appear, or even seem not to want to appear at all.

But the forum solution referred to in post 28 is obviously only a temporary retro-fix, pending final resolution of the issue and the production of a proper fix.

I have implemented an easier temporary solution, which may be useful for some: I have simply created an application launcher on my desktop, using the GUI desktop context menu, which launches <gnome-panel> when I double click on the icon, and off I go...

Dvanzo (danielvanzo) wrote :

Well, reading an old post I can reduce the time from 25/30 seconds to only 6 !

https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/128803
===================================================================================================
Mitch Wiedemann wrote on 2007-10-31: #65

I was seeing very slow Gnome load times as well.

After reading a "misconfigured loopback" comment above, I checked my network interface settings, and sure enough, I had configured a static IP address for my ethernet interface and the slow startup would happen only when I didn't have the ethernet cable plugged in.

I mostly use my wireless interface, so I set the ethernet interface back to "roaming" and the problem was solved for me.

So, I suspect the long load times are due to a network-manager timeout or something like that.
===================================================================================================

I checked my connections settings, and one of they have static IP... Changed it to Authomatic (DHCP) and now all its working ok!

Regards!!

Daniel

franco_bez (franco-bez) wrote :

I had the same issue, the panels took a long time to start.

I didn't have the passwordless login enabled.

But turning "passwordless login" on, (remove the mark from "ask for password" then click OK) and then turning it off again, (set the mark "ask for password" and click OK) fixed the problem.

schuelaw (schuelaw) wrote :

I confirm that the the suggestion in Post #30 is helpful. I'm trying to setup a small computer lab. Lab account logins are authenticated by a kerberos server. Home directories are automounted over nfs from a file server. User information is distributed by an NIS server. However, there is a setup account on each machine that is a local account (i.e. home directory is in /usr/local/home, authentication is done locally not through kerberos, not in NIS). The local account logs in without delay. The lab accounts have the startup delay.

Noel J. Bergman (noeljb) wrote :

> could users having the issue gives detail on what user configuration they use

Local user, pam fprint

schuelaw (schuelaw) wrote :

I followed the advice in post #30 and that seems to have solved the problem. On a side note, since I expect to run 10.04 LTS for a long time, eventually I will probably need to undo what I've done. I've searched around on the net about "pinning" version numbers on certain apt packages, but have not found a clear example about how to "un-pin" the version number. Can someone that knows apt better than I post an example of how to "un-pin" the version number in post #30? Thanks.

Sebastien Bacher (seb128) wrote :

did any of you tried if the gnome-keyring candidate update makes a difference?

schuelaw (schuelaw) wrote :

This goes back to my previous comment about pinning. I can't figure out how to un-pin the downgraded version.

MGdesigner (shoichi-chou) wrote :

The bug also affect me. I also confirm the solution in #30 indeed works! Fast booting comes back. Thanks god.

firesock (firesock-ml) wrote :

I just wanted to add that I have updated the packages to the last version available by now and the problem was fixed...

DjznBR (djzn-br) wrote :

Upon a clean install from Ubuntu 10.04.1, I have not seen this bug come up with same configuration conditions as of before. Could we consider this fixed released?

Launchpad Janitor (janitor) wrote :

[Expired for gnome-keyring (Ubuntu) because there has been no activity for 60 days.]

Changed in gnome-keyring (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers