gnome-keyring mysteriously asks for keyring password on startup

Bug #575877 reported by Ari Fogel on 2010-05-05
92
This bug affects 19 people
Affects Status Importance Assigned to Milestone
gnome-keyring (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: gnome-keyring

I recently (yesterday) upgraded from Karmic to Lucid. Now whenever I start up, gnome-keyring asks me for my keyring password. Note that I use a password to log in, and I also have a keyring password. So I am not using auto-login. What confuses me is that I cannot tell what application is trying to access the keyring. And when I am asked for my password, I am unable to switch to other applications, e.g. terminal, to perform any debugging.
This behavior did not occur before the upgrade.
As far as I know, I should not have to enter my keyring password until something actually has to use the keyring. And it should only unlock that portion of the keyring that it uses. But the dialog I get provides me with no information other than "an application wants to access the keyring".

From apt-cache policy gnome-keyring:
gnome-keyring:
  Installed: 2.92.92.is.2.30.0-0ubuntu3
  Candidate: 2.92.92.is.2.30.0-0ubuntu3
  Version table:
 *** 2.92.92.is.2.30.0-0ubuntu3 0
        500 http://ubuntu.osuosl.org/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

From lsb_release -rd:
Description: Ubuntu 10.04 LTS
Release: 10.04

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: gnome-keyring 2.92.92.is.2.30.0-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Wed May 5 12:10:00 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: gnome-keyring

Ari Fogel (arifogel) wrote :
barney_1 (szczys) wrote :

I also just upgraded from Karmic to Lucid. I am using automatic login and before the upgrade I didn't need to enter my keyring password. Now it does ask me for it but I can't tell what application needs access. I have no problem minimizing the window and using my network connection without unlocking the keyring.

Changed in gnome-keyring (Ubuntu):
importance: Undecided → Low
Mr. X (obvio-capitao) wrote :

This bug shouldn't be marked as low importance. This is an usability issue that impacts the very first impression of ubuntu.

As an example, I installed Ubuntu in a netbook for my parents.

Because they value simplicity, I made the netbook login automatically, opening the web browser and skype immediately.

It worked perfectly until I upgraded to Lucid. It now asks for a password to access the wireless network.

Advanced users may think this is low priority; but for the regular users this is an usability killer.

Please give us a workaround -- or mark this as higher priority.

Remember: this is the very first impression of ubuntu.

vista killer (vistakiller) wrote :

I have the same problem after some update i have done to lucid

lavinog (lavinog) wrote :

There are three bugs here:
- Keyring is not unlocked when user logs in with password.
- Keyring steals focus with always on top dialog (frustrating when you are in the middle of typing something)
- Keyring doesn't provide information about what application is requiring the keyring. This should be considered a security flaw since the dialog is asking the user to blindly provide a password without reason. If mimicked by a web popup, a user can have their password phished.

SteveDude (stevedude-) wrote :

My Gnome keyring asks for the password twice. This started when upgrading from Lucid 10.04 to Maverick 10.10. Upon upgrading from Karmic to Lucid, the keyring would pop-up once upon startup or logoff/login, now I receive 2 pop-up boxes requesting a password upon a startup or logoff/login.

I utilize automatic login since I am the only user. I tried to use manual login, but that did not correct the situation.

"Lavinog" has succinctly stated the issues I face too.

I also tried #13 from this article, and that did not work either: http://hubpages.com/hub/15-First-steps-after-installing-ubuntu

d❤vid (kwill) wrote :

I think there needs to be more clarification about this bug.

1. For some people it occurs when they log in with a password - this is clearly wrong. (Could it be that your account password and keyring password don't match?) This is in the original bug report.

2. For others it occurs when they auto-login. Arguments about security aside, they don't want it. This is my issue, and I think warrants a separate ticket.

3. Keyring steals focus. I think this is a feature, which wouldn't be annoying if 1 & 2 weren't happening. Warrants a separate ticket if you disagree.

4. Keyring only says "an application". There is an existing ticket for this issue at https://bugs.launchpad.net/ubuntu/+source/gnome-keyring/+bug/246185 After lots of searching I got clarification from a gnome-keyring developer at https://bugzilla.gnome.org/show_bug.cgi?id=574315#c4 , including the security implications and scope of the task. See also http://live.gnome.org/GnomeKeyring/SecurityPhilosophy

Geoffrey Pursell (geoffp) wrote :

I have a single keyring, labeled "Passwords: login". I do have auto-login set, and I would get asked two or sometimes three times for my password on login, every time.

As suggested elsewhere, I changed the password on that keyring to nothing. That worked; I was no longer asked at startup. Then I logged out and in as another user, logged out, logged in as my primary user, then set the keyring back to my real password, which is the same as the password on the user account. Strangely, it would not accept nothing as the "old" password, which I had set it to earlier, but did accept my real password as the "old" password. Baffling.

Now, it does not appear to ask me at startup, and does automatically unlock the keyring.

Changed in gnome-keyring (Ubuntu):
status: New → Confirmed
Thomas (t-hartwig) wrote :

Low priority? Why?

This bug is really annoying and cumbersome, it affects a lot of people, please, please have a look at this.

Chris Roberts (chrisjrob) wrote :

I am logging in with a password (i.e. not auto-login) and after about 10 seconds this keyring dialog pops up. Wireless is already working by this time, and continues to work even if you cancel the dialog.

I have tried in Passwords & Keys setting both default and login passwords to the same, but this made no difference.

I can't help thinking that the only reason we don't have thousands of people complaining about this, is that most people just blindly enter the password and don't worry too much about it.

The popular workaround seems to be to remove the password altogether from the keyring, and thus do away with security altogether. I appreciate that we all think the bugs that affect us are a priority, but I am surprised this only warrants a low priority tag, given the security implications.

Sure, let's just type in our password in any misterious popup we get. Hello Windows users!
I don't have auto-login, I don't have wireless, and I sure didn't ask it to remember any passwords of mine.
It's for security, so it's supposed to act secure and be very clear about what's going on!

markling (markling) wrote :

This problem has arisen periodically for years. It has just arisen again on my computer. I've been running Xubuntu 13.04 since April. It just now started to ask me for a keyring password.

It says (and apologies - I shall have to report the precise message at next startup) - it says something like 'keyring password not set at startup'.

The keyring password request occurs apparenlty randomly. And when it comes it prevents user access to all other programs. Unless you shut down the computer, you have to give it your system password.

I second Alroger: this is most offensive behaviour. I don't want to give my password out to any popup - especially one that is random, erroneous and unexplained. Every time it happens I feel like I'm being fleeced by some phishing scam.

I suspect it may have something to do with the Ubuntu Software Centre.

The keyring problem started happening after I accessed the Software Centre's user account recently. It asked for a keyring password. It came up again when subsequently I opened the Software Centre just to download some software. And now it has stuck around. The kering just pops up at random in a session. It's been a few days, at a guess.

markling (markling) wrote :

Further info.

The keyring password request started appearing after I opened a Software Centre account. It seems to appear when the Software Updater runs.

This might suggest - in relation to kwill's question - that the problem is related to different passwords.

The Software Centre asks for a new username and password. The request is for a low security setting: a software feeback forum on the web. It is sensible to give it a password other than your primary/root password. It is therefore most likely to be different to your keyring password.

This, by the way, is the only time the system ever makes mention of a keyring password. The request for a keyring password is meaningless to the user. The error is therefore twofold: a failure of the Update and password manager - if, that is, they are indeed using a software forum password for software updates; and a failure of the user interface/experience - in that the request for a keyring password is a breakdown of usual user protocol.

markling (markling) wrote :

That was nonsense, what I said about Tor. It's not Tor at all.

Bryce Nesbitt (bryce2) wrote :

This seems to still be an issue: and it's a serious issue when a semi public computer is involved, as those using the computer won't know the password.

It is also a problem to train users to enter their password when a prompt box comes up: that's just ripe for abuse.

See also:
http://askubuntu.com/questions/867/how-can-i-stop-being-prompted-to-unlock-the-default-keyring-on-boot

---
Better and more secure the above cases is a mode for gnome-keyring "never prompt".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.