Very slow logout caused by gnome-keyring-daemon

Bug #427118 reported by Maxim Levitsky on 2009-09-10
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
GNOME Keyring
Fix Released
Medium
gnome-keyring (Ubuntu)
Low
Ubuntu Desktop Bugs
Karmic
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-keyring

After updating to karamic I have noticed that logout is very slow, like if system was waiting on some timeout
No disk activity was observed.

I found out that if I disable 'GNOME Keyring Daemon' in startup application, this problem goes away

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

summary: - Very slow logout caused by gnome key ring daemon
+ Very slow logout caused by gnome-keyring-daemon
Changed in gnome-keyring (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Changed in gnome-keyring (Ubuntu):
milestone: none → ubuntu-9.10
Changed in gnome-keyring (Ubuntu Karmic):
status: New → Confirmed
Chris Coulson (chrisccoulson) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=595698

Changed in gnome-keyring (Ubuntu Karmic):
status: Confirmed → Triaged
Changed in gnome-keyring:
importance: Undecided → Unknown
status: New → Unknown
Changed in gnome-keyring:
status: Unknown → New
Maxim Levitsky (maximlevitsky) wrote :

This appears to be fixed.

I did enable this daemon, but no delays observed now.
Maybe it just doesn't trigger

Sebastien Bacher (seb128) wrote :

still seeing the issue on karmic there

Sandro Mani (sandromani) wrote :

Issue still present here too.

Tormod Volden (tormodvolden) wrote :

I can reproduce this on a normal daily-live, so it is not an exotic issue. With all the work that has been put into karmic to make quicker shutdowns, it is a pity this bug ruins it all. I see there is no reaction upstream, but has anyone some idea what can be the reason for this issue? Should we look into a workaround for Karmic already, or will an upstream fix be accepted even if it arrives after karmic freeze or release?

Changed in gnome-keyring (Ubuntu Karmic):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-keyring - 2.28.0-0ubuntu2

---------------
gnome-keyring (2.28.0-0ubuntu2) karmic; urgency=low

  * debian/patches/90_upstream_change_fix_timeout_issue.patch:
    - upstream change to fix a timeout issue on session closing
      (lp: #427118)

 -- Sebastien Bacher <email address hidden> Mon, 05 Oct 2009 15:04:31 +0200

Changed in gnome-keyring (Ubuntu Karmic):
status: Fix Committed → Fix Released
Changed in gnome-keyring:
importance: Unknown → Medium
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.