gnome-keyring-daemon causes xfce4 startup to hang

Bug #316222 reported by Mario Limonciello
18
Affects Status Importance Assigned to Milestone
GNOME Keyring
Fix Released
Critical
Xfce4 Session
Won't Fix
Unknown
gnome-keyring (Ubuntu)
Fix Released
High
Ubuntu Desktop Bugs
xfce4-session (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: gnome-keyring

WIthin the last few days, the mythbuntu and xubuntu daily live disks started to boot up to a blank screen. It looks like something in gnome-keyring-daemon is causing problems.

You can still press alt-f2 to bring up the xfce "start application dialog". If you run "killall gnome-keyring-daemon", the rest of the desktop continues to boot in either case.

Revision history for this message
Mario Limonciello (superm1) wrote :
description: updated
Changed in gnome-keyring:
importance: Undecided → High
status: New → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

thank you for your bug report, don't confirm your own bugs. what ubuntu version do you use?

Changed in gnome-keyring:
assignee: nobody → desktop-bugs
status: Confirmed → Incomplete
Revision history for this message
Sebastien Bacher (seb128) wrote :

the issue seems similar to bug #316070

Revision history for this message
Mario Limonciello (superm1) wrote : Re: [Bug 316222] Re: gnome-keyring-daemon causes xfce4 startup to hang

I had marked it confirmed because it was on both Xubuntu and Mythbuntu daily
jaunty disks (2 verifications). Sorry.

As indicated in the description, these are the daily disks for 9.04 over the
last few days (likely after the 1-8 upload).

On Mon, Jan 12, 2009 at 07:02, Sebastien Bacher <email address hidden> wrote:

> the issue seems similar to bug #316070
>
> --
> gnome-keyring-daemon causes xfce4 startup to hang
> https://bugs.launchpad.net/bugs/316222
> You received this bug notification because you are a member of
> Mythbuntu, which is a direct subscriber.
>

--
Mario Limonciello
<email address hidden>

Revision history for this message
Sebastien Bacher (seb128) wrote :

could you open the bug on bugzilla.gnome.org where the people writting the code will read it? you can easily reply to their comment since you have systems which trigger the bug

Revision history for this message
Mario Limonciello (superm1) wrote :

I'm not sure it's necessarily an upstream bug. This started being included which may have triggered it:
  * debian/gnome-keyring.install:
    - inclusion of
      debian/tmp/usr/share/gnome/autostart/gnome-keyring-daemon.desktop.

Changed in gnome-keyring:
status: Unknown → New
Revision history for this message
Sebastien Bacher (seb128) wrote :

The file described there is a new upstream desktop installed by make install too, they just changed the way gnome-session is starting gnome-keyring

Changed in gnome-keyring:
status: Incomplete → Triaged
Changed in gnome-keyring:
status: New → Confirmed
Revision history for this message
Sebastien Bacher (seb128) wrote :

upstream needs details on the issue if somebody gets the bug and want to reply to their comments on bugzilla that would be a good start to debug the issue

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package xfce4-session - 4.4.3-0ubuntu2

---------------
xfce4-session (4.4.3-0ubuntu2) jaunty; urgency=low

  * Add 09_gnome_keyring_daemon_2_25_compat.patch which prevents
    xfce4-session from spawning gnome-keyring-daemon on it's own.
    It gets spawned by PAM during login, so it shouldn't be started
    again by XFCE. (LP: #316222)

 -- Mario Limonciello <email address hidden> Tue, 13 Jan 2009 15:18:45 -0600

Changed in xfce4-session:
status: New → Fix Released
Revision history for this message
Mark__T (mark-trompell) wrote :

For me it looks like a bug in gnome-keyring, if it doesn't prevent things like this, or handles that gracefully,
so please file a bug upstream.

Revision history for this message
Cody A.W. Somerville (cody-somerville) wrote :

Ugh... which upstream Mark? Cause if you had looked, we've already filed bugs in both Xfce4 upstream and Gnome upstream.

Changed in gnome-keyring:
status: Confirmed → Fix Released
Revision history for this message
Sebastien Bacher (seb128) wrote :

the bug has been fixed upstream now

Changed in gnome-keyring:
status: Triaged → Fix Committed
Revision history for this message
johnw (johnw.mail) wrote :

After upgrade to jaunty/xubuntu, i have this problem too.
and i can not upgrade xfce4-session to 4.4.3-0ubuntu2, do not know why.
please help.

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

If you are using Xubuntu Jaunty 9.04 updated as of 2009-02-08, you are upgraded to Xfce 4.6RC. This is the reason you can not upgrade to xfce4-session. xfce4-session is already at 4.4.3.

apt-cache policy xfce4-session
xfce4-session:
  Installed: 4.4.3-0ubuntu3
  Candidate: 4.5.99.1-0ubuntu1
  Version table:
     4.5.99.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com jaunty/universe Packages
 *** 4.4.3-0ubuntu3 0
        100 /var/lib/dpkg/status

Please run apt-cache policy xfce4-session to see if you are fully up to date.

Revision history for this message
johnw (johnw.mail) wrote :

Hi Charlie, when i run apt-cache policy xfce4-session, the output like this:

xfce4-session:
已安裝:4.4.3-0ubuntu1~intrepid1
  候選:4.5.99.1-0ubuntu1
  版本表格:
     4.5.99.1-0ubuntu1 0
        500 http://tw.archive.ubuntu.com jaunty/universe Packages
 *** 4.4.3-0ubuntu1~intrepid1 0
        100 /var/lib/dpkg/status

Anyway, how can i solve it?
Please help, thank you.

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

@register88: You ned help in a forum or mailing list to configure the system correctly. If you are using Jaunty 9.04, you should not have intrepid files in use. Perhaps you need to manually update /etc/apt/sources.list . This is not the correct place to be asking "how do I?" questions. This is for bug reporting. You do not appear to have a bug issue, but a configuration issue.

Revision history for this message
johnw (johnw.mail) wrote :

Ok, my xubuntu/amd64 is from 8.10 upgrade to 9.04, and my /etc/apt/sources.list is changed from intrepid to jaunty.
(s/intrepid/jaunty/g)

So, maybe it is bug(s), the apt/package not update/upgrade correctly.

Anyway, can you get me some tips, if you know how to solve it.
Please help, thank you again.

Revision history for this message
Charlie Kravetz (charlie-tca) wrote :

Okay, this is what I have:
apt-cache policy xfce4-session
xfce4-session:
  Installed: 4.4.3-0ubuntu3
  Candidate: 4.5.99.1-0ubuntu1
  Version table:
     4.5.99.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com jaunty/universe Packages
 *** 4.4.3-0ubuntu3 0
        100 /var/lib/dpkg/status

This is what you have:
xfce4-session:
已安裝:4.4.3-0ubuntu1~intrepid1
  候選:4.5.99.1-0ubuntu1
  版本表格:
     4.5.99.1-0ubuntu1 0
        500 http://tw.archive.ubuntu.com jaunty/universe Packages
 *** 4.4.3-0ubuntu1~intrepid1 0
        100 /var/lib/dpkg/status

Please note that I do not have 已安裝:4.4.3-0ubuntu1~intrepid1 . This is an error in you sources.list. You are installing or need to remove intrepid components. Please check your /etc/apt/sources for lines with intrepid in them. They need to be changed to jaunty. Then run "sudo apt-get update" and "sudo apt-get dist-upgrade" to attempt to fix this.

Revision history for this message
Sebastien Bacher (seb128) wrote :

the new version is in jaunty now

Changed in gnome-keyring:
status: Fix Committed → Fix Released
Changed in xfce4-session:
status: Unknown → Won't Fix
Changed in gnome-keyring:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.